Radio and code 32 problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Radio and code 32 problem

Old Man Emu WK Lift - Black Friday Special!!The Original 3/8" Ruffstuff Diff Cover!Safety Thimble Fairleads

Reply
Unread 12-12-2012, 09:09 PM   #1
ninjastar
Registered User
1993 ZJ 
 
Join Date: May 2010
Location: Carson,CA
Posts: 548
Radio and code 32 problem

Hi you guys, havent been here on a while since I left on military buisness and just came back on Nov16.

Well my jeeps has been used once a week since I been gone and I have been driving it the past two weeks that I have been back and just yesterday, the radio wouldnt turn on anymore and as well since I been driving the radio has been turning on a tad bit slow when the jeep is turnered on. I checked the fuse on the side pannel fues 8,10,11,15 are all good and the cigerette lighter works, so other than checking if theirs power to it, I dont know whats wrong.

As for the cel code 32, its been happening for a while and 9 months ago before I left I been getting this code and I just want to fix this because its just bugging the sh out of me.

ninjastar is offline   Reply With Quote Quick reply to this message
Unread 12-13-2012, 08:58 AM   #2
HighLonesome
Belief In All Things Jeep
 
HighLonesome's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Mexico
Posts: 5,802
EGR transducer and solenoid assy likely will fix the code 32. It did for me anyway. You may need to remove the intake manifold and clean out the EGR ports too.

If the radio is turning on 'slow' and all else is well, I'd guess the radio.
HighLonesome is offline   Reply With Quote Quick reply to this message
Unread 12-13-2012, 05:17 PM   #3
ninjastar
Registered User
1993 ZJ 
 
Join Date: May 2010
Location: Carson,CA
Posts: 548
I replaced the whole entire erg before I left and my jeep passed the smog check, so I dont know whats wrong.

I never knew a radio could go bad.
ninjastar is offline   Reply With Quote Quick reply to this message
Unread 12-13-2012, 06:50 PM   #4
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
A second note for CA emissions...

KoreaZJ is offline   Reply With Quote Quick reply to this message
Unread 12-14-2012, 10:09 AM   #5
ninjastar
Registered User
1993 ZJ 
 
Join Date: May 2010
Location: Carson,CA
Posts: 548
So how would I go about doing that and if I passed the smog check wouldnt that mean things are in order?
ninjastar is offline   Reply With Quote Quick reply to this message
Unread 12-14-2012, 10:27 AM   #6
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,794
Quote:
Originally Posted by ninjastar View Post
I replaced the whole entire erg before I left and my jeep passed the smog check, so I dont know whats wrong.

I never knew a radio could go bad.
Radios go bad all the time. They're not self repairing miracle machines.

I'd check the wiring for the egr
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote Quick reply to this message
Unread 12-19-2012, 09:03 PM   #7
ninjastar
Registered User
1993 ZJ 
 
Join Date: May 2010
Location: Carson,CA
Posts: 548
Got a new radio and man my sound system sounds great.

If i changed the whole entire egr wouldnt that solve the problem.
ninjastar is offline   Reply With Quote Quick reply to this message
Unread 12-20-2012, 09:15 AM   #8
HighLonesome
Belief In All Things Jeep
 
HighLonesome's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Mexico
Posts: 5,802
Quote:
Originally Posted by ninjastar View Post
Got a new radio and man my sound system sounds great.

If i changed the whole entire egr wouldnt that solve the problem.
Probably. Not sure if plugged ports inside the intake manifold can cause a CEL.
HighLonesome is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.