Radiator issue 1997 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Radiator issue 1997

Labor Day Sale!FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 06-18-2013, 10:29 AM   #1
bigislandhikers
Registered User
1989 XJ Cherokee 
 
Join Date: Jun 2010
Location: Michigan
Posts: 145
Radiator issue 1997

Got a call from my daughter that she had a radiator hose blow off. When I got there the top hose had indeed come off. I noticed that the small raised ring on the inlet nozzle had snapped off cleanly. Seems like the clamp wasn't real tight either. I replace the hose and topped off the fluid.

Started up fine and I drove about 10 miles and it held together.

Am I looking at a new radiator or can it get by without this ring to hold the hose on? Maybe use two clamps instead of one?


Another question dealing with this. It was definitely low of fluid but the overflow container was at a normal level. Any guess why this would be?

Thanks
BIH

bigislandhikers is offline   Reply With Quote
Unread 06-18-2013, 10:36 AM   #2
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, MD
Posts: 15,993
The overflow container rises and falls according to the motor temp. I would go ahead and replace the radiator. Even with 3 clamps on there it would worry me since that will leave you stranded. Also it appears that the plastic is weakened. It could happen again.
PolkaPower is offline   Reply With Quote
Unread 06-18-2013, 11:06 AM   #3
OldManTan
Registered User
1998 ZJ 
 
Join Date: Feb 2013
Location: Redlands, Ca
Posts: 246
You may have bigger problems that just a shetty worm clamp.

Was the truck running hot before the hose blew off? Mine got to around 230-240 before this happened...

further investigation showed me that my clutch fan was shot and my radiator was in piss poor condition.

new radiator and e fan swap did the trick for me.

haha

hope you dont have to make such a drastic fix.
zj.jpg   rad.jpg  
OldManTan is offline   Reply With Quote
Unread 06-18-2013, 12:19 PM   #4
bigislandhikers
Registered User
1989 XJ Cherokee 
 
Join Date: Jun 2010
Location: Michigan
Posts: 145
Quote:
Originally Posted by OldManTan View Post
You may have bigger problems that just a shetty worm clamp.

Was the truck running hot before the hose blew off? Mine got to around 230-240 before this happened...

further investigation showed me that my clutch fan was shot and my radiator was in piss poor condition.

new radiator and e fan swap did the trick for me.

haha

hope you dont have to make such a drastic fix.
She said it wasn't running hot at all. I drove it this weekend and it was below 210 to whole time, even with the air on.
bigislandhikers is offline   Reply With Quote
Unread 06-18-2013, 05:34 PM   #5
coralman
green backs to no backs
 
coralman's Avatar
1998 ZJ 
 
Join Date: Jul 2010
Location: florida
Posts: 4,338
Yeah if the pressure snapped that off I would replace the radiator. Is it the original one? Mine did the thing with the coolant bottle once. A brand new radiator cap was bad and didn't allow the fluid to enter the radiator in the cool down cycle. Replaced the cap and all was well. Kinda sounds like in a way your cap is bad.
__________________
Move over bear.I'm tired of working on the jeep

Links to axle rebuilds, mount replace,a/c box rebuild,ect in history section of my profile page
coralman is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.