Quadratrac Equipped Trans Question - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Quadratrac Equipped Trans Question

Spartan Locker Promo Running now @ ROCKRIDGE 4WD plus FREEG2 Disc Brake Conversion Kit for Jeep Wrangler YJ TJ LJ ChSave 15% in XT's Pre-Black Friday Event!

Reply
Unread 05-10-2004, 09:01 AM   #1
kampster
Registered User
 
Join Date: May 2004
Posts: 5
Quadratrac Equipped Trans Question

Hello Everyone,
First time Jeep owner here. My question relates to a humming noise coming from the trans whenever it's either in drive or reverse, but not when it's neutral or park. Is this normal? It shifts fine, doesn't slip and the fluid looks very clean. Just wondering if anyone else has this issue, if it is indeed even an issue. Thanks in advance. I guess I should also mention that it's a '94 Limited with the 5.2 and I believe it has the tow package, as it's equipped with a trans cooler.


Last edited by kampster; 05-10-2004 at 09:05 AM..
kampster is offline   Reply With Quote Quick reply to this message
Unread 05-10-2004, 09:41 AM   #2
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha, NE
Posts: 20,133
This "noise" is it when the vehicle is moving? or still?

Have you ever had the fluid changed? Have you checked the tranny fluid level?

Hunter
__________________
00 4.7 Laredo...stock

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4
http://www.kevinsoffroad.com/
602.841.3355

For your performance needs:

kolak@kolakperformance.com
480.998.3661
Texas ZJ1 is offline   Reply With Quote Quick reply to this message
Unread 05-10-2004, 10:00 AM   #3
kampster
Registered User
 
Join Date: May 2004
Posts: 5
Quote:
Originally Posted by Texas ZJ1
This "noise" is it when the vehicle is moving? or still?

Have you ever had the fluid changed? Have you checked the tranny fluid level?

Hunter
It’s more noticeable when not moving, perhaps simply because while moving it may be drowned by road noise. The level is dead on and the fluid looks practically brand new, nice and pink. Thanks for the quick reply by the way.
kampster is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.