PS pressure hose working loose -

LinkBack Thread Tools
post #1 of 2 Old 02-03-2013, 01:57 AM Thread Starter
Web Wheeler
2002 WJ 
Join Date: Apr 2007
Location: UK
Posts: 3,714
PS pressure hose working loose

A few months ago I suddenly lost power assistance on my steering just as I was pulling into the car park at work. Turned out that the pressure hose had come loose where it screws into the pump and sprayed fluid everywhere. Replaced the O-ring, tightened it back down and everything was fine.

This morning I noticed that it had started working loose again, but I caught it early this time, so I'd only lost a small amount of fluid. It's no big deal to re-tighten it every so often, but is this actually a symptom of a bigger problem that I need to deal with, or just a Jeep thing?

AVR2 is offline  
Sponsored Links
post #2 of 2 Old 02-03-2013, 01:56 PM
coralman's Avatar
1998 ZJ 
Join Date: Jul 2010
Location: florida
Posts: 7,479
Thats freaky! If the hose is in a bind maybe its putting tension on the fitting? Not much room to put it in wrong though. I'm stumped on this one.

Info on projects and repairs categorized by system

Originally Posted by HighLonesome
lol...if life is as a simple as a 5.9 making you happy, I'd say go ahead and buy it on impulse. ZJs are the way of Zen. Wax on, wax off
coralman is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome