Problems with 96 Grand Cherokee zj - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 09-26-2009, 10:54 AM Thread Starter
kabrewski
Registered User
1996 ZJ 
 
Join Date: Jun 2009
Location: Nashville
Posts: 32
Problems with 96 Grand Cherokee zj

so its a 96 jeep grand cherokee v8 and theres a few things that came to my attention.

1. When i shift to 4 low or N i let it roll at 3-4 kmph in neutral and shift the transfer case down firm and quick and once its in 4 low or N i press on the gas and it just rev's but when i put it back to 4 hi it works fine.

2. Kenwood deck is not working properly, there is no power to the deck. While im driving its off 80% of the time and doesnt light up or anything but randomly it will turn on while driving and work fine but once it turns on when i turn on the radio it will shut back down like it cant deal with the power.

3. The seat belt light goes on when i start the engine but if i DON'T buckle any seat belt it goes off within 3 seconds of it being on. Will this effect me taking it for a safety inspection.

4. The steering feels very loose, while turning it feels unstable, i plan to lift it with a 3.5 IRO lift in the next month with new rancho shocks and a OME steering stabilizer, would this fix the problem.


Any answers would be greatly appreciated.

Kabrewski

kabrewski is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-26-2009, 11:04 AM
ZeJokee
Registered User
1993 ZJ 
 
Join Date: Nov 2008
Location: Kansas City
Posts: 1,492
MY friends 93 Zj had very loose steering, we thought it was the stabilizer or something worn out in the steering. We replaced the stabilizer and a week later the gear box blew up. HE replaced that now his steering if fine.

99 WJ Ltd, Blacked out, 4.7L, 242j Swap, 2'' BB, 245/75/16 Kuhmo Venture AT KL78, Flow Master Super 40, MagnaFlow high flow Cat, Akebono caliper upgrade, Addco rear swaybar, Westin brush guard, Moog Super Trail Boss, Rancho RS5000, Rola roof rack with dual kayak J hooks, PAC-AOEM-CHR, Sony Xplod 1200w amp, 2 Sony Xplod 12'' subs, 118,XXX miles (SOLD)
93 ZJ Ltd, Blacked out, 5.2L, Reman 46RH, Reman 242 Swap, 3.5'' IRO + 2" BB, 33x12.50r15 Mud Claw MTX radials, Bushwacker Flares, 216,XXX miles (Still parked in NC)
04 F-350 SD Crew Cab FX4 Lariat, 6.0 PSD SRW, Head studs, AFE Stage 2 SI Pro Guard 7 intake, Blue Spring mod, 150,XXX Miles

ZeJokee is offline  
post #3 of 3 Old 09-26-2009, 04:19 PM
urq2
Registered User
 
Join Date: Sep 2009
Location: California
Posts: 31
.
urq2 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
94 Grand Cherokee Problems HELP! staygold123 ZJ Grand Cherokee Forum 1 09-04-2009 02:37 PM
grand cherokee problems?? erikgenerik WK Grand Cherokee & XK Commander Forum 2 06-12-2008 09:38 AM
06 Grand Cherokee HID problems pakhung99 WK Grand Cherokee & XK Commander Forum 14 02-06-2007 08:27 AM
'97 Grand Cherokee, any problems? AllanB ZJ Grand Cherokee Forum 7 05-09-2005 08:07 PM
99 Grand Cherokee Fan Problems capps WJ Grand Cherokee Forum 2 08-30-2003 10:48 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome