Problem w/ factory tow harness - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 07-18-2011, 08:05 AM Thread Starter
jjeep
Registered User
1998 WJ 
 
Join Date: Jul 2011
Location: Gaithersburg
Posts: 5
Problem w/ factory tow harness

I have a 98 jeep grand cherokee larado with the factory tow harness. Problem is I have no turn, or stop lights, just tail and marker. I have replaced all relays. I am not seeing any voltage on the pink/black stripe wire. Where the tow harness connects to the full harness at the full harnes side. I suspect this wire is the power that the relay is connecting. I can't locate the pink/blk in any fuse box.

The 50 AMP tow/mux fuse in the engine comp. is also good.
The breaker in the harness also has continuity.

At my factory connector -
Blu/Red - Tail lights
Grn - Left Signal
Tan - Right Signal
Wht/Tan - Brake
Light Blu - Electric Brake
Blk - Grnd
Pink/Blk - Power for lights thru relay ? (I have no voltage here)

What is the routing for the Pink/Blk? Test points?
Is there a fuse or relay I am missing?
Thanks this is driving me nuts!

jjeep is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 07-18-2011, 08:17 AM
Foundrydude
Registered User
1995 ZJ 
 
Join Date: Jan 2011
Location: Flatsville
Posts: 2,689
The factory tow light module for your truck should be behind the driver's side cargo area panel, it combines the turn/stop lamps for the trailer. Are your trailer brakes factory, or does the truck have an aftermarket controller?

There's an extra on the round 7 pin design (purple). Some people use it for reverse lights. But you don't have to use it at all and not all trailers have reverse lights anyway. Is that your pink/black?

I am confused by you listing 7 pins but having one pin for stop, and two others for turn. At the trailer those signals have been unified by the module mentioned previously, and only occupy two pins.

If you're lacking turn/stop, then green and tan are what you should be looking at. If the truck's got voltage at green or tan with signals/brakes on then your problem's in the trailer. Lots of times when a friend calls me over to sort out his truck's trailer wiring we end up fixing the trailer.

Here's a link that shows standard color coding for trailer wiring.
http://www.etrailer.com/faq-wiring.aspx



good luck!
Foundrydude is offline  
post #3 of 9 Old 07-18-2011, 01:05 PM Thread Starter
jjeep
Registered User
1998 WJ 
 
Join Date: Jul 2011
Location: Gaithersburg
Posts: 5
Hey Thanks for the response.

The rear driver side panel is where I found the 3 relays I replaced.
The harness is factory.
No aftermarket controller.

Colors for signals into the relays -
Grn - Left Signal (turn)
Tan - Right Signal (turn)
Wht/Tan - Brake (stop)

These are working I have voltage when the signals are activated.

The wires that leave the relays and go to the trailer are not showing voltage at the relay when they should.

There should be a supply wire that is hot going into the relay, when the signal wire (Lt Grn - left turn) has voltage it throws the relay switch and the voltage from the supply wire heads to the lights. I believe the pink wire supply that voltage and it is not hot but I don't know why? I think this is the same circuit that come in on the pink/blk from the jeep vehicle harness which is also not hot but should be (I think) or I am completly wrong.

The ground is good to the tailgate latch so thats not the problem.
jjeep is offline  
 
post #4 of 9 Old 07-18-2011, 01:17 PM
Foundrydude
Registered User
1995 ZJ 
 
Join Date: Jan 2011
Location: Flatsville
Posts: 2,689
You may have a bad tail lamp converter module. They're available aftermarket for $25 if you don't mind soldering. Fair number of people on this board have em fail.
Foundrydude is offline  
post #5 of 9 Old 07-18-2011, 01:37 PM Thread Starter
jjeep
Registered User
1998 WJ 
 
Join Date: Jul 2011
Location: Gaithersburg
Posts: 5
Where is the tail lamp converter module?

Thanks
jjeep is offline  
post #6 of 9 Old 07-18-2011, 01:42 PM
Foundrydude
Registered User
1995 ZJ 
 
Join Date: Jan 2011
Location: Flatsville
Posts: 2,689
I believe the module itself is behind the cargo area service door, but on your 98 it plugs into wiring that's behind the passenger side cargo panel. Black box, bout the size of a pack of smokes. A quick search for trailer wiring should pull up several threads.

Note that 95-earlier had a different module that plugs in at a different point. So take your advice or junkyard parts from a 96-up.

Good luck!
Foundrydude is offline  
post #7 of 9 Old 07-18-2011, 02:00 PM Thread Starter
jjeep
Registered User
1998 WJ 
 
Join Date: Jul 2011
Location: Gaithersburg
Posts: 5
Is there anyway to test it?
jjeep is offline  
post #8 of 9 Old 07-18-2011, 02:10 PM
Foundrydude
Registered User
1995 ZJ 
 
Join Date: Jan 2011
Location: Flatsville
Posts: 2,689
I think if there's correct power going in, but not correct power coming out.....that's the test.
Foundrydude is offline  
post #9 of 9 Old 07-18-2011, 03:46 PM Thread Starter
jjeep
Registered User
1998 WJ 
 
Join Date: Jul 2011
Location: Gaithersburg
Posts: 5
Okay.

I searched but have not come up w/ much info on a tail lamp converter module.

Just to confirm - This is different from the three relay pack I found behind the driverside rear panel? Which is also about the sz of smokes. I am really getting tired of taking the interior apart! Who's idea was it to put these on opposite sides?

Thanks for the info.
jjeep is offline  
Reply

Tags
harness , pink , relay , tow

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Help please with installation of factory trailer harness DarrylFlynn WK Grand Cherokee & XK Commander Forum 20 02-13-2009 12:55 AM
wiring harness / factory amp not2high ZJ Grand Cherokee Forum 4 07-14-2008 11:20 AM
WTB factory trailer harness WJ Btm495 ZJ Grand Cherokee Forum 11 04-03-2008 08:08 PM
Non Factory Tow Harness 4 My JEEP PresTx82 ZJ Grand Cherokee Forum 5 06-13-2007 01:50 PM
Factory hitch and wire harness pbesanson ZJ Grand Cherokee Forum 2 02-03-2002 10:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome