Problem with starter?? hmm - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Problem with starter?? hmm

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineGrizzly Lockers available at Rockridge4wd.comThe ULTIMATE "Selectable" Locker System! Brough

Reply
Unread 05-11-2013, 06:22 AM   #1
Angutittussen
Registered User
 
Join Date: May 2013
Location: Nuuk, DK
Posts: 1
Problem with starter?? hmm

Hello,

I have a Jeep Grand Cherokee, 1996, V8, Limitied, 5,2, 8V. I have had problem with my car at the last period. Last week, when I tried to start the car, it will not start and did just click sound. I was thinking that it could be the battery that has run out of power, so i tried to start the car with jumper cable, and it started, I thought the problem was solved.

But the day after it will not start, same problem, click sound. And i had to start it with jumper cables again. Well when i drive the car i dont have any problems with light or other electronically and things.

I deliver the car to the workshop which was fast suspect that it is problem with the generator. When the workshop called me, and tell me that the they have fix my car, the told me when i picket up, that they have repaired the generator and has changed coal.


But this morning when I tried to start the car, it will not start. When I came home after work, I tried starting it again and it fails. But when I was going to start it with jumper cables, thinking I just want to try to start it, and it started it without using jumper cable.

the problem come, I have also experienced several times that the car starts when I turn the key back and forth in the ignition key.

And i just bought new battery, and its doesnt help.

But it often starts first with the jumper cable

What could be the problem? hope you can help.

What could the problem be? Battery? start?

Sorry about my english :-)

Angutittussen is offline   Reply With Quote Quick reply to this message
Unread 05-11-2013, 07:28 AM   #2
SpenceAK
Registered User
1995 ZJ 
 
Join Date: Sep 2012
Location: Anchorage, Alaska
Posts: 182
sounds to me like you have a parasitic drain.
SpenceAK is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.