Power door lock motors work but no lock! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Power door lock motors work but no lock!

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSteinjager TJ tube doorsAttention to the TJ owners 1996-2006 NEW LED LIGHT OPTIONS

Reply
Unread 10-25-2009, 09:53 AM   #1
lasvegas
Registered User
1995 ZJ 
 
Join Date: Oct 2009
Location: california
Posts: 96
Power door lock motors work but no lock!

Anyone heard of this? When I push the Lock/Unlock button, the motors run but don't do anything except for the back hatch. I'm thinking someone disconnected them but why all 4 doors and not the hatch? I know...sounds stupid but just curious. Also, does anyone know where to find replacement remotes for the car? It is a 1995 4.0 JGC Laredo? Thanks!

lasvegas is offline   Reply With Quote
Unread 10-25-2009, 09:58 AM   #2
Izzy
Registered User
1997 ZJ 
 
Join Date: Oct 2006
Location: Kent, WA
Posts: 110
Each door has a solenoid (spelling?). It is probably burned out. When mine failed, they made a noise like they were working, but wouldn't lock. Try searching here, e-bay, or a local pick-n-pull. They can be expensive unless you find a used one. I have replaced two of mine so far with used ones and had no problems.

Good luck!
Izzy is offline   Reply With Quote
Unread 10-25-2009, 12:29 PM   #3
lasvegas
Registered User
1995 ZJ 
 
Join Date: Oct 2009
Location: california
Posts: 96
Thanks for the input
lasvegas is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.