post tuneup problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > post tuneup problems

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineVisit 1aauto.com For ShockTober Deals on Monroe shocks andAdvance Adapters SYE Kits

Reply
Unread 05-08-2009, 05:57 AM   #1
spikeystrip
Registered User
1993 XJ Cherokee 
 
Join Date: Oct 2007
Location: eastern PA
Posts: 88
post tuneup problems

i just did a tuneup on my 95 grand cherokee 5.2. i replaced cap + rotor, wires, and plugs. its runs a little rough at idle but i dont notice it until about 1700 rpm when it starts chugging and today it backfired through exhaust a couple times. i didnt have any of these symptoms before i did the tuneup. what do you think it could be? i checked the plug wires once already and these seemed to be in right spot but ill check again

__________________
1993 cherokee country.
Rustys 5inch lift
firestone 31x10.5 w/ cragar d windows
1995 Grand Cherokee
Stock Daily Driver
AWD 5.2 V8
spikeystrip is offline   Reply With Quote
Unread 05-08-2009, 06:51 AM   #2
dobe
Registered User
1999 XJ Cherokee 
 
Join Date: Apr 2004
Location: PA.
Posts: 108
That would be my first guess, crossed wires.

Make sure you didn't break something or pull a vac line off while doing tune up.

Any codes ?
dobe is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.