Possible WJ 545RFE Issue? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Possible WJ 545RFE Issue?

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineOld Man Emu WK Lift - Black Friday Special!!

Reply
Unread 10-26-2009, 07:28 PM   #1
WiCkeDuDe
Web Wheeler
 
WiCkeDuDe's Avatar
2002 WJ 
 
Join Date: Dec 2007
Location: Utah
Posts: 3,115
Possible WJ 545RFE Issue?

Hey guys looking for some advice from some guys that know alot more than I do about automatic transmissions. I have a 02 V8 WJ with a the 545RFE and 107k on it.

Every once in a awhile I will start it up and put it in gear and it acts like nothing happened. It then seems like if I push the gas pedal it barely wants to move. When I give it a bit more gas then it moves and goes normally. I have no other issues with the tranny. Other times as soon as I put it in drive or reverse you can feel it engage and want to move but cant since my foot is on the pedal.


Can anyone tell me what this could be?

Before you ask yes the fluid is topped off and I just did a tranny flush replacing both filters and filled using mopar ATF4+.

Thanks!

WiCkeDuDe is offline   Reply With Quote Quick reply to this message
Unread 10-26-2009, 07:53 PM   #2
Falkon
Registered User
2004 WJ 
 
Join Date: Jun 2009
Location: Wisconsin
Posts: 1,027
Mine does that once in a while. I was told it's an issue w/ the torque converter draining. In my case the trans shop said there is a little plunger inside the trans, and if it happens to set a certain way the converter drains & must refil before the Jeep moves.

I recall reading about this on other forums also, under delayed engagement I believe. Some threads...

http://www.jeepforum.com/forum/f67/t...roblem-356662/

http://www.jeepforum.com/forum/f13/9...gement-608494/
Falkon is offline   Reply With Quote Quick reply to this message
Unread 10-26-2009, 08:40 PM   #3
WiCkeDuDe
Web Wheeler
 
WiCkeDuDe's Avatar
2002 WJ 
 
Join Date: Dec 2007
Location: Utah
Posts: 3,115
Yeah this is exactly how it feels. Once it refills it is great. Is it supposed to do this though? Doesnt seem right. I did replace the spin on return filter with a dealer filter in July. I hadent noticed it before that but I just bought it too.

Tranny is perfect otherwise. Good to know it wont hurt anything.
WiCkeDuDe is offline   Reply With Quote Quick reply to this message
Unread 10-26-2009, 09:08 PM   #4
dougy147
Registered User
2007 JK Wrangler 
 
Join Date: Jan 2005
Posts: 651
Mine does that from time to time as well. Come to think of it, the 06 Altima I had did it as well.
__________________
The Past
95 ZJ Laredo 4.0
00 WJ Laredo 4.0 & 4.7
08 WK Laredo 4.7 (traded for tin can)
The Present
07 JK Unlimited Sahara
dougy147 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.