Possible cv shaft or front axle issue - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 04-28-2013, 01:49 PM Thread Starter
Registered User
1997 ZJ 
Join Date: Apr 2012
Location: Hammond
Posts: 573
clicking when turning

Got stuck in a mud hole today but only cause the front wheel stopped spinning in 4 low. I got pulled out of the hole and put it back in 4 all time, going straight it doesnt make a noise. turning to the left makes a clicking noise. I think its a cv shaft issue but would that cause the front wheels to stop spinning also?

good gas mileage is highly overrated.
booked101 is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome