Possible bad sounding 4.0L engine knock - JeepForum.com

 
LinkBack Thread Tools
post #1 of 10 Old 08-06-2013, 07:03 PM Thread Starter
RoldGold
Registered User
1996 ZJ 
 
Join Date: Jun 2013
Location: Philadelphia
Posts: 317
Possible bad sounding 4.0L engine knock

Excuse my ignorance, but this is my first car, and therefore my first Jeep. I noticed today that my Jeep was idling very high (1500rpm), but that is not the point of this thread, I think it might be the IAC or a dirty TB and haven't yet investigated. While it was idling at a high rpm, I noticed an unpleasant sounding knock/tap/tick from the engine. Granted I do have the inline 6, which has the supposed "from the factory piston slap", but since I don't know what the engine should sound like, its hard for me to make a judgement call on whether something is wearing out/worn out. If someone could take a listen and let me know what they think, I'd greatly appreciate it.

My engine only has 107k miles on it, and I know how high these 4.0's frequently clock, so I apologize if my concerns are unfounded, I'd just like to know for sure so the bottom end of my engine doesn't blow out while I'm driving.

In the video I rev the engine at about 30 seconds and again at a later time.

Let me know if this audio doesn't provide any conclusive results.

http://www.youtube.com/watch?v=lhhFw...ature=youtu.be


1996 Grand Cherokee Limited 4.0L
PSC Steering Gear; NP249 w/ new VC; Moog TRE's, Track Bar, Stabilizer bar bushings and endlinks, control arm bushings
Still no lift, and almost no paint on the hood
RoldGold is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 08-06-2013, 07:08 PM
dunkeye11
Registered User
1996 ZJ 
 
Join Date: Jun 2012
Posts: 789
Is it idling high at every stop or just at start?
dunkeye11 is offline  
post #3 of 10 Old 08-06-2013, 07:12 PM Thread Starter
RoldGold
Registered User
1996 ZJ 
 
Join Date: Jun 2013
Location: Philadelphia
Posts: 317
It doesn't idle high at either the start or at every stop. Normally after a 10-15 minute drive, after I've stopped and put it in park the engine revs up to 1100-1500rpm's and stays there steadily. I can give it some gas in park, and it'll still stay at that rpm. I can even put it in reverse or neutral and the resting rpm's are still high. But nonetheless, I am more concerned about the engine noise, as I think I am capable of diagnosing the bad idle speed.

1996 Grand Cherokee Limited 4.0L
PSC Steering Gear; NP249 w/ new VC; Moog TRE's, Track Bar, Stabilizer bar bushings and endlinks, control arm bushings
Still no lift, and almost no paint on the hood
RoldGold is offline  
post #4 of 10 Old 08-06-2013, 07:14 PM
BlazeB
Registered User
1995 ZJ 
 
Join Date: Jul 2013
Location: Thunder Bay
Posts: 10
My 95 has the same noise except mine only does it when idling, I also am a first time vehicle owner and I notice that you said that the zj's have a from facory pistion slap, so I am wondering if thats just whats wrong with mine or if I have the same problem. To me when your idling it sounds fine, but that could also be my bad speakers.
BlazeB is offline  
post #5 of 10 Old 08-06-2013, 07:27 PM
dunkeye11
Registered User
1996 ZJ 
 
Join Date: Jun 2012
Posts: 789
The video sounds pretty normal from the 4.0s my friends own and the ones I have driven

Clean the IAC and throttle body also look inside with a flashlight for oils or anything
dunkeye11 is offline  
post #6 of 10 Old 08-06-2013, 08:23 PM
jnowak
Registered User
1993 ZJ 
 
Join Date: Nov 2011
Location: dahlonega
Posts: 495
Sounds like an exhaust leak. Check your.exhaust looking for black at any connection. Also check.the collector at the base of the manifold. Bad about cracking ecpecially if you've got a bad motor mount.
Mine sounds about like that. These 4.0 are not the smoothest sounding engines. Put your mind at ease alitttle mine has 293k miles and sounds similar. Still running strong.
jnowak is offline  
post #7 of 10 Old 08-06-2013, 08:42 PM
98GCLimited
Registered User
1998 ZJ 
 
Join Date: Jun 2009
Location: LHC
Posts: 513
Sounds like you have a small exhaust leak, probably a cracked exhaust manifold very common issue on our 4.0s.

The knocking/ticking noise I could also hear. Mine is the same way. My uncle works as a master tech at the local Jeep dealership, I had asked him what he thought about the noise on my 4.0 and he said thats normal they are noisy engines.

Mine is still running strong at 144k miles, just sounds like a diesel at idle lol.
98GCLimited is offline  
post #8 of 10 Old 08-07-2013, 09:03 AM
driftwood00
Registered User
1995 ZJ 
 
Join Date: Apr 2009
Location: Hillsdale
Posts: 93
Mine sounds the exact same, a buddy of mine who is a master mechanic said that over half the 4.0's he has worked on have the same "knocking noise" he said they are just noisy engines. I have been driving mine this way for about 10,000 miles and it has gotten no worse or no better.

1995 JGCL
4.0L
4x4
driftwood00 is offline  
post #9 of 10 Old 08-11-2013, 02:30 AM
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 5,467
The deeper clanking im hearing is normal for a 4.0.. Every 4.0 I've seen makes that noise.... The light sounding tapping im hearing.. sound more like an exhaust issue.. check your tailpipe and muffler and cat and stuff.. I mean actually crawl under and look where the pipe meets the muffler and so forth... I had a cracked muffler where the tailpipe met and when it was idling it made a similer noise.. I thought it was the engine at first it freaked me out. Skip to 2:00 on the video youll hear it really good

In fact here is a video I made wondering the same thing almost 4 years ago lol this was prior to me knowing much at all about jeeps


this video is the crack on the muffler mine had

Candymancan is offline  
post #10 of 10 Old 08-23-2013, 10:13 PM Thread Starter
RoldGold
Registered User
1996 ZJ 
 
Join Date: Jun 2013
Location: Philadelphia
Posts: 317
Yeah my exhaust is pretty jury-rigged. It's got a lot of those cheap clamps and reduction pipes and what not. I'm not all that sure where the PO got the exhaust and catback from, but it's certainly got quite a few leaks. And if the numbers pressed into the bottom of the muffler correspond to the date, mine is a 1992. But I don't care, as long as it passes inspection/emissions I'm happy!

Thanks for the responses everyone, my mind is at ease now.

1996 Grand Cherokee Limited 4.0L
PSC Steering Gear; NP249 w/ new VC; Moog TRE's, Track Bar, Stabilizer bar bushings and endlinks, control arm bushings
Still no lift, and almost no paint on the hood
RoldGold is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome