please help!!!! 97 zj died and wont restart - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > please help!!!! 97 zj died and wont restart

NEW JK WRANGLER GRAB BARS NOW at ROCKRIDGE4WDThe Original 3/8" Ruffstuff Diff Cover!Offset Tie Rod Kit From RuffStuff!

Reply
Unread 04-01-2013, 04:38 AM   #16
Adam86
Registered User
1998 ZJ 
 
Join Date: Dec 2012
Location: Birmingham, England
Posts: 62
Easy way to find out if its your O2 wires is just to disconnect them. I had the same problem when l ripped my exhaust off.

Simply disconnected the O2 sensor next to the cat and replaced the fuse. Jeeped started first time. Tbh I'm still running with no O2 sensor connected as my mpg hasn't got any worse. 4.0 in my case.

Adam86 is offline   Reply With Quote Quick reply to this message
Unread 04-01-2013, 08:03 AM   #17
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,035
That fuse powers the PCM to supply the 5v necessary for all of the sensors that are monitored by the PCM. If the fuel pump runs continuously with the key on engine off, the fuse is either blown or you have fried the PCM. Locate the problem!!!!! Don't keep replacing the fuse or you will fry the PCM.
The sensors include the cam, crank, tps, map,engine coolant, engine air temp and trans sensor.
Check the routing of all the wires to those sensors and pay close attention to the o2 wire routing near the exhaust manifold. Many guys don't route the wires back to their original place when replacing parts.
JS97ZJ is offline   Reply With Quote Quick reply to this message
Unread 04-02-2013, 03:48 PM   #18
ryanlawhon
Registered User
1997 ZJ 
 
Join Date: Oct 2012
Location: el cajon, California
Posts: 63
so my fuel pump is running continuously and i noticed when i do have the key on the overdrive off button light stays on and no matter if i just push it for a second or i hold it it stays on. still nothing obvious that i can see both from under the hood and all the way under the jeep
ryanlawhon is offline   Reply With Quote Quick reply to this message
Unread 04-04-2013, 06:24 PM   #19
98lmtdJay
Registered User
 
Join Date: Mar 2013
Posts: 66
I cant remeber what fuse was blowing but one of those under the hood when my O2 sensor plug fell on the drive shaft. Thanks to the guys here at jeepforum! Same symptoms tho!
98lmtdJay is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.