JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   is it ok to use RTV on the Power steering pump/reservoir (http://www.jeepforum.com/forum/f13/ok-use-rtv-power-steering-pump-reservoir-1551174/)

Candymancan 07-19-2013 08:22 PM

is it ok to use RTV on the Power steering pump/reservoir
 
My moms Jeeps failed state inspection because the power steering apparently wasn't "good enough" for the mechanic which is BS because it turns and drives fine lol.. So anyway I bought a new OEM pump from advance auto not the made in china ones.. And I replaced the reservoir with the original Jeep reservoir because im all too familier with those nipples leaking on the new pumps..


Filled it up and it was leaking badly out of the connection between the pump and reservoir you know where the big o ring is.. I think the O ring is too small of diameter.. I didn't feel like going to the store so I used big globs of the right stuff rtv on the o ring and around where it fits into and I saw it squish out when I pressed it on so it should be good I refilled it after a few hours and it isn't leaking but im letting it sit overnight before I start it... However I know these pumps do build up pressure inside.. Sooo.. my question is do you think ill be ok like this or do you think the right stuff will blow under pressure and cause a big problem driving down the road lol.. Maybe I should get the right diameter o ring ?

a70eliminator 07-19-2013 08:44 PM

I would fix it right with a new o-ring and forget the RTV goop great stuff whatever you want to call it because it will leak eventually.

kachink 07-19-2013 10:06 PM

That point in the system doesn't see any pump pressure, so you don't need to worry about it blowing from pressure. You might get away with it, but if someone other than me was driving it I'd bring it in to pass the test, then fix it right at the next convenient opportunity.

Uniblurb 07-19-2013 10:54 PM

Quote:

Originally Posted by Candymancan (Post 15697073)
My moms Jeeps failed state inspection because the power steering apparently wasn't "good enough" for the mechanic which is BS because it turns and drives fine lol.. So anyway I bought a new OEM pump from advance auto not the made in china ones.. And I replaced the reservoir with the original Jeep reservoir because im all too familier with those nipples leaking on the new pumps..


Filled it up and it was leaking badly out of the connection between the pump and reservoir you know where the big o ring is.. I think the O ring is too small of diameter.. I didn't feel like going to the store so I used big globs of the right stuff rtv on the o ring and around where it fits into and I saw it squish out when I pressed it on so it should be good I refilled it after a few hours and it isn't leaking but im letting it sit overnight before I start it... However I know these pumps do build up pressure inside.. Sooo.. my question is do you think ill be ok like this or do you think the right stuff will blow under pressure and cause a big problem driving down the road lol.. Maybe I should get the right diameter o ring ?

Good luck finding the exact size o-ring and couldn't even match it up at a parts store. So I fixed mine the exact same way you fixed yours but used Ultra Black RTV. Hasn't leaked a drop in 1-2 years and don't even worry about it leaking anymore. As was just mentioned there's no pressure between the reservoir and pump anyhow.

zjosh93 07-20-2013 10:21 AM

Turns out this is a common issue that someone may be working on:

http://www.jeepforum.com/forum/f13/p...-ring-1549194/

Candymancan 07-20-2013 07:04 PM

Quote:

Originally Posted by Uniblurb (Post 15697453)
Good luck finding the exact size o-ring and couldn't even match it up at a parts store. So I fixed mine the exact same way you fixed yours but used Ultra Black RTV. Hasn't leaked a drop in 1-2 years and don't even worry about it leaking anymore. As was just mentioned there's no pressure between the reservoir and pump anyhow.



If there is no pressure why do they go PSSHHH when you pop the top.. All power steering pump have some pressure its designed to be like that

zjosh93 07-20-2013 09:38 PM

The only source of pressure between the reservoir is the small amount of pressure caused by the thermal expansion of the fluid and air in the system. I'd guess it was less than 1 psi. If you mean that engineers took that small amount in to account when they designed the system then you are correct.

The most common Ford power steering pump used on millions of vehicles has a tiny hole in the cap to vent the system. Most other systems either have a atmospheric vent or just don't worry about the small pressure in the reservoir.

I've been maintaining my family's cars for twenty years and I worked at a parts store for ten years and I don't recall ever hearing a PSHH when I opened a power steering cap.

Uniblurb 07-21-2013 09:04 AM

Quote:

Originally Posted by Candymancan (Post 15699642)
If there is no pressure why do they go PSSHHH when you pop the top.. All power steering pump have some pressure its designed to be like that

There may be a little air pressure in the reservoir if the cap isn't vented but I've never had the cap make a noise when removing it on the 4-5 Jeeps I maintain.

Sure power steering pumps are designed to have pressure but it's on the pump outlet, high pressure line, steering box, less pressure in the return line, etc., rather than where the reservoir meets the pump. The pump is pulling the fluid in from the reservoir rather than creating back pressure where the o-ring is located. Bet if you have a leak there you may see almost as much fluid leaking from gravity while sitting vs while running.

I only posted to offer some support that your use of RTV/gasket maker on the o-ring and reservoir inlet may very well work permanently like it has on mine vs a discussion on PSP psi. If you want to rip it apart and try to find an o-ring to fit go for it.

Candymancan 07-21-2013 12:30 PM

I have 2 Jeeps both go Psshhh after you have driven it when you take the cap off. I have never heard of them having ventilation.. If that's true then my caps could be clogged if they have a vent somewhere because both my Jeeps go pssh after its been driven and I take the cap off.. Its probably a good 3 psi of pressure. I'll look into getting 2 new caps and see if that pressure goes away.. As for your rude *** comment on me "ripping" it apart.. listen if you have cant a discussion without getting your panties all ina wad then you should probably not be on these forums.. No one was ripping anything.. I simply stated my pumps have pressure in them and I was told that's normal

It works fine with the rtv I used no leaks ina couple days and it passed inspection.

kachink 07-21-2013 03:14 PM

I've had mine make a noise when taking off the cap, but I think it's just from thermal expansion because it's NOT vented. I have seen other reservoir caps vented; just a pinhole top center. I wouldn't think that a part of the system that was designed to be under pressure would be designed to have an air pocket in it.

zjosh93 07-21-2013 05:46 PM

1 Attachment(s)
Just took my stock cap apart and the ZJ cap is definitely vented. There are a three small holes around the edge of the cap that connect to a passage that terminates under the cap. If you flip it over they are under the spring. I took a picture of me spraying brake cleaner in the holes under the cap and it coming out the top of the cap.

kachink 07-21-2013 09:40 PM

Wow, good find zjosh! Mine must be plugged then. I don't know if there's enough pressure to cause the leak I had, but it certainly doesn't help the situation.

Candymancan 07-22-2013 10:56 AM

Yea I just took my cap apart and noticed the same thing there is a pressure relief on it.. However once I poped the yellow top off I noticed its like glued on so it doesn't stay on anymore really. There is a rubber O ring like thing in there and I took that off and put the cap back on and drove it around for a few miles and then took the cap off the pump and no more pressure.. The pump I just installedwasnt leaking for a few days and now I think it is I keep feeling a small drip under it now.. I wonder if it will stop leaking now that all that pressure isn't in the reservoir anymore.. I mean if it has a tiny leak somewhere all that pressure has to have some force on pushing the fluid out.. So im crossing my fingers that it will stop that leak... Im getting sick and tired of taking the power steering off and on both my Jeeps.. I have had to fix a leak on my 5.9 3 times and this 4.0 3 times now as well.. Do you how frustrating it is to remove the pumps.. drain them... and refill (and expensive in fluid) it gets ??

I took my 5.9's cap apart as well and removed that rubber o ring thing it doesn't have anymore pressure either now.. My only concern is since I removed that brown o ring thing and the (Use approved power steering fluid) top would power steering fluid manage to get into the ventilation hole and spill out.. So far after driving the 4.0 for a few minutes making u-turns and so forth there was no fluid coming out so I think its ok. So Uniblurb even tho you think I was ripping you which I wasn't.. thanks for mentioning that there is a pressure relief hole in the cap I never knew this and I think all that pressure is what is causing my pumps to constantly leak

http://i1083.photobucket.com/albums/...ps42aac721.jpg

Uniblurb 07-22-2013 11:28 AM

Sorry if you took my post the way you did Candymancan and that was not my intention to rip you either. Amends. Glad you found maybe your cap vent was clogged/faulty and I looked at mine yesterday too. It seems to work fine but will say when working on my son's 96 XJ late last night on installing an oil cooler I let it run for about 10 minutes. Then once I removed the cap I heard the psssh noise you're talking about. But it almost seemed like vacuum rather than pressure build up. Regardless, I'm going to have to check his cap out to make sure the vent is working.

I've followed all your posts about your leaking PSP's, cheap replacement reservoirs, OE reservoirs not available, etc., and sound like a nightmare. Hope someday you get all your power steering woes resolved.

Candymancan 07-22-2013 11:54 AM

Yea its pissing me off.. Like its been going on for years... For one never use the replacement reservoirs the nipple where the return line goes in is like glued on it isn't molded plastic like the original reservoirs are so they ALWAYS leak there... and then on top of that the o rings aren't the right sizes and they leak..

Frankly Im not sure where my leak is coming from on this.. I used a ton of RTV I don't see fluid leaking from the connection between the pump and reservoir.. The reservoir is an original molded one and it isn't leaking from the nipple.. So I dunno where its coming from... Maybe its cracked somewhere.. I dunno.. It is just pissing me off.. My 5.9's hasn't leaked in a few months and thank god the pump isn't defective... becauseon top of the leaks I have had defective pumps.. I bought one from car quest... that pump has no power steering at all and when I looked into the reservoir was full of metal shavings.. That pump spewd shavings into my gear box and I had to flush it with like 3 quarts of power steering fluid because shaving = death to a gear box.. So I got a replacement carquest pump and this one is ok thank god. My mom's pump had the same issue.. the reason why it failed inspection was because the car quest pump I installed on it had no power steering when your standing still... So I had to replace it and I got the advance auto one.. this one the power steering is fine but like I said its leaking somewhere and I don't know where..

My suggestion is never buy anything from car quest they have crappy stuff worse then advance and auto zone.. As for the pressure/vacuum thing.. I dunno I cant tell if its a vacuum or pressure.. Too me it sounds like pressure, but you could be right it might be a vacuum.. Im not sure... All I know is when I took the cap apart like in my picture I have no more pshh.. I think its pressure because when the fluid heats up it rises.... But it very well might be a vacuum I dunno... Maybe I broke my caps for no reason lol ? Oh well more money to spend....

Im just SOOOO sick of these frigging leaks.. I probably have to take the 4.0's pump off for a 3rd time here soon because like I said it seems to be leaking again..


The time now is 10:41 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.