ODB Port not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > ODB Port not working

FS: Wranger BRIGHT License Plate LED! Just $3! Great valueTJ 5.25" Speaker Adapters - NalinMFGSmittybilt Products at Oconee Off-Road!

Reply
Unread 02-04-2013, 04:36 AM   #1
Mlarv
Registered User
2014 JK Wrangler 
 
Join Date: Jan 2013
Location: Kent, OH
Posts: 264
ODB Port not working

I am not sure what is going on I posted this the other day from my iPad and I do not see it now. I have a 96ZJ limited with the 5.2 in it. I bought it on Friday afternoon and by Friday night the CEL came on. I went to get it read at the parts house and there ODB2 reader would turn on like it was going to work then when they hit DTC to read the code it would power down correctly. I had it tested at another parts house and theirs did the same thing. ANy idea of where to even start I have to get the emmisions tested to get this registered and a CEL is not a good thig to have. Thanks and if someone could help with my iPad and iPhone issue of not showing up here that would be good also. Yes I made sure I had the correct app(-;

__________________
What Would Scooby Do?
Mlarv is offline   Reply With Quote
Unread 02-04-2013, 09:45 AM   #2
Nejeep
Registered User
 
Join Date: Jun 2006
Location: Lincoln, NE
Posts: 414
You could try the key dance method to see if it blinks out any codes, but that probably wont help fixing the port connection problem. Sounds like a wiring or ECM problem. Repair any obvious damaged wires, otherwise check and clean the ECM connectors under the hood.
If you bought the ZJ from a reputable dealer, take it back and complain. If you bought it "as is" on CL, good luck.
__________________
06 Laredo - 4x4 V6 - Stone White - Custom LED Cargo Area Lights, Lighted Visors Added - now at 49k miles

97 Laredo - 4.0 4x4 Daily driver for 8 years then relocated to Arizona for 6 more years with the relatives
Nejeep is offline   Reply With Quote
Unread 02-04-2013, 10:00 AM   #3
Jeeples
Registered User
2000 WJ 
 
Join Date: Jul 2006
Location: forum/f310/, UT
Posts: 4,385
Check your fuses. A lot of times the ODB port is powered off another circuit like for the auxilary power outlet/cigarette lighter.
__________________
His: '00 WJ 4.7 Limited- stock

Hers: '03 WJ 4.7 V8- IRO 3", 245/75/16 Duratracs
Jeeples is offline   Reply With Quote
Unread 02-04-2013, 10:32 AM   #4
Mlarv
Registered User
2014 JK Wrangler 
 
Join Date: Jan 2013
Location: Kent, OH
Posts: 264
Quote:
Originally Posted by Nejeep View Post
You could try the key dance method to see if it blinks out any codes, but that probably wont help fixing the port connection problem. Sounds like a wiring or ECM problem. Repair any obvious damaged wires, otherwise check and clean the ECM connectors under the hood.
If you bought the ZJ from a reputable dealer, take it back and complain. If you bought it "as is" on CL, good luck.
Thanks I bought it as is which is no problem I understood that when I bought it. The CEL came on after about I replaced the battery and drove it 7 miles. I found the pin out for the ODB port I am looking for the other side on the ECM now so I can start playing the electronics game.
__________________
What Would Scooby Do?
Mlarv is offline   Reply With Quote
Unread 02-05-2013, 02:58 PM   #5
Mlarv
Registered User
2014 JK Wrangler 
 
Join Date: Jan 2013
Location: Kent, OH
Posts: 264
Found the ground wire off behind the dip stick I guess I will run it to work I tomorrow and hope the CL goes out


Thanks for the help
__________________
What Would Scooby Do?
Mlarv is offline   Reply With Quote
Unread 02-05-2013, 04:26 PM   #6
herqulees
Registered User
1997 ZJ 
 
Join Date: Aug 2012
Location: Nashville, Tennessee
Posts: 145
+1 to checking the fuses. I have seen the OBD port powered off of the cig lighter, aux lighter, interior lights, and dash fuses in various cars. So don't stop at just one or two fuses in the inside fuse box, check all of them everywhere.
herqulees is offline   Reply With Quote
Unread 02-06-2013, 02:22 PM   #7
Mlarv
Registered User
2014 JK Wrangler 
 
Join Date: Jan 2013
Location: Kent, OH
Posts: 264
Quote:
Originally Posted by herqulees
+1 to checking the fuses. I have seen the OBD port powered off of the cig lighter, aux lighter, interior lights, and dash fuses in various cars. So don't stop at just one or two fuses in the inside fuse box, check all of them everywhere.
Well just had the E check done it passed I am doing a happy dance
__________________
What Would Scooby Do?
Mlarv is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.