JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   ODB Port not working (http://www.jeepforum.com/forum/f13/odb-port-not-working-1473645/)

Mlarv 02-04-2013 05:36 AM

ODB Port not working
 
I am not sure what is going on I posted this the other day from my iPad and I do not see it now. I have a 96ZJ limited with the 5.2 in it. I bought it on Friday afternoon and by Friday night the CEL came on. I went to get it read at the parts house and there ODB2 reader would turn on like it was going to work then when they hit DTC to read the code it would power down correctly. I had it tested at another parts house and theirs did the same thing. ANy idea of where to even start I have to get the emmisions tested to get this registered and a CEL is not a good thig to have. Thanks and if someone could help with my iPad and iPhone issue of not showing up here that would be good also. Yes I made sure I had the correct app(-;

Nejeep 02-04-2013 10:45 AM

You could try the key dance method to see if it blinks out any codes, but that probably wont help fixing the port connection problem. Sounds like a wiring or ECM problem. Repair any obvious damaged wires, otherwise check and clean the ECM connectors under the hood.
If you bought the ZJ from a reputable dealer, take it back and complain. If you bought it "as is" on CL, good luck.

Jeeples 02-04-2013 11:00 AM

Check your fuses. A lot of times the ODB port is powered off another circuit like for the auxilary power outlet/cigarette lighter.

Mlarv 02-04-2013 11:32 AM

Quote:

Originally Posted by Nejeep (Post 14904860)
You could try the key dance method to see if it blinks out any codes, but that probably wont help fixing the port connection problem. Sounds like a wiring or ECM problem. Repair any obvious damaged wires, otherwise check and clean the ECM connectors under the hood.
If you bought the ZJ from a reputable dealer, take it back and complain. If you bought it "as is" on CL, good luck.

Thanks I bought it as is which is no problem I understood that when I bought it. The CEL came on after about I replaced the battery and drove it 7 miles. I found the pin out for the ODB port I am looking for the other side on the ECM now so I can start playing the electronics game.

Mlarv 02-05-2013 03:58 PM

Found the ground wire off behind the dip stick I guess I will run it to work I tomorrow and hope the CL goes out


Thanks for the help

herqulees 02-05-2013 05:26 PM

+1 to checking the fuses. I have seen the OBD port powered off of the cig lighter, aux lighter, interior lights, and dash fuses in various cars. So don't stop at just one or two fuses in the inside fuse box, check all of them everywhere.

Mlarv 02-06-2013 03:22 PM

Quote:

Originally Posted by herqulees
+1 to checking the fuses. I have seen the OBD port powered off of the cig lighter, aux lighter, interior lights, and dash fuses in various cars. So don't stop at just one or two fuses in the inside fuse box, check all of them everywhere.

Well just had the E check done it passed I am doing a happy dance


The time now is 04:31 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.