OBDII code P1763 - JeepForum.com

 
LinkBack Thread Tools
post #1 of 11 Old 09-27-2007, 11:16 AM Thread Starter
5.9forLife
Registered User
 
Join Date: May 2006
Posts: 13
OBDII code P1763

I drive a 5.9 and just had the check engine light come on so i plugged in and found the code it was throwing (P1763). Apparently it is that the Governor Pressure Sensor Voltage is too high. Has anyone ever had an issue with this? if so what can i do to fix it?

5.9forLife is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 09-27-2007, 11:23 AM
doug1810
Registered User
 
Join Date: Sep 2007
Location: stockbridge mi
Posts: 4
Had this problem on a 47re cummins replaced sensor good to go


Try to pull and clean first maybe save some $$$$
doug1810 is offline  
post #3 of 11 Old 09-28-2007, 07:35 AM
kentman
Registered User
 
kentman's Avatar
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,437
Garage
I highly recommend resetting the code. I get this code when it is really rainy wet and I plow into a puddle such that the undercarriage gets really wet. When I let it dry and reset the code, it does not come back. I have not seen this code for at least a year since the last time.

'06 XK Limited, 5.7L, QD II, Black, 155K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 118K

Last edited by kentman; 09-29-2007 at 02:44 AM.
kentman is offline  
post #4 of 11 Old 09-28-2007, 08:55 AM
ddevitto
Registered User
 
Join Date: Jul 2006
Location: pa
Posts: 9
p1763

had the same problem. changed the governor pressure switch and solenoid. i did it in a day. found all the info needed to do it under the faq area of this web site. not that hard to do, total cost was about $165.00 including parts and new oil.
ddevitto is offline  
post #5 of 11 Old 09-28-2007, 09:31 AM Thread Starter
5.9forLife
Registered User
 
Join Date: May 2006
Posts: 13
Thanks guys i really appreciate all your help. I was worried it may be something bigger than that.
5.9forLife is offline  
post #6 of 11 Old 09-28-2007, 09:55 AM
Creek-Chub
Registered User
 
Join Date: Sep 2007
Location: SW Lower Michigan
Posts: 8
This might be a dumb question, but where is the FAQ section for the site located at?
Creek-Chub is offline  
post #7 of 11 Old 09-28-2007, 11:17 AM Thread Starter
5.9forLife
Registered User
 
Join Date: May 2006
Posts: 13
Did any of you have trouble with the transmission when this code was being thrown? It seems like the car is starting off in second gear and cant get good power.
5.9forLife is offline  
post #8 of 11 Old 09-29-2007, 02:43 AM
kentman
Registered User
 
kentman's Avatar
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,437
Garage
It will go into limp mode. I think that something like three cycles of the ignition will take it out of limp mode. Get out of limp mode and reset the code, and I bet that you will be good to go. If the code keeps coming back, then you can resort to swapping the solenoid. I have done the solenoid swap dance once in the past, but I believe that it may not be required.

'06 XK Limited, 5.7L, QD II, Black, 155K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 118K
kentman is offline  
post #9 of 11 Old 08-06-2011, 10:13 PM
IL_WJ04
Registered User
2004 WJ 
 
Join Date: Mar 2011
Location: Naperville
Posts: 31
Just got the P1763 code this evening on my 04 WJ drove about 20 miles home with it stuck in 3rd gear. Tomorrow I will try and get it out of limp home mode then clear the code and see if it comes back. Anyone have a link to the forum where someone replaced this sensor?

Thanks,
-Pat
IL_WJ04 is offline  
post #10 of 11 Old 08-07-2011, 08:23 AM
technophat
Member
1997 ZJ 
 
Join Date: Nov 2010
Location: Reaford
Posts: 190
Garage
I was recently stuck in "limp mode" in my 42re. I was throwing both the p1763 and a p1762 codes. I replaced the Transmission Governor Pressure Solenoid and the Transmission Pressure Sensor, and the problem was solved. It did take a few days for the jeep to return to normal operation though, even with resetting the codes and disconnecting the battery. Couldn't tell you why. I bought the parts through:

http://www.transmissionpartsusa.com/...rs_s/10538.htm

And I followed this YouTube vid:

http://youtu.be/TWXaoC3Qi7g

1997 ZJ Laredo, 4.0, 42re trans, 242 T-case
1994 ZJ Laredo, 4.0, 42re trans, NP231 T-case
technophat is offline  
post #11 of 11 Old 08-07-2011, 11:05 AM
98mopar
Registered User
1998 ZJ 
 
Join Date: Feb 2011
Location: desoto
Posts: 262
I just did it to my 5.9 a few weeks ago. Same code, had no 1st gear. Got the solenoid, and the sensor and the gasket for $103 from a place called transtar industries. Good to go. I reused the old trans. fluid, shifts strong, no problems!

--- 1998 ZJ 5.9 Limited - 4" lift, 31 x 10.50 15, Jet chip, Kenwood Excelon everything, current DD
--- 1996 ZJ Laredo - Parts parts and more parts
--- 1993 ZJ Laredo - 4.0 Bone stock for now (New to me)
98mopar is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Help! OBDII code P0351...x2 rooster51 ZJ Grand Cherokee Forum 82 11-17-2016 07:00 PM
help p1763 fmac ZJ Grand Cherokee Forum 3 02-27-2010 09:45 PM
need help 97 ZJ CEL (P1763) indredsnake99 ZJ Grand Cherokee Forum 1 10-07-2008 08:50 PM
P1763 code notchback ZJ Grand Cherokee Forum 9 10-26-2005 05:40 PM
OBDII CODE 1757 Governor Pressure zoom248 ZJ Grand Cherokee Forum 0 05-20-2004 08:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome