OBDII code P1763 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > OBDII code P1763

Savvy/Currie Aluminum Control ArmsRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 09-27-2007, 11:16 AM   #1
5.9forLife
Registered User
 
Join Date: May 2006
Posts: 13
OBDII code P1763

I drive a 5.9 and just had the check engine light come on so i plugged in and found the code it was throwing (P1763). Apparently it is that the Governor Pressure Sensor Voltage is too high. Has anyone ever had an issue with this? if so what can i do to fix it?

5.9forLife is offline   Reply With Quote Quick reply to this message
Unread 09-27-2007, 11:23 AM   #2
doug1810
Registered User
 
Join Date: Sep 2007
Location: stockbridge mi
Posts: 4
Had this problem on a 47re cummins replaced sensor good to go


Try to pull and clean first maybe save some $$$$
doug1810 is offline   Reply With Quote Quick reply to this message
Unread 09-28-2007, 07:35 AM   #3
kentman
Registered User
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,433
I highly recommend resetting the code. I get this code when it is really rainy wet and I plow into a puddle such that the undercarriage gets really wet. When I let it dry and reset the code, it does not come back. I have not seen this code for at least a year since the last time.
__________________
'06 XK Limited, 5.7L, QD II, Black, 128K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 104K

Last edited by kentman; 09-29-2007 at 02:44 AM..
kentman is offline   Reply With Quote Quick reply to this message
Unread 09-28-2007, 08:55 AM   #4
ddevitto
Registered User
 
Join Date: Jul 2006
Location: pa
Posts: 9
p1763

had the same problem. changed the governor pressure switch and solenoid. i did it in a day. found all the info needed to do it under the faq area of this web site. not that hard to do, total cost was about $165.00 including parts and new oil.
ddevitto is offline   Reply With Quote Quick reply to this message
Unread 09-28-2007, 09:31 AM   #5
5.9forLife
Registered User
 
Join Date: May 2006
Posts: 13
Thanks guys i really appreciate all your help. I was worried it may be something bigger than that.
5.9forLife is offline   Reply With Quote Quick reply to this message
Unread 09-28-2007, 09:55 AM   #6
Creek-Chub
Registered User
 
Join Date: Sep 2007
Location: SW Lower Michigan
Posts: 8
This might be a dumb question, but where is the FAQ section for the site located at?
Creek-Chub is offline   Reply With Quote Quick reply to this message
Unread 09-28-2007, 11:17 AM   #7
5.9forLife
Registered User
 
Join Date: May 2006
Posts: 13
Did any of you have trouble with the transmission when this code was being thrown? It seems like the car is starting off in second gear and cant get good power.
5.9forLife is offline   Reply With Quote Quick reply to this message
Unread 09-29-2007, 02:43 AM   #8
kentman
Registered User
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,433
It will go into limp mode. I think that something like three cycles of the ignition will take it out of limp mode. Get out of limp mode and reset the code, and I bet that you will be good to go. If the code keeps coming back, then you can resort to swapping the solenoid. I have done the solenoid swap dance once in the past, but I believe that it may not be required.
__________________
'06 XK Limited, 5.7L, QD II, Black, 128K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 104K
kentman is offline   Reply With Quote Quick reply to this message
Unread 08-06-2011, 10:13 PM   #9
IL_WJ04
Registered User
2004 WJ 
 
Join Date: Mar 2011
Location: Naperville, IL
Posts: 31
Just got the P1763 code this evening on my 04 WJ drove about 20 miles home with it stuck in 3rd gear. Tomorrow I will try and get it out of limp home mode then clear the code and see if it comes back. Anyone have a link to the forum where someone replaced this sensor?

Thanks,
-Pat
IL_WJ04 is offline   Reply With Quote Quick reply to this message
Unread 08-07-2011, 08:23 AM   #10
technophat
Registered User
1997 ZJ 
 
Join Date: Nov 2010
Location: Reaford, NC
Posts: 115
I was recently stuck in "limp mode" in my 42re. I was throwing both the p1763 and a p1762 codes. I replaced the Transmission Governor Pressure Solenoid and the Transmission Pressure Sensor, and the problem was solved. It did take a few days for the jeep to return to normal operation though, even with resetting the codes and disconnecting the battery. Couldn't tell you why. I bought the parts through:

http://www.transmissionpartsusa.com/...rs_s/10538.htm

And I followed this YouTube vid:

http://youtu.be/TWXaoC3Qi7g
__________________
1997 ZJ Laredo, 4.0, 42re trans, 242 T-case
1994 ZJ Laredo, 4.0, 42re trans, NP231 T-case
technophat is offline   Reply With Quote Quick reply to this message
Unread 08-07-2011, 11:05 AM   #11
98mopar
Registered User
1998 ZJ 
 
Join Date: Feb 2011
Location: desoto, kansas
Posts: 262
I just did it to my 5.9 a few weeks ago. Same code, had no 1st gear. Got the solenoid, and the sensor and the gasket for $103 from a place called transtar industries. Good to go. I reused the old trans. fluid, shifts strong, no problems!
__________________
--- 1998 ZJ 5.9 Limited - 4" lift, 31 x 10.50 15, Jet chip, Kenwood Excelon everything, current DD
--- 1996 ZJ Laredo - Parts parts and more parts
--- 1993 ZJ Laredo - 4.0 Bone stock for now (New to me)
98mopar is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.