No start after heavy rain - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 04-23-2011, 11:48 AM Thread Starter
gstroe
Registered User
1996 ZJ 
 
Join Date: Apr 2011
Location: Burlington
Posts: 33
No start after heavy rain

Hi guys, some electricals gremlins somewhere: car is parked outside and engine won't start after a heavy rain (the engine compartment is bone dry). This is the 3rd or 4th time it happens. It's been at least 3 hours now since the rain has stopped and still no start. It will most likley start a bit later in the afternoon. Last time it did this I sprayed the ignition wires and ditributor cap with WD40 but did not help. A colleague of mine mentioned a very similar experience he had with another Chrysler car and it was an electronic module in the engine compartment that was sensitive to excess humidity in the air and would not work. Any clues? patient is a 1996 Grand Cherokee Laredo (inline 6). Thank you very much,

George

gstroe is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 04-23-2011, 12:30 PM
Dodgeram1989
Registered User
1976 FSJ Cherokee 
 
Join Date: Jan 2011
Location: Des Moines
Posts: 347
Chryslers seem to be notorious for the Distributor cap being the issue after a heavy rain.

97 ZJ - Stock again
1976 Chief AMC 360 6 in lift, 35 inch tires

Dodgeram1989 is offline  
post #3 of 8 Old 04-23-2011, 02:56 PM
rlcii77
Registered User
1998 ZJ 
 
Join Date: Jun 2010
Location: Middleport
Posts: 257
?? Bad grounds, PCM connections, short elsewhere in electrical system,??
rlcii77 is offline  
post #4 of 8 Old 04-23-2011, 04:39 PM
victorb
Registered User
1994 ZJ 
 
Join Date: Jan 2005
Location: New York's Hudson Valley
Posts: 28
I have seen problems with not starting or stalling with just a little moisture with just a hairline crack in the distributer cap. I would look there first.
victorb is offline  
post #5 of 8 Old 04-28-2011, 03:37 AM
mudpuppy_n_jeep
Registered User
1980 CJ7 
 
Join Date: Feb 2010
Location: marietta 45750
Posts: 188
same ^^^.moisture in the cap.

80 cj7
boys 79 cj5
daughters 87 xj build
youngest girl 79 cj5
mudpuppy_n_jeep is offline  
post #6 of 8 Old 04-28-2011, 07:41 AM
RuffDogg68
Registered User
 
Join Date: Apr 2011
Location: Okmulgee
Posts: 3
Yes check the cap..Also unhook the battery and then unplug your ECM and check for moisture in the plug-ins if you find some blow it out with some air and apply some dielectric grease on the plug-ins to keep out the moisture.
RuffDogg68 is offline  
post #7 of 8 Old 04-28-2011, 08:09 AM
JS97ZJ
Registered User
2004 WJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry
Posts: 2,274
Put ty-wraps around your PCM connectors like in the picture below....
Attached Thumbnails
zeejay pcm.jpg  
JS97ZJ is offline  
post #8 of 8 Old 04-29-2011, 09:21 PM Thread Starter
gstroe
Registered User
1996 ZJ 
 
Join Date: Apr 2011
Location: Burlington
Posts: 33
Thank you very much guys! I will obviously replace the distributor cap and hope this was the problem. Will know at the first heavy rain....

George
gstroe is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
New guy here! pic heavy!! Ramoyer ZJ Grand Cherokee Forum 3 03-08-2011 11:23 PM
No start/hard start in/after heavy rain. BenzB ZJ Grand Cherokee Forum 1 03-08-2011 06:11 PM
Newbie - abs pump and heavy rain avocado ZJ Grand Cherokee Forum 0 10-30-2006 04:00 AM
No Start... Working all day in the rain...and other fun things jigawatt77 ZJ Grand Cherokee Forum 9 06-24-2006 06:31 PM
BB & 31s on. (poser) Pic heavy Wiley ZJ Grand Cherokee Forum 23 03-29-2006 08:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome