No start after heavy rain - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > No start after heavy rain

Smittybilt Hard Tops @ Oconee Off-Road! 706-534-9955XHD Heavy-Duty Hood Latches for JK and TJ available at OcoFS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 04-23-2011, 11:48 AM   #1
gstroe
Registered User
1996 ZJ 
 
Join Date: Apr 2011
Location: Burlington, ON, CANADA
Posts: 24
No start after heavy rain

Hi guys, some electricals gremlins somewhere: car is parked outside and engine won't start after a heavy rain (the engine compartment is bone dry). This is the 3rd or 4th time it happens. It's been at least 3 hours now since the rain has stopped and still no start. It will most likley start a bit later in the afternoon. Last time it did this I sprayed the ignition wires and ditributor cap with WD40 but did not help. A colleague of mine mentioned a very similar experience he had with another Chrysler car and it was an electronic module in the engine compartment that was sensitive to excess humidity in the air and would not work. Any clues? patient is a 1996 Grand Cherokee Laredo (inline 6). Thank you very much,

George

gstroe is offline   Reply With Quote
Unread 04-23-2011, 12:30 PM   #2
Dodgeram1989
Registered User
1976 FSJ Cherokee 
 
Join Date: Jan 2011
Location: Des Moines, Iowa
Posts: 347
Chryslers seem to be notorious for the Distributor cap being the issue after a heavy rain.
__________________
[CENTER][FONT="Comic Sans MS"]97 ZJ - Stock again
1976 Chief AMC 360 6 in lift, 35 inch tires[/FONT]
[/CENTER]
Dodgeram1989 is offline   Reply With Quote
Unread 04-23-2011, 02:56 PM   #3
rlcii77
Registered User
1998 ZJ 
 
Join Date: Jun 2010
Location: Middleport, Ohio
Posts: 255
?? Bad grounds, PCM connections, short elsewhere in electrical system,??
rlcii77 is offline   Reply With Quote
Unread 04-23-2011, 04:39 PM   #4
victorb
Registered User
1994 ZJ 
 
Join Date: Jan 2005
Location: New York's Hudson Valley
Posts: 26
I have seen problems with not starting or stalling with just a little moisture with just a hairline crack in the distributer cap. I would look there first.
victorb is offline   Reply With Quote
Unread 04-28-2011, 03:37 AM   #5
mudpuppy_n_jeep
Registered User
1980 CJ7 
 
Join Date: Feb 2010
Location: marietta 45750, ohio
Posts: 188
same ^^^.moisture in the cap.
__________________
80 cj7
boys 79 cj5
daughters 87 xj build
youngest girl 79 cj5
mudpuppy_n_jeep is offline   Reply With Quote
Unread 04-28-2011, 07:41 AM   #6
RuffDogg68
Registered User
 
Join Date: Apr 2011
Location: Okmulgee, Oklahoma
Posts: 3
Yes check the cap..Also unhook the battery and then unplug your ECM and check for moisture in the plug-ins if you find some blow it out with some air and apply some dielectric grease on the plug-ins to keep out the moisture.
RuffDogg68 is offline   Reply With Quote
Unread 04-28-2011, 08:09 AM   #7
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,035
Put ty-wraps around your PCM connectors like in the picture below....
zeejay-pcm.jpg  
JS97ZJ is offline   Reply With Quote
Unread 04-29-2011, 09:21 PM   #8
gstroe
Registered User
1996 ZJ 
 
Join Date: Apr 2011
Location: Burlington, ON, CANADA
Posts: 24
Thank you very much guys! I will obviously replace the distributor cap and hope this was the problem. Will know at the first heavy rain....

George
gstroe is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.