No rear sway bar links - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 06-28-2013, 04:58 PM Thread Starter
CorbieZJ
Registered User
1998 ZJ 
 
Join Date: Jun 2013
Location: lake city
Posts: 3
No rear sway bar links

I recently lifted my ZJ 3.5" and while doing the rear i snapped the rear sway bar links on both sides cause they were rusted..is it safe to drive without a rear sway bar for a little while until i get new links?

CorbieZJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome