no parking lights, rear wiper, dash lights flash with blinker - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > no parking lights, rear wiper, dash lights flash with blinker

D.i.y. Ford 8.8 tj,xj,yjSavvy Aluminum BumpersSwag Off Road BIG-HIT TJ-YJ Rear Bumper

Reply
Unread 05-21-2006, 02:22 PM   #1
kemicalburns
Registered User
 
Join Date: Mar 2004
Location: Central Orygun
Posts: 192
no parking lights, rear wiper, dash lights flash with blinker

1998 5.9 limited

I just recently towed a small trailer and since have lost my parking lights and dash lights. when the head light switch is in the auto position and i turn on my blinker or hit the breaks the clock, Odometer flash. I have checked the fuses under the hood and all look good. any help guys, thanks

__________________
98 limited
5.9ltr
stock
2.5" exhaust flowmaster
kemicalburns is offline   Reply With Quote
Unread 05-21-2006, 03:25 PM   #2
Meerkat
Registered User
1996 ZJ 
 
Join Date: Apr 2003
Location: Belle, WV
Posts: 4,930
Does your Jeep have the factory installed tow package, or did you install an aftermarket one?
If you installed an aftermarket one, how did you connect the lights for the trailer?
__________________
Warren
Black 1996 5.2L ZJ Limited
Meerkat is offline   Reply With Quote
Unread 05-21-2006, 03:29 PM   #3
kemicalburns
Registered User
 
Join Date: Mar 2004
Location: Central Orygun
Posts: 192
its got the factory tow package. I had to use a reducer and figured the trailer might have shorted something out. the problem is none of the fuses are bad. an not sure how these items can all be connected. the heads lights work and the break lights still work along with the blinkers so i would think the bulbs are still good all the way around. Also the fog lights wont turn on , the switch does not light up
__________________
98 limited
5.9ltr
stock
2.5" exhaust flowmaster
kemicalburns is offline   Reply With Quote
Unread 05-22-2006, 10:38 AM   #4
kemicalburns
Registered User
 
Join Date: Mar 2004
Location: Central Orygun
Posts: 192
Anybody else
__________________
98 limited
5.9ltr
stock
2.5" exhaust flowmaster
kemicalburns is offline   Reply With Quote
Unread 05-22-2006, 04:36 PM   #5
Meerkat
Registered User
1996 ZJ 
 
Join Date: Apr 2003
Location: Belle, WV
Posts: 4,930
I'm not sure what you mean by 'reducer'. I'm thinking you mean an adapter to convert the round receptacle to a flat 4 pin plug. Which shouldn't cause any problem.
There are fuses behind the passenger side kick panel as well. Have you checked all those? Also the relays. The only thing that I can think of at this point that would be in common with the elements that are malfunctioning is the Body Control Module. The BCM controls your fogs and the headlight functions when in Auto. However, if a relay feeding the BCM has gone bad, you could experience similar symptoms.

HTH
__________________
Warren
Black 1996 5.2L ZJ Limited
Meerkat is offline   Reply With Quote
Unread 11-25-2009, 11:29 PM   #6
JohnnyCommando8
Registered User
2001 XJ Cherokee 
 
Join Date: Mar 2009
Location: Las Vegas, NV
Posts: 40
I don't know if anybody is still reading this thread but I just got done with this issue on my wife's 1998 ZJ 5.9 Limited with the factory tow package. Blinking Dash lights and radio and trannsmision/ t-case indicator lights and compass/ temp lights when head lamp switch was in the auto possition and a blinker is on and or the brake pedal is pressed. If the head lamp switch is in any other possition there are none of the fore mentioned lights. So I searched the hell out of Google and tried replacing the switch itself and that didn't work then the BCM and that didn't work then checked relays then got out the meter then checked the fuses. Two of my 15 amp fuses in the passanger side foot area panel were blown. Now I don't know for sure but I do think it had something to do with pulling a trailer that had a shorted wiring harness. I hope this helps someone out. JohnnyCommando8
JohnnyCommando8 is offline   Reply With Quote
Unread 04-23-2010, 08:45 PM   #7
99SS-T
Registered User
1998 ZJ 
 
Join Date: Apr 2010
Location: CT, AZ
Posts: 18
Back from the grave

While googling my issue i came across this issue. Which happens to be EXACTLY mine. 5.9 limited that was towing a trailer leads to no parking dash or fog lights.
Putting the headlight selector into the auto makes the radio light dim and undim once a sec. And putting the selector into the parking lights position does nothing. As as if it were turned off totally. No clicking like usual. It appears the original poster has since left the forum so i cannot ask them what they ended up doing.
Hope someone is able to gimmie an idea. Thanks!!

John

Edit. Im a retard. Please disregard. Had to pull all fuses to find the bad one. Surry

Last edited by 99SS-T; 04-23-2010 at 09:00 PM.. Reason: retarded
99SS-T is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.