No O/D problem. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > No O/D problem.

New Vendor - ARTEC Industries Battery MountsComplete Axle Options Expanded !!!! ECGSNEW Smittybilt Gen 2 9.5 winch at JeepHut.com

Reply
Unread 07-08-2011, 11:42 AM   #1
randumbull
Registered User
 
Join Date: Jul 2011
Location: Menomonie, WI
Posts: 4
No O/D problem.

I have a 97 jeep grand Cherokee 5.2. I changed my tranny fluid and filter and now it wont go into O/D. I didn't mess with anything. I cant find anything on the net so i thought id sign up and ask a question. thanks for the help guys.

randumbull is offline   Reply With Quote
Unread 07-08-2011, 01:05 PM   #2
randumbull
Registered User
 
Join Date: Jul 2011
Location: Menomonie, WI
Posts: 4
please?!
randumbull is offline   Reply With Quote
Unread 07-08-2011, 01:51 PM   #3
KingtheZJ
Registered User
1998 ZJ 
 
Join Date: Nov 2009
Location: Rochester NY
Posts: 2,651
there is an OD lockout button on the dash. is the light on? when it light is on, the overdrive is locked off
__________________
'98 ZJ on 37s and tons
'97 Cummins 2500
KingtheZJ is offline   Reply With Quote
Unread 07-08-2011, 04:03 PM   #4
randumbull
Registered User
 
Join Date: Jul 2011
Location: Menomonie, WI
Posts: 4
i know that. like i said, i didnt mess with anything. just did a filter and fluid change.
randumbull is offline   Reply With Quote
Unread 07-08-2011, 04:18 PM   #5
gomes512
Registered User
1994 ZJ 
 
Join Date: Nov 2005
Location: Des Plaines, IL
Posts: 1,142
Going to ask anyways... Are you positive you have the correct fluid level?


Does the O/D light come on when you press the button? Might be that coincidentally the O/D solenoid went bad. Or perhaps it got blocked by freed wear metal after the filter change.

The 42re has the O/D and TCC solenoid as an assembly not sure about your 46.
gomes512 is offline   Reply With Quote
Unread 07-08-2011, 05:23 PM   #6
randumbull
Registered User
 
Join Date: Jul 2011
Location: Menomonie, WI
Posts: 4
yes positive, and the light does come on when i push it, every once and a while when i push it it raises about 200rpm and goes back down. but only sometimes.
randumbull is offline   Reply With Quote
Unread 07-08-2011, 05:34 PM   #7
Blwn89gt
Registered User
1998 ZJ 
 
Join Date: Jan 2010
Location: New York
Posts: 51
what tranny fluid did you put in?
Blwn89gt is offline   Reply With Quote
Unread 07-14-2011, 02:23 PM   #8
jeeponthebeach
Registered User
1995 ZJ 
 
Join Date: Nov 2009
Location: hawaii
Posts: 35
Hmm I'm having similar problems. At freeway speeds the 46RH tranny in my 95 ZJ wont stay in overdrive. It'll shift into OD then downshift then shift back into OD then downshift again. It'll keep shifting and dropping out of OD if I keep that speed and RPM. Usually when I'm going up a hill or something. Just recently the light on the OD switch on my dashboard stopped working but when I press the button I can feel it shift. Any ideas?
jeeponthebeach is offline   Reply With Quote
Unread 07-16-2011, 04:14 AM   #9
GMV93
Registered User
1997 ZJ 
 
Join Date: Oct 2010
Location: Ankara
Posts: 50
is fluid level correct?
GMV93 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.