No horn - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 06-30-2013, 05:58 PM Thread Starter
Jenglish
Registered User
1998 ZJ 
 
Join Date: Jun 2012
Location: Raleigh
Posts: 26
No horn

Is the horn something that can go out? Last time I used it, it did make an off sound...

Jenglish is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-30-2013, 06:11 PM
Oldfrog
Registered User
2007 WK 
 
Join Date: Feb 2008
Location: Louisiana/Texas
Posts: 5,092
Probably just a dirty connection or a bad horn relay. It needs some use !

Blow it at the next cop you see.

2007 5.7 Hemi, Ltd. QD II -
1997 ZJ, 4,0 select trac, Up country, track lok.
Oldfrog is offline  
post #3 of 3 Old 06-30-2013, 06:50 PM
dnuccio
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Phoenix
Posts: 3,483
x2^
i have 2 sets of early 90s cadillac deville horns on my ZJ them *****es is loud!

Reliability is relative
R.I.P. Ratmonkey
dnuccio is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome