No gauges no lights will turn over but wont start - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > No gauges no lights will turn over but wont start

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsLight up the holidays with LED lights from JeepHut

Reply
Unread 08-03-2012, 03:14 PM   #1
matthew51423
Registered User
1997 XJ Cherokee 
 
Join Date: Aug 2012
Location: seneca, illinois
Posts: 9
No gauges no lights will turn over but wont start

i have a 1997 grand cherokee limted 5.2 that i cant get to start it will turn over.... i have no lights,gauges,alram light nothing but it will turn over... im totally stuck with no idea what happen about 3days the rmp tech an speed gauge went out... no i went to start it n nothing no radio alram head lights doom lights nothing but the truck will turn over.... somebody out shoot me some ideas of whats going on?

matthew51423 is offline   Reply With Quote Quick reply to this message
Unread 08-03-2012, 03:24 PM   #2
KingtheZJ
Registered User
1998 ZJ 
 
Join Date: Nov 2009
Location: Rochester NY
Posts: 2,650
fuse
__________________
'98 ZJ on 37s and tons
'97 Cummins 2500
KingtheZJ is offline   Reply With Quote Quick reply to this message
Unread 08-04-2012, 12:19 AM   #3
98BlackZJ
Registered User
1998 ZJ 
 
Join Date: Sep 2008
Location: Monticello, NY
Posts: 313
^^ x2, check the small 20A fuses in the fuse box under the hood, I'd bet the one for the ASD relay is blown
__________________
98' 5.2 ltd, 4.5" lift, 33x12.50 KM2's, Clayton's longarms, 8.8/HP30 Aussie F&R
Build Thread
98BlackZJ is offline   Reply With Quote Quick reply to this message
Unread 08-04-2012, 11:05 AM   #4
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,794
That, or crank sensor is bad and the lights are just a coincidence.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote Quick reply to this message
Unread 08-04-2012, 11:44 AM   #5
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, Italy
Posts: 16,504
Crank sensor and cam shaft sensor are the two that will cause it not to start right?
PolkaPower is offline   Reply With Quote Quick reply to this message
Unread 08-04-2012, 12:05 PM   #6
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,794
Two of the ones that can. The crank sensor and o2 sensors can short out causing the ecu to not boot. giving no gauges while cranking, no cel either.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote Quick reply to this message
Unread 08-05-2012, 10:06 PM   #7
Murdered0utGC
Registered User
2000 WJ 
 
Join Date: Jul 2012
Location: Omaha, Nebraska
Posts: 18
my cousin had the same problem with his '96 GC, it was the body control module (BCM) that was bad. we put in a new one, and it started right up!
Murdered0utGC is offline   Reply With Quote Quick reply to this message
Unread 08-06-2012, 12:08 AM   #8
Roskoe
Registered User
1998 ZJ 
 
Join Date: Sep 2009
Location: Palm Coast, FL
Posts: 543
http://www.jeepforum.com/forum/f13/9...e-help-787003/
__________________
"aut viam inveniam aut faciam"

I hate when old people poke me at weddings, point and whisper, "You're next." So I've started doing the same thing to them at funerals
Roskoe is offline   Reply With Quote Quick reply to this message
Unread 08-07-2012, 02:06 PM   #9
matthew51423
Registered User
1997 XJ Cherokee 
 
Join Date: Aug 2012
Location: seneca, illinois
Posts: 9
I just replace the bcm an got nothing.... the fuses are all good an i replaces the asd relay nothin... the fuel pump is not turning on either....but i did have the battery an alt check both are good... some how the battery is full charged an when i wake up in the morning the battery is dead so thiers something still drawing power... im clueless.....does anybody think it could be with the alram ?
matthew51423 is offline   Reply With Quote Quick reply to this message
Unread 08-07-2012, 02:12 PM   #10
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,794
i think you need to get a multimeter out and track down the draw.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote Quick reply to this message
Unread 08-07-2012, 02:44 PM   #11
matthew51423
Registered User
1997 XJ Cherokee 
 
Join Date: Aug 2012
Location: seneca, illinois
Posts: 9
what would be the main cause of tech an mph gauge going out? 3days before i had any major problems my tech an mph gauge went out everything else still worked?
matthew51423 is offline   Reply With Quote Quick reply to this message
Unread 08-08-2012, 09:44 AM   #12
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,794
Gauge cluster, wiring, ecu, bcm, could be a lot of things
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote Quick reply to this message
Unread 08-09-2012, 01:46 AM   #13
NYCXJ90
Registered User
1990 XJ Cherokee 
 
Join Date: Nov 2004
Location: Bronx, New York
Posts: 691
Recently replaced my evaporator so naturally I had every harness disconnected. Once I put it all back and started it up I had no cluster whatsoever and it only idled for about 3 seconds and died each time.

OBD wasn't giving me any clues so under the dash I went and disconnected and inspected/cleaned every quick disconnect on every harness. I even pulled the cluster out and checked the connection there.

Magically after 45 min of that nonsense it started up and everything worked. Its the long way but who knows.

It sounds like you have a short but you may get lucky and find a corroded/shorted terminal somewhere.

Good luck
__________________
'90 XJ Laredo RE 3.5" Super Ride
'95 ZJ 5.9 Stock
NYPD Jeep Club Member #2
Marine Corps Jeep Club Member #3
So I tell the swampdonkey to sock it before I give her a trunky in the tradesman's entrance and I have her lick me yardballs.
NYCXJ90 is offline   Reply With Quote Quick reply to this message
Unread 08-14-2012, 09:00 AM   #14
matthew51423
Registered User
1997 XJ Cherokee 
 
Join Date: Aug 2012
Location: seneca, illinois
Posts: 9
I got it fixed... I learned my lesson i bought this jeep about 4months an never thought it would been a bad ground... Thier two braided metal grounds that attach to the back side of the motor by the driver side val cover to the firewall them a ground goes from the motor to.the frame... Jeep to not like sh*t for grounds make sure u always have a back up ground on the battery if you plan on puttin some mud on them tires...... An i fixed the mph gauge the wires holding the speed sensor were not holding in the plug... Nothing but a Lil tape can't fix...
matthew51423 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.