No Air from Defrost Vents - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > No Air from Defrost Vents

Labor Day Sale!FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 12-21-2009, 12:44 PM   #1
D73
Registered User
1999 WJ 
 
Join Date: Dec 2009
Location: London
Posts: 7
No Air from Defrost Vents

Hi Guys,

I drive a 99 Grand Cherokee Ltd. I fixed the heater blendoor a couple of months ago and everything worked ok but now i don`t get any air coming from the defrost vent to the windshield. all other vents seem to work fine and the blower motor is working. i am getting fault code 13 = Mode motor not responding.
i also noticed that i can`t set the climate controll to the hi or low automatic setting anymore. any ideas as i am driving around with fogged up windscreen.

Many thanks

Dirk

D73 is offline   Reply With Quote
Unread 12-21-2009, 12:46 PM   #2
JeepPimp
Registered User
2004 WJ 
 
Join Date: Nov 2009
Location: CT
Posts: 147
do all of the speeds work for the fan control?
JeepPimp is offline   Reply With Quote
Unread 12-21-2009, 12:51 PM   #3
D73
Registered User
1999 WJ 
 
Join Date: Dec 2009
Location: London
Posts: 7
all speeds work ok.
D73 is offline   Reply With Quote
Unread 12-21-2009, 12:54 PM   #4
D73
Registered User
1999 WJ 
 
Join Date: Dec 2009
Location: London
Posts: 7
it blows hot or cold through floor/dash etc. but nothing at all to the windscreen.
D73 is offline   Reply With Quote
Unread 12-21-2009, 12:54 PM   #5
JeepPimp
Registered User
2004 WJ 
 
Join Date: Nov 2009
Location: CT
Posts: 147
you got more then 1 blower motor?
JeepPimp is offline   Reply With Quote
Unread 12-21-2009, 12:59 PM   #6
D73
Registered User
1999 WJ 
 
Join Date: Dec 2009
Location: London
Posts: 7
i guess only one. i checked the connection to the blower motor and couldn`t find anything wrong.
D73 is offline   Reply With Quote
Unread 12-21-2009, 01:03 PM   #7
D73
Registered User
1999 WJ 
 
Join Date: Dec 2009
Location: London
Posts: 7
i checked the error codes and i get 13, 24, 48, 52 and 54. i guess the 52 and 54 are historic ones from the previous blend door problem. this is driving me mad as i am driving around with a damn cloth in my hand.
D73 is offline   Reply With Quote
Unread 12-21-2009, 03:53 PM   #8
BigE3
Registered User
1993 ZJ 
 
Join Date: Sep 2009
Location: Tombstone,Az
Posts: 1,014
could be a stuck actuator. I do believe the actuators had metal plungers to push the door. but if they changed it to plastic that year. it could be that the plastic piece rounded out and not letting the door close that far. The new peterbilt trucks use the same POS part and its more expensive at Peterbilt than it does at an auto store.
might sound stupid, but its a piece of info
__________________
I like my Jeep, just like my women. 'Loose and Flexible'
BigE3 is offline   Reply With Quote
Unread 01-04-2010, 08:54 AM   #9
mainfr4me
Registered User
2000 XJ Cherokee 
 
Join Date: Nov 2008
Location: WI
Posts: 17
@D73
Were you able to resolve this?
mainfr4me is offline   Reply With Quote
Unread 01-04-2010, 12:11 PM   #10
D73
Registered User
1999 WJ 
 
Join Date: Dec 2009
Location: London
Posts: 7
Hi mainfr4me

I checked the vacuum lines,connections. all seems ok. after going through some related posts i also checked the cruise control which is working. seems like all the other guys get it stuck on defrost. mine is the other way around.lol
I tried to access the actuator doors from under the dash but couldn`t get nowhere near it.
Still getting error code 13 = mode motor not responding.
Any help would be appreciatet as i am having a hard time driving around like this.
D73 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.