No air coming from defrost vents - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > No air coming from defrost vents

Engo winches available at www.rockridge4wd.com! Free shippRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 01-28-2010, 07:09 AM   #1
D73
Registered User
1999 WJ 
 
Join Date: Dec 2009
Location: London
Posts: 7
No air coming from defrost vents

Hi Guys

I re-post this as i didn`t get my issue solved.
I got no air coming out the defrost vents. it blows out the middle/side vents,what ever the setting.the Control knob seems to work as i still can switch it on and off.
I checked the vacuum lines,connections. all seems ok. after going through some related posts i also checked the cruise control which is working. seems like all the other guys get it stuck on defrost. mine is the other way around.lol
I tried to access the actuator doors from under the dash but couldn`t get nowhere near it.
Still getting error code 13 = mode motor not responding.
Can i fix this without removing the dash?
Any help would be appreciatet as i am having a hard time driving around like this.

D73 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.