no air blowing out vents - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 27 Old 02-16-2012, 12:12 PM Thread Starter
red95GC
Registered User
1995  
 
Join Date: Feb 2012
Location: reno
Posts: 20
no air blowing out vents

95 4.0 gc, i checked to see if the blend door were moving and the levers going into the two vacuum solenoids under the dash are moving back and forth when i turn the switch to different modes. its not redirecting air out of any of the vents, foot defrost or front vents, blower motor of course is working its just not directing air? any ideas?

red95GC is offline  
Sponsored Links
Advertisement
 
post #2 of 27 Old 02-16-2012, 02:21 PM
xxmikewalshxx
Registered User
1997 ZJ 
 
Join Date: Oct 2011
Location: Plains
Posts: 139
The blend door itself breaks off. There's a bunch of threads on here relating to this, search it out.

All Stock save for one track arm bushing, one Plenumn gasket, one Thremostat, one Magnaflow Muff, some vacum crap and roof accessories. Just added, loads of burn marks, melted plastic, tires, paint, smoke tinted glass.......
xxmikewalshxx is offline  
post #3 of 27 Old 02-16-2012, 04:26 PM Thread Starter
red95GC
Registered User
1995  
 
Join Date: Feb 2012
Location: reno
Posts: 20
even on the95's? where can i get a repair kit
red95GC is offline  
post #4 of 27 Old 02-16-2012, 04:57 PM
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut
Posts: 545
not sure if the 95's are the same as the 96 but i had this problem, i had air just coming out of my defroster and found that i had a broken vaccum line under the hood, i slid a slightly bigger rubber hose over the line and everything worked propperly again
DickDickle is offline  
post #5 of 27 Old 02-16-2012, 05:05 PM Thread Starter
red95GC
Registered User
1995  
 
Join Date: Feb 2012
Location: reno
Posts: 20
well my actuators all have vaccum to them and move freely. im pretty sure i have a broken door
red95GC is offline  
post #6 of 27 Old 02-17-2012, 01:53 PM
astigracing
Registered User
1993 ZJ 
 
Join Date: Feb 2012
Location: Palm Springs
Posts: 51
Quote:
Originally Posted by DickDickle View Post
not sure if the 95's are the same as the 96 but i had this problem, i had air just coming out of my defroster and found that i had a broken vaccum line under the hood, i slid a slightly bigger rubber hose over the line and everything worked propperly again
I have the same problem. No air coming out on any of the vents except the windshield defroster vents.

Where can I find this vacuum line under the hood? Can you be more specific and maybe I can look into it and hopefully fix it. I have a '93 5.2 if that helps. Thanks.
astigracing is offline  
post #7 of 27 Old 02-23-2012, 03:36 PM Thread Starter
red95GC
Registered User
1995  
 
Join Date: Feb 2012
Location: reno
Posts: 20
well i been playing with the switch lately and now noticed air coming out from the middle vents, if i take the instrument cluster out can i get access to the door and see if there's something jammed in there? or any other access points before ripping the dash out?
red95GC is offline  
post #8 of 27 Old 02-23-2012, 03:42 PM
AVR2
Web Wheeler
1993 ZJ 
 
Join Date: Apr 2007
Location: UK
Posts: 3,568
All the air doors are inside the AC box. The only way to get to them is to pull the dash and then remove and open the box. I have to do this soon
AVR2 is offline  
post #9 of 27 Old 02-23-2012, 03:55 PM Thread Starter
red95GC
Registered User
1995  
 
Join Date: Feb 2012
Location: reno
Posts: 20
well if u end up doing this take some pics or do a write up lol, i cant find one anywhere on a 95
red95GC is offline  
post #10 of 27 Old 02-23-2012, 03:59 PM
AVR2
Web Wheeler
1993 ZJ 
 
Join Date: Apr 2007
Location: UK
Posts: 3,568
Have you seen this writeup?
AVR2 is offline  
post #11 of 27 Old 02-23-2012, 04:11 PM Thread Starter
red95GC
Registered User
1995  
 
Join Date: Feb 2012
Location: reno
Posts: 20
nope, i was looking for one on this forum lmao. im blind.
red95GC is offline  
post #12 of 27 Old 05-06-2012, 02:24 PM Thread Starter
red95GC
Registered User
1995  
 
Join Date: Feb 2012
Location: reno
Posts: 20
To the people who said vacuum lines your a bunch of morons
The evaporator was clogged with dirt hair and leaves.
this year gc doesnt have the blend door breaking issue as the later models. and if all the actuators are moving then there isnt a vacuum problem
That being said air flow is perfect now and it only took 4 hours to do.


red95GC is offline  
post #13 of 27 Old 05-06-2012, 02:44 PM
jnowak
Registered User
1993 ZJ 
 
Join Date: Nov 2011
Location: dahlonega
Posts: 495
Little harsh for someone trying help you out. Its little hard to diagnose a problem with out being there. Next time if their all "morons" dont ask for help. ::
jnowak is offline  
post #14 of 27 Old 05-06-2012, 08:41 PM Thread Starter
red95GC
Registered User
1995  
 
Join Date: Feb 2012
Location: reno
Posts: 20
no one helped me out in this thread, there was just a bunch of guesses being posted by non mechanically inclined people, stick with your jiffy lube jobs boys.
red95GC is offline  
post #15 of 27 Old 05-06-2012, 11:32 PM
AVR2
Web Wheeler
1993 ZJ 
 
Join Date: Apr 2007
Location: UK
Posts: 3,568
Quote:
Originally Posted by red95GC View Post
no one helped me out in this thread, there was just a bunch of guesses being posted by non mechanically inclined people, stick with your jiffy lube jobs boys.
Are you for real? That's incredibly unfair. Even the most experienced mechanic wouldn't be able to guarantee what was wrong until they'd opened up the HVAC box. So yes, people *will* guess when presented with a common problem like reduced AC airflow, but they are educated guesses based on previous experience of what goes wrong inside HVAC boxes.

It makes no difference in this case, because whether it was a clogged evap core or a broken blend door, you still had to pull the dash and open the HVAC box.
AVR2 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
problems with air blowing only through my defrost vents joshhuwa ZJ Grand Cherokee Forum 1 07-19-2008 08:45 PM
Air not Blowing from vents? 93' Grand Cherokee stylezprodukz ZJ Grand Cherokee Forum 1 11-22-2007 10:50 AM
air cond. only blowing threw ceenter vents 2000 wj ZJ Grand Cherokee Forum 20 07-17-2007 08:37 PM
Defrost not working, blowing out vents instead mattadams ZJ Grand Cherokee Forum 8 11-27-2006 12:52 PM
A/C Vents Blowing Water? cajunc4 ZJ Grand Cherokee Forum 2 08-06-2003 11:29 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome