No AC, Heat, or defogger--Climate Control?? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > No AC, Heat, or defogger--Climate Control??

FS: Wranger BRIGHT License Plate LED! Just $3! Great valuePremium LED Lighting by VISION X, Proudly sold at ROCKRIDGIntroducing the Quart Crate...

Reply
Unread 08-15-2009, 10:27 PM   #1
TurboSam
Registered User
 
Join Date: Aug 2009
Location: Seattle
Posts: 2
No AC, Heat, or defogger--Climate Control??

My 2001 Grand Cherokee with dual ATC seems to have lost its ability to do any HVAC function. I have no heat, no AC, no blower, no rear window defogger (though I can hear it clicking when pressed), and no lights related on the ATC display in the center console. I checked the blower control motor and the connections were not burned out as I thought might be the case after looking at wjjeeps.com. I don't think it is the blend doors, since I do not have a hot/cold issue (I have nothing), and I don't think it's a resistor since the fan does not work at any speed. The darn things just seems dead. Have also checked fuses, and they are fine.

So I pulled the climate control unit out and was heading to the auto store, when the thing came to life for a few minutes. I've tried moving/pulling wires to see if either of the two plugs at the back of the CCU are loose, but it does not seem to cause or solve the problem. I pulled apart the CCU looking for obvious breaks, but saw nothing (and the unit came back to life as noted above after I did this).

I tried to get error AZC codes when it was working , and I got these (all of which I got with the unit loose in the console area): 39, 42, 43, 44, 58, 59, 60, 61, 62, 63, and 64. I am not sure, however, if they are historical or current codes since it was "on" and running when I got them, but I can't get the darn thing to turn on again to check. Several of the codes refer to lack of a "bus message," so maybe that is the problem. Can anyone tell me what the bus message codes mean?

I'm inclined to replace the climate control unit and see if that solves the problem (though it could be a wiring issue upline), but any thoughts would be much appreciated.

Thanks

Sam

TurboSam is offline   Reply With Quote
Unread 08-17-2009, 03:20 PM   #2
BLKGRANDJP
Registered User
2000 WJ 
 
Join Date: Sep 2005
Location: Nashville
Posts: 59
dealing with the exact same issue. hate to replace the CCU only to find there is a bad wire. let me know if you resolve this
__________________
00 WJ 4.7L
99 XJ 4.0L
89 Wrongler
BLKGRANDJP is offline   Reply With Quote
Unread 08-17-2009, 06:31 PM   #3
TurboSam
Registered User
 
Join Date: Aug 2009
Location: Seattle
Posts: 2
Still working it.

I noticed tonight that the AC compressor does not engage until the engine gets warm, but when it does, the ACC unit starts working again.

But it's a chicken/egg problem: does the compressor not engaging mean the ACC has no "power" or does the ACC, without power, mean it can't turn the compressor on?

If, as I suspect, the AC switch (the one like the recirculation switch on the ACC) is supposed to manually turn on the compressor, then I think there is a problem with either that switch (which is part of the ACC unit) or the whole unit. But what I saw with the compressor today brings in all kinds of issues like hi and low pressure switches which are way above my head....

Sam
TurboSam is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.