No AC, Heat, or defogger--Climate Control?? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 08-15-2009, 10:27 PM Thread Starter
TurboSam
Registered User
 
Join Date: Aug 2009
Location: Seattle
Posts: 2
No AC, Heat, or defogger--Climate Control??

My 2001 Grand Cherokee with dual ATC seems to have lost its ability to do any HVAC function. I have no heat, no AC, no blower, no rear window defogger (though I can hear it clicking when pressed), and no lights related on the ATC display in the center console. I checked the blower control motor and the connections were not burned out as I thought might be the case after looking at wjjeeps.com. I don't think it is the blend doors, since I do not have a hot/cold issue (I have nothing), and I don't think it's a resistor since the fan does not work at any speed. The darn things just seems dead. Have also checked fuses, and they are fine.

So I pulled the climate control unit out and was heading to the auto store, when the thing came to life for a few minutes. I've tried moving/pulling wires to see if either of the two plugs at the back of the CCU are loose, but it does not seem to cause or solve the problem. I pulled apart the CCU looking for obvious breaks, but saw nothing (and the unit came back to life as noted above after I did this).

I tried to get error AZC codes when it was working , and I got these (all of which I got with the unit loose in the console area): 39, 42, 43, 44, 58, 59, 60, 61, 62, 63, and 64. I am not sure, however, if they are historical or current codes since it was "on" and running when I got them, but I can't get the darn thing to turn on again to check. Several of the codes refer to lack of a "bus message," so maybe that is the problem. Can anyone tell me what the bus message codes mean?

I'm inclined to replace the climate control unit and see if that solves the problem (though it could be a wiring issue upline), but any thoughts would be much appreciated.

Thanks

Sam

TurboSam is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-17-2009, 03:20 PM
BLKGRANDJP
Registered User
2000 WJ 
 
Join Date: Sep 2005
Location: Nashville
Posts: 61
dealing with the exact same issue. hate to replace the CCU only to find there is a bad wire. let me know if you resolve this

00 WJ 4.7L
99 XJ 4.0L
89 Wrongler
BLKGRANDJP is offline  
post #3 of 3 Old 08-17-2009, 06:31 PM Thread Starter
TurboSam
Registered User
 
Join Date: Aug 2009
Location: Seattle
Posts: 2
Still working it.

I noticed tonight that the AC compressor does not engage until the engine gets warm, but when it does, the ACC unit starts working again.

But it's a chicken/egg problem: does the compressor not engaging mean the ACC has no "power" or does the ACC, without power, mean it can't turn the compressor on?

If, as I suspect, the AC switch (the one like the recirculation switch on the ACC) is supposed to manually turn on the compressor, then I think there is a problem with either that switch (which is part of the ACC unit) or the whole unit. But what I saw with the compressor today brings in all kinds of issues like hi and low pressure switches which are way above my head....

Sam
TurboSam is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Anyone have problem with climate control, no fans, and r/w defogger not working? jcp122301 WK Grand Cherokee & XK Commander Forum 0 04-19-2009 03:58 PM
Dual Climate - No Heat on Driver's Side Only 2004jeepgrand WJ Grand Cherokee Forum 6 02-05-2009 06:38 PM
AC standard control UPGRADE to Climate control ? eschapiro ZJ Grand Cherokee Forum 1 01-24-2007 08:26 AM
Need HELP :Climate control chong ZJ Grand Cherokee Forum 11 01-27-2004 04:07 PM
swaping laredo climate control w/ Limited digital control atlien928 ZJ Grand Cherokee Forum 7 12-28-2003 03:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome