New ZJ, New To Jeep, some questions:) - Page 2 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #16 of 22 Old 10-11-2012, 02:22 PM
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Quote:
Originally Posted by tibrocks View Post
2 on the computer display (..is that the 'EVIC'?) there's a red square over the bonnet.. what's that?! some errors at the engine?
Low engine oil level, bad engine oil level sensor, or VIC (Vehicle Information Center) problem.

KoreaZJ is offline  
Sponsored Links
Advertisement
 
post #17 of 22 Old 12-26-2012, 04:33 PM Thread Starter
tibrocks
Registered User
 
Join Date: Sep 2012
Location: LONDON
Posts: 8
Thank you all guys, you've been a real help - my Jeep is running much better now. solved almost everything, I got another ABS unit and the VIC warning was for the coolant sensor. the Transmission is flawless now.
I've checked the OBD codes and I got a '12' and the 55 which is the 'end of error codes' .. no clue for the 12 though

thanks again for your help!! happy holidays!
tibrocks is offline  
post #18 of 22 Old 12-26-2012, 04:38 PM
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,580
Quote:
Originally Posted by tibrocks View Post
the Transmission is flawless now.
Did I miss something, or are you going to make us guess what fixed it?
ZeeJay1997 is online now  
post #19 of 22 Old 12-27-2012, 02:00 PM
backyardjeeper
Registered User
1992 XJ Cherokee 
 
Join Date: Aug 2012
Location: raytown
Posts: 282
Quote:
Originally Posted by tibrocks
Thank you all guys, you've been a real help - my Jeep is running much better now. solved almost everything, I got another ABS unit and the VIC warning was for the coolant sensor. the Transmission is flawless now.
I've checked the OBD codes and I got a '12' and the 55 which is the 'end of error codes' .. no clue for the 12 though

thanks again for your help!! happy holidays!
12 jut means the battery was removed recently. Nothing to worry about.

92 xj on 235/75/15's. $2000 into a $400 dollar jeep.
backyardjeeper is offline  
post #20 of 22 Old 01-03-2013, 08:11 AM Thread Starter
tibrocks
Registered User
 
Join Date: Sep 2012
Location: LONDON
Posts: 8
Quote:
Originally Posted by ZeeJay1997 View Post
Did I miss something, or are you going to make us guess what fixed it?
ok, sorry I just added 3L of oil.
First I checked the level and it was waay below but it looked really clean and ~pink-ish so I just filled until the normal level. no problem now.
tibrocks is offline  
post #21 of 22 Old 01-03-2013, 08:17 AM Thread Starter
tibrocks
Registered User
 
Join Date: Sep 2012
Location: LONDON
Posts: 8
Quote:
Originally Posted by backyardjeeper View Post
12 jut means the battery was removed recently. Nothing to worry about.
oh, that's true, I've replaced the battery
thanks

and just thinking:

I have the 'analog' climate control unit and it works fine except the Fan knob which has 4 levels but it only works on OFF and Max. I was thinking to replace the unit with the one with a display on the right, will it fit?
tibrocks is offline  
post #22 of 22 Old 02-04-2013, 09:48 AM Thread Starter
tibrocks
Registered User
 
Join Date: Sep 2012
Location: LONDON
Posts: 8
anyone?

I have this one:

http://www.ebay.com/itm/1993-1995-JE...f75320&vxp=mtr


and want to replace with this one:

http://www.ebay.com/itm/Heater-Contr...f33092&vxp=mtr


anyone done it?
thanks
tibrocks is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Questions about my new jeep Jeepguy91 ZJ Grand Cherokee Forum 0 10-03-2010 05:58 PM
New to Jeep and I Have a Few Questions bumzo1 WK Grand Cherokee & XK Commander Forum 8 05-27-2010 05:10 PM
My New Jeep! few questions... tyler711 ZJ Grand Cherokee Forum 17 04-10-2008 05:43 AM
New guy with first Jeep has a few questions Deschain ZJ Grand Cherokee Forum 14 09-23-2006 10:26 PM
jeep questions jonnyslim ZJ Grand Cherokee Forum 1 12-22-2005 08:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome