New to ZJ and i have a wee problem with overheating. - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 08-13-2012, 08:49 PM Thread Starter
Concolour
Registered User
1994 ZJ 
 
Join Date: Aug 2012
Location: Calgary
Posts: 610
New to ZJ and i have a wee problem with overheating.

Ok. so i just bought this 94 grand cherokee limited with the 5.2 a month ago. and just this week it started overheating. first i noticed that there was coolant bubbling out of the overflow, usually after shutting it off. and yes, it was still boiling in the reservoir. but other than that just that it will come up to temp really fast and eventually up to the redline while at any speed including just idling.... it's been a long long time since i've done anything cooling related. there's no leaks that i can detect, just from the cap of the reservoir. the fan is indeed working, and the rad isn't blocked/bent fins. this leaves me with three things that i can think of. a clog, water pump, or thermostat. or even a combo of all three. are there any symptoms that would show for any of those so i know what part to order and replace/fix? would like this fixed asap as its currently the DD.

thanks for any and all help

-Puma

Concolour is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-14-2012, 12:18 AM
KennzX
Registered User
1998 ZJ 
 
Join Date: Jan 2010
Location: Pflugerville-Hutto-Austin, TX
Posts: 230
Get a new cap, burp the system. Should be good after that.

Sent from my iPhone using JeepForum

Jeep, The dirtiest of the four-letter words
Not stuck; temporarily detained
KennzX is offline  
post #3 of 6 Old 08-14-2012, 12:43 AM Thread Starter
Concolour
Registered User
1994 ZJ 
 
Join Date: Aug 2012
Location: Calgary
Posts: 610
Quote:
Originally Posted by KennzX View Post
Get a new cap, burp the system. Should be good after that.

Sent from my iPhone using JeepForum
actually just tried that..... it didn't work. not sure why when it should have given what i've seen is wrong. but. i'll try reburping the system and go from there.

anything else i could try?
Concolour is offline  
post #4 of 6 Old 08-14-2012, 05:58 AM
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha
Posts: 20,306
Cap? With the motorat idle at operating temp, touch the upper and lower hoses. Is either hose "cold"? Have you flushed the radiator? Changed the thermostat or waterpump?

Hunter

04 4.7 HO, limited

08 Z71 Suburban, front leveling kit with rear spacers. 285/65 18s Nitto TerraGrappler G2s

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4
http://www.kevinsoffroad.com/
602.841.3355

For your performance needs:

kolak@kolakperformance.com
480.998.366
Texas ZJ1 is offline  
post #5 of 6 Old 08-14-2012, 10:55 AM Thread Starter
Concolour
Registered User
1994 ZJ 
 
Join Date: Aug 2012
Location: Calgary
Posts: 610
Quote:
Originally Posted by Texas ZJ1 View Post
Cap? With the motorat idle at operating temp, touch the upper and lower hoses. Is either hose "cold"? Have you flushed the radiator? Changed the thermostat or waterpump?

Hunter
I'll try that when I get home. Thermostat and wp will have To wait for parts
Concolour is offline  
post #6 of 6 Old 08-15-2012, 06:07 PM Thread Starter
Concolour
Registered User
1994 ZJ 
 
Join Date: Aug 2012
Location: Calgary
Posts: 610
alright ^.^ went and checked it out. let it heat up and lo and behold? thermostat was stuck closed XD so swapped that out, or rather, one of the tech's at work did and if anything it runs a bit cold now X3 thanks for all the suggestions. especially hunter, who practically diagnosed it from his desktop. i'm sure the rad cap was also a culprit in this case too, so thank you too, KennzX!
Concolour is offline  
Reply

Tags
cooling , overheating , thermostat , water pump , zj

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Overheating problem? hdcmfan WK Grand Cherokee & XK Commander Forum 2 06-12-2011 11:51 AM
overheating problem! drob951 ZJ Grand Cherokee Forum 13 07-10-2009 10:26 PM
overheating problem???????? snowgoer987 ZJ Grand Cherokee Forum 4 05-05-2008 08:17 PM
Overheating problem? DTJ ZJ Grand Cherokee Forum 19 10-29-2007 10:10 AM
99 WJ 4.7 Overheating problem ? 99WJ4.7limited ZJ Grand Cherokee Forum 11 05-24-2006 06:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome