New project Speed bumps! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > New project Speed bumps!

Poison Spyder DeFenders™ - "Tubeless" Jeep FendeAll Bilstein shocks & struts - Lowest Prices Ever and Santa Kolak Announces: Kolak Exhaust 20% Off Sale!

Reply
Unread 11-14-2010, 01:17 PM   #1
Jacobjeep
Registered User
1995 ZJ 
 
Join Date: Apr 2010
Location: Sheridan wy
Posts: 68
New project Speed bumps!

I just inherited a 1995 zj 4.0 very clean! but the engine has water in oil and transmission does not want to shift?

#1 I have looked around head gasket and it appears to be in good shape what else could put water in oil? anything? could be head gasket still just wondering?


#2 The transmission does not like to shift it will shift into 2nd fine but then it takes an act of god to get into 3 or 4. there is a small amount of metal flake in tran pan but seems to be fine. ( when put into drive it goes into gear fast and feels like it wants to go? maybe related?)

Jacobjeep is offline   Reply With Quote Quick reply to this message
Unread 11-14-2010, 02:01 PM   #2
MoparBoy01
Registered User
1998 XJ Cherokee 
 
Join Date: May 2008
Location: ILLINOIS
Posts: 450
I had the same issue you did with question #2. I had a small amount of flakes in the trans pan but it looked good. I changed the trans fluid and filter and now shifts fine. I dont know how to answer questions #1 though, I have never really had that problem. Have you changed the oil lately?
__________________
1998 ZJ 4.0L-Trail Rig
1998 ZJ Black 5.9L-Prerunner/Daily Driver
1999 XJ 4.0L-Daily Driver/sometimes a weekend warrior
Down and Dirty Offroad Club Member
ddoffroad.com
MoparBoy01 is offline   Reply With Quote Quick reply to this message
Unread 11-14-2010, 02:08 PM   #3
Newb1995jeepgc
Registered User
1994 ZJ 
 
Join Date: Jun 2010
Location: Gallatin, Tennessee
Posts: 572
Your TV cable might need adjusted, that should help your shifting issue, and for the water issue in the oil, do you have Coolent in your Radiater or Water? If you have water in your oil and coolent in your radiater then its not a head gasket problem, it may had just had water in the oil from some other reason that hopefully wont happen again. Hope you get your problems worked out on your ZJ.
__________________
1995 Jeep ZJ Limited V8- 213k- sold
2000 Jeep WJ I6- 185xxx-sold
1994 Jeep ZJ Limited Red I6- 210k
Newb1995jeepgc is offline   Reply With Quote Quick reply to this message
Unread 11-14-2010, 02:38 PM   #4
Jacobjeep
Registered User
1995 ZJ 
 
Join Date: Apr 2010
Location: Sheridan wy
Posts: 68
I have adjusted tv cable its really not the same as that, I will change filter and fluid...

the oil was changed and it immediately was contaminated ? is there a plug or something by the water pump?
Jacobjeep is offline   Reply With Quote Quick reply to this message
Unread 11-14-2010, 05:32 PM   #5
biggoofy
Registered User
1996 ZJ 
 
Join Date: Nov 2009
Location: Troy, NC Uwharrie
Posts: 4,182
head gasket
__________________
[CENTER]Zack

96 ZJ HP44 / 9"
90 XJ on 33s
RIP Troy aka BigBlueZJ94

FroBot Fab FTW

[URL="http://www.mallcrawlin.com/forum/showthread.php?22776-Biggoofy-s-96-ZJ-build!-**Building-axles**"]My Build[/URL]


Need quality parts call Andy at Ironman4x4fab!!!!!
[url]http://ironman4x4fab.com/index.html[/url]
[/CENTER]
biggoofy is offline   Reply With Quote Quick reply to this message
Unread 11-14-2010, 05:47 PM   #6
Jacobjeep
Registered User
1995 ZJ 
 
Join Date: Apr 2010
Location: Sheridan wy
Posts: 68
I hope
Jacobjeep is offline   Reply With Quote Quick reply to this message
Unread 11-15-2010, 01:04 AM   #7
JesseOR
Registered User
1993 ZJ 
 
Join Date: Oct 2009
Location: Eugene, Oregon
Posts: 1,621
COMPRESSION TEST TIME!!!!
__________________
-Jesse-
GO DUCKS!

www.facebook.com/jesse.whitehargrove
JesseOR is offline   Reply With Quote Quick reply to this message
Reply

Tags
42re , jeep , problems , shift , zj

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.