Need some quick advice - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Need some quick advice

The ULTIMATE "Selectable" Locker System! BroughRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits WJ Modular Recovery & Bull Bar Relocation Packages

Reply
Unread 05-07-2013, 02:40 PM   #1
Robinfortmill
Registered User
1996 ZJ 
 
Join Date: Jun 2009
Location: Charleston, SC
Posts: 61
Need some quick advice

My jeep, 1998 zj 4.0 select trac, all of a sudden lost power on my way home. Had to be towed home. now it won't start at all. not sure where to start. there was a burning smell when it first started happening. also the coolant sensor bad light has been coming on occasionally. any help would be great....thanks

__________________
1996 ZJ, 4.0L, 3.73 Gears, Select-Trac, Flowmaster Exhaust, Mopar Roof Rack Basket, E3 plugs
Robinfortmill is offline   Reply With Quote
Unread 05-07-2013, 02:52 PM   #2
JeepNicholson
Registered User
1996 ZJ 
 
Join Date: Apr 2013
Location: Burbank, OH
Posts: 755
Quote:
Originally Posted by Robinfortmill View Post
My jeep, 1998 zj 4.0 select trac, all of a sudden lost power on my way home. Had to be towed home. now it won't start at all. not sure where to start. there was a burning smell when it first started happening. also the coolant sensor bad light has been coming on occasionally. any help would be great....thanks
What kind of burning smell, meaning like burning oil, gas, plastic, coolant? I'm guessing you've checked to see if it has coolant in it?

Is it turning over at all, or just no spark? Any electrics working at all? Is there pressure at the fuel rail?
JeepNicholson is offline   Reply With Quote
Unread 05-07-2013, 02:56 PM   #3
Robinfortmill
Registered User
1996 ZJ 
 
Join Date: Jun 2009
Location: Charleston, SC
Posts: 61
burning oil i think it will turn over but no spark.....i just pulled the air intake off and smoke was coming out of the intake manifold
__________________
1996 ZJ, 4.0L, 3.73 Gears, Select-Trac, Flowmaster Exhaust, Mopar Roof Rack Basket, E3 plugs
Robinfortmill is offline   Reply With Quote
Unread 05-07-2013, 02:58 PM   #4
Robinfortmill
Registered User
1996 ZJ 
 
Join Date: Jun 2009
Location: Charleston, SC
Posts: 61
electronics all seem fine......coolant is fine......temp never increased while i was driving
Robinfortmill is offline   Reply With Quote
Unread 05-07-2013, 03:22 PM   #5
JeepNicholson
Registered User
1996 ZJ 
 
Join Date: Apr 2013
Location: Burbank, OH
Posts: 755
Is there any oil on your air filter? My thinking is that maybe your ccv elbows or tubes could be clogged, blowing oil into your air intake, or possibly blowing oil from under the valve cover onto your exhaust manifold which would explain the burning smell.

One tip I've got if you pull out your ccv elbows is to let them get warm first even if it just means parking in the sun for a while if you can't start it, if they're cold they'll just break off.

While you're there you can try checking your IAC which I imagine might be all gooey if there was a bunch of oil going into your throttle body.

Both are pretty cheap and easy things to check, hopefully it works
JeepNicholson is offline   Reply With Quote
Unread 05-07-2013, 04:27 PM   #6
Robinfortmill
Registered User
1996 ZJ 
 
Join Date: Jun 2009
Location: Charleston, SC
Posts: 61
no oil in the filter and the ccv's are not clogged.......its getting spark.....doesn't seem to be any oil in the throttle body....any other ideas?
__________________
1996 ZJ, 4.0L, 3.73 Gears, Select-Trac, Flowmaster Exhaust, Mopar Roof Rack Basket, E3 plugs
Robinfortmill is offline   Reply With Quote
Unread 05-07-2013, 04:52 PM   #7
AaronButler
Registered User
1996 ZJ 
 
Join Date: Sep 2012
Location: Phoenix, AZ
Posts: 151
the coolant sensor issue is nothing to worry about, Im sure most of us ZJ owners have that stupid wiring issue show up. Its a PITA to fix, so most people (myself included) just ignore it, lol.

I know you said the electronics are fine, but I still have to ask, have you checked your alternator and/or battery? Just because things like your radio turn on doesnt necessarily mean that all is well.

what did the burning smell smell like? Were you experiencing any rough engine symptoms before it died? I had an issue where my Jeep would ONLY die when it rained. It would start right back up when it was dry, but the humidity was causing issues with my computer, and it had to be replaced.
AaronButler is offline   Reply With Quote
Unread 05-07-2013, 05:00 PM   #8
Robinfortmill
Registered User
1996 ZJ 
 
Join Date: Jun 2009
Location: Charleston, SC
Posts: 61
Like burning rubber...and it has always drove rough.
__________________
1996 ZJ, 4.0L, 3.73 Gears, Select-Trac, Flowmaster Exhaust, Mopar Roof Rack Basket, E3 plugs
Robinfortmill is offline   Reply With Quote
Unread 05-07-2013, 05:01 PM   #9
Robinfortmill
Registered User
1996 ZJ 
 
Join Date: Jun 2009
Location: Charleston, SC
Posts: 61
Battery was dead when I got it back from the tow truck....but even when jumping it it won't start
__________________
1996 ZJ, 4.0L, 3.73 Gears, Select-Trac, Flowmaster Exhaust, Mopar Roof Rack Basket, E3 plugs
Robinfortmill is offline   Reply With Quote
Unread 05-07-2013, 05:10 PM   #10
Afdude88
Registered User
1993 ZJ 
 
Join Date: Jan 2012
Location: Ogden, Ut
Posts: 547
Burning rubber could be because a failed alternator wasnt turning properly with the belt. I would check all the wiring to-from the battery and alternator and starter. You could always remove the alternator and have it tested at a parts store

When trying to jump start swap the starter relay with something else and make sure its good.

Obviously check all fuses for anything broken.

Is the cel coming on when turning the key to on?

Is the engine actually turning over? Or just nothing when you turn the key?

If its turning over but not starting, but has spark, check fuel pressure.

Even with spark check the coil with a multimeter. Maybe the spark isnt strong enough for ignition.

1993 Grand Cherokee Limited 4.0L AW-4
Afdude88 is offline   Reply With Quote
Unread 05-07-2013, 05:15 PM   #11
tucsonzj
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Boston, MA
Posts: 2,114
i'm goin with alternator is shot. Check your belts for any unusual or extreme wear, can show damage and hint in the right direction.
__________________
"washing it inside and out is on my to-do, eventually, maybe, if I have time, OOOH angle grinder."
tucsonzj is offline   Reply With Quote
Unread 05-07-2013, 05:36 PM   #12
Robinfortmill
Registered User
1996 ZJ 
 
Join Date: Jun 2009
Location: Charleston, SC
Posts: 61
I will check that out thanks
__________________
1996 ZJ, 4.0L, 3.73 Gears, Select-Trac, Flowmaster Exhaust, Mopar Roof Rack Basket, E3 plugs
Robinfortmill is offline   Reply With Quote
Unread 05-08-2013, 08:26 AM   #13
Robinfortmill
Registered User
1996 ZJ 
 
Join Date: Jun 2009
Location: Charleston, SC
Posts: 61
quick recap
driving home the gas pedal got hard to push...lost power.....got towed home and then it wouldn't start.
Still turns over and has spark.
Seems to be getting fuel.
Belt looks fine.
plugs look clean.
not sure what to look at next.
__________________
1996 ZJ, 4.0L, 3.73 Gears, Select-Trac, Flowmaster Exhaust, Mopar Roof Rack Basket, E3 plugs
Robinfortmill is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.