Need some advice on 96 GC Laredo was stalling but now battery is dying - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Need some advice on 96 GC Laredo was stalling but now battery is dying

The ULTIMATE "Selectable" Locker System! BroughOconee Off-Road Free Shipping Lifts Tires Bumpers Tops andNitro Gear Packages Now Available at Rockridge 4wd

Reply
Unread 06-28-2013, 10:29 AM   #31
mcp2009
Registered User
1996 ZJ 
 
Join Date: Mar 2011
Location: YORK, PA
Posts: 29
Quote:
Originally Posted by ZeeJay1997 View Post
so far you've cleaned and reseated the PCM connectors and changed battery.

what else?

you have dig to beat these things.
I've also done 2, part of 3, 4, and 5, and gonna try 10 today hopefully if I can find a way to get some tb cleaner.

mcp2009 is offline   Reply With Quote
Unread 06-29-2013, 01:46 PM   #32
HandsOn
Registered User
 
Join Date: Mar 2005
Location: San Jose, CA
Posts: 251
Just out of curiosity, while it was all running fine on the new battery, what did your voltmeter say? I've noticed that on a ZJ I'm working on for a friend, that even if the needle is at 13v, it's not really charging.

It does sound like you have a different issue, but at some points during your dilemma you have mentioned low voltage too I think. So I wondered.

Thanks

Paul
HandsOn is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.