Need quick replies.. Both passenger windows no longer work raining outside - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Need quick replies.. Both passenger windows no longer work raining outside

The ULTIMATE "Selectable" Locker System! BroughRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits WJ Modular Recovery & Bull Bar Relocation Packages

Reply
Unread 05-09-2013, 02:32 PM   #1
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Need quick replies.. Both passenger windows no longer work raining outside

So its raining out right now and both passenger windows no longer work.. They are rolled down and dont go up... The drivers side work tho.. I tried all switchs on the drivers door and the 2 doors in question..

I noticed that the drivers side doors that work when i push the button up when they are up they both make clicking noises inside the doors. The passenger side makes no clicking noises..

The power locks work tho... I looked in the book i dont see any fuses that control these doors are there any ? What can i do ? Both motors cant be bad at the same time.. It has to be something else

__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 05-09-2013, 02:40 PM   #2
1ATony
Vendor
1997 ZJ 
 
Join Date: Apr 2009
Location: mass
Posts: 4,476
Check the fuse, and also check the wire harness between the door and body of the Jeep for a broken or a frayed wire that might need to be fixed.
__________________

Click Here^^ For a Great Selection Of Auto Repair Parts
1ATony is offline   Reply With Quote
Unread 05-09-2013, 02:55 PM   #3
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Where is the fuse ?? I dont see any fuse labled for the power windows in the book. I checked the door harnesses for the drivers door and passenger by removing that rubber boot and unscrewing the panels and pulling the carpet back.. The wires look fine to me.
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 05-09-2013, 02:56 PM   #4
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,805
you've got a broken wire somewhere.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote
Unread 05-09-2013, 03:13 PM   #5
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Yea probly.. i dont see it tho.. Found the fuse switched it with my 5.9's no change..

Somehow after messing with stuff the rear passenger window works now.. but only from the main switch on the drivers door.. If i use its own switch it will roll down but not back up.. I can hear clicking on both passenger doors now when i push the switch but still no go on rolling up the front passenger window...

I dont see any breaks anywhere.. so how do i use a multimeter to check this ? Im terrible at electrical stuff
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 05-09-2013, 03:50 PM   #6
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
No one ?? is there no way to check to see if its the motor ??

I tried hooking my battery cables up to the battery and unplugging the harness on the door and hooking up the motor to the battery cables and i got nothing. no window up... Does this mean its the motor ?? Because this is a newish motor replaced by the dealership a few years ago.

Anyone knoiw a link to something showing how to remove the motor and replace it ?? Im going to hook up my 5.9's motor to the 4.0 and see if that fixes it.. But i dont want to break any glass or anything
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 05-09-2013, 04:35 PM   #7
coralman
Web Wheeler
 
coralman's Avatar
1998 ZJ 
 
Join Date: Jul 2010
Location: florida
Posts: 4,214
Korea must be sleeping, but he's the man.
__________________
Move over bear.I'm tired of working on the jeep
coralman is offline   Reply With Quote
Unread 05-09-2013, 05:00 PM   #8
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
So I took the motor out lifted the glass up and taped it up.. I hooked the 2 wires up again to the car battery and no power even when i reverse the wires.. So I guess this means its the motor thats bad correct ?
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 05-09-2013, 08:29 PM   #9
eagsc7
Registered User
1994 ZJ 
 
Join Date: Apr 2013
Location: Sweetwater Cyt, WY
Posts: 432
That Should be correct... Unless your battery is dead as well. I had one die on me over the winter. Just unbolted the motor itself to where I could push the window up and then bolted it all back together. About 20 Minutes per window. Course, a TARP also does wonders as a temp solution til you can get to it...
eagsc7 is offline   Reply With Quote
Unread 05-09-2013, 09:33 PM   #10
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
It was the motor got a new one from autozone for $70 and hooked it up and it works good now.. I had to cut the harness plug off and splice the old harness plug on i got it backwords so up was down and down was up lol but i fixed it works like new.. thanks
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 05-10-2013, 10:57 AM   #11
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, MD
Posts: 15,742
Quote:
Originally Posted by Candymancan View Post
It was the motor got a new one from autozone for $70 and hooked it up and it works good now.. I had to cut the harness plug off and splice the old harness plug on i got it backwords so up was down and down was up lol but i fixed it works like new.. thanks
If you have time get it at the JY next time. I got one for 15 bucks.
PolkaPower is online now   Reply With Quote
Unread 05-10-2013, 08:13 PM   #12
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
My jy's are expensive i tried them they wanted $50 lol and i didnt feal like driving 45 min to the cheap JY... so i bought it new
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.