Need a little help with a fuse - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Need a little help with a fuse

Currie Antirock, Currectlync & Lift Kits on Sale!Oconee Off-Road Free Shipping Lifts Tires Bumpers Tops andIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 07-23-2011, 09:59 PM   #1
vonericsen
Registered User
1995 ZJ 
 
Join Date: Nov 2009
Location: Longmont, Colorado
Posts: 777
Need a little help with a fuse

I keep blowing fuse 12 whenever I turn my parking lights on.
I've removed all the bulbs and I've been checking all the wiring for exposed wire, but I haven't found anything.
I've also now tried 2 other switches with no success.
This happened once before to my dad when he towed a trailer but that was years ago, this time there is no trailer involved.
The most recent thing I've done is replaced the alternator, but I dont see how it could be that because the fuse blows whether the engine is running or not, so I haven't disconnected it yet. (trying that in the morning).
Anyone have other things I should try or look for? Think it could be the trailer harness?

Thanks

__________________
[URL="http://www.jeepforum.com/forum/f197/vonericsens-build-thread-995145/"]Build Thread[/URL]

Moss Green 95 5.2l zj- 3in lift (2" BB + Upcountry coils), 255 75 R17 BFG M/T on JK Moabs, Durango Airhat, Mopar ECU, Mopar Tire Carrier
vonericsen is offline   Reply With Quote Quick reply to this message
Unread 07-23-2011, 11:08 PM   #2
CrazyMacaw
Registered User
 
Join Date: Sep 2010
Posts: 18
Trailer lights come on with parking lights as well as turn signal/brake.
I would definitely check the plug & harness.


Last edited by CrazyMacaw; 07-23-2011 at 11:43 PM..
CrazyMacaw is offline   Reply With Quote Quick reply to this message
Unread 07-23-2011, 11:23 PM   #3
airwolf9090
Registered User
1996 ZJ 
 
Join Date: May 2011
Location: Clyo, Ga
Posts: 570
I would check it too! For a while my reverse lights was sending SOS signals while driving down the road and sometimes even stay on while parked and shut off. Turned out someone cut the 7point connector and spliced in a pig tail and one of the wires was shorting out on another wire. Only reason i figured it out was when i was walking behind my jeep and the lights were on i kicked the pigtail and the lights went out.
__________________
1996 Jeep ZJ Orvis
airwolf9090 is offline   Reply With Quote Quick reply to this message
Unread 07-24-2011, 08:39 PM   #4
vonericsen
Registered User
1995 ZJ 
 
Join Date: Nov 2009
Location: Longmont, Colorado
Posts: 777
I disconnected the alternator and the trailer harness and still no luck
I also have yet to find any exposed wire
__________________
[URL="http://www.jeepforum.com/forum/f197/vonericsens-build-thread-995145/"]Build Thread[/URL]

Moss Green 95 5.2l zj- 3in lift (2" BB + Upcountry coils), 255 75 R17 BFG M/T on JK Moabs, Durango Airhat, Mopar ECU, Mopar Tire Carrier
vonericsen is offline   Reply With Quote Quick reply to this message
Unread 07-24-2011, 09:01 PM   #5
airwolf9090
Registered User
1996 ZJ 
 
Join Date: May 2011
Location: Clyo, Ga
Posts: 570
Okay this may sound weird but do you have an aftermarket radio?? in an old Trans-Am i had some reason it kept blowing the fuse for the headlight motors and taillights..... Turns out the radio was not grounded right and everytime i switched on the headlights it would blow the fuse and one day i was messing with the radio and had its ground unhooked and i bumped the headlight switch and it didn't pop the fuse. so i hooked the ground back up and it blew the fuse so i changed the ground to a different spot and never had the problem again.
__________________
1996 Jeep ZJ Orvis
airwolf9090 is offline   Reply With Quote Quick reply to this message
Unread 07-24-2011, 09:18 PM   #6
vonericsen
Registered User
1995 ZJ 
 
Join Date: Nov 2009
Location: Longmont, Colorado
Posts: 777
I do have an after market radio and I just tried that with no luck...still blowing fuses
__________________
[URL="http://www.jeepforum.com/forum/f197/vonericsens-build-thread-995145/"]Build Thread[/URL]

Moss Green 95 5.2l zj- 3in lift (2" BB + Upcountry coils), 255 75 R17 BFG M/T on JK Moabs, Durango Airhat, Mopar ECU, Mopar Tire Carrier
vonericsen is offline   Reply With Quote Quick reply to this message
Unread 07-24-2011, 10:44 PM   #7
vonericsen
Registered User
1995 ZJ 
 
Join Date: Nov 2009
Location: Longmont, Colorado
Posts: 777
I have a few more things to try tomorrow, but I did find an aftermarket alarm in my jeep. If anyone knows anything about it please let me know. Its a sky-trak 200m.
I don't know if that would cause these problems or not but I can't find any info on it.
__________________
[URL="http://www.jeepforum.com/forum/f197/vonericsens-build-thread-995145/"]Build Thread[/URL]

Moss Green 95 5.2l zj- 3in lift (2" BB + Upcountry coils), 255 75 R17 BFG M/T on JK Moabs, Durango Airhat, Mopar ECU, Mopar Tire Carrier
vonericsen is offline   Reply With Quote Quick reply to this message
Unread 07-25-2011, 05:19 PM   #8
vonericsen
Registered User
1995 ZJ 
 
Join Date: Nov 2009
Location: Longmont, Colorado
Posts: 777
I took it to a shop that specializes in electrical problems and they almost found the exact location before it disappeared...it is somewhere in the rear quarter panel that holds the trailer wiring.hope it stats hidden...
__________________
[URL="http://www.jeepforum.com/forum/f197/vonericsens-build-thread-995145/"]Build Thread[/URL]

Moss Green 95 5.2l zj- 3in lift (2" BB + Upcountry coils), 255 75 R17 BFG M/T on JK Moabs, Durango Airhat, Mopar ECU, Mopar Tire Carrier
vonericsen is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.