Need help with this strange noise... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Need help with this strange noise...

JK Vent Covers - NalinMFGRCV Axles at CCORPoison spyder items @ oconee off road 706 534 9955

Reply
Unread 11-08-2013, 02:17 PM   #1
silent35
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Las Vegas, NV
Posts: 118
Need help with this strange noise...

Well, Everytime i turn off my engine i have this strange ticking, I havent a clue what it is, it only started doing this recently. Id love some insight on it. heres a link to the video.

I hope its nothing serious.

silent35 is offline   Reply With Quote
Unread 11-08-2013, 03:01 PM   #2
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,139
"This video is private"

My ZJ ticks after I shut it off, it's just the exhaust though.

Can you describe it since we can't watch the video?
JasonStebbins is offline   Reply With Quote
Unread 11-08-2013, 03:10 PM   #3
silent35
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Las Vegas, NV
Posts: 118
oh sorry its public now
silent35 is offline   Reply With Quote
Unread 11-08-2013, 03:13 PM   #4
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,033
oh no it's not.
JS97ZJ is offline   Reply With Quote
Unread 11-08-2013, 03:25 PM   #5
silent35
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Las Vegas, NV
Posts: 118
New Link
silent35 is offline   Reply With Quote
Unread 11-08-2013, 03:42 PM   #6
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,033

Try this one.

That's a weird noise,,,,, Injectors keep firing?
If you click on the YouTube logo the video comes on..????
JS97ZJ is offline   Reply With Quote
Unread 11-08-2013, 04:42 PM   #7
silent35
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Las Vegas, NV
Posts: 118
yeah thats what it sounds like, i replaced 2 not too long ago, there were on opossite sides which is where it sounds like there comming from, idk why
silent35 is offline   Reply With Quote
Unread 11-08-2013, 07:34 PM   #8
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,033
A while back, another member had an extremely noisy injector problem when the engine was shut off. I forget what the solution was but it was related to the PCM not fully shutting down.
I'll check into it, but you can start by checking the connectors to the PCM, swap the ASD relay, and play around with the ignition key.
JS97ZJ is offline   Reply With Quote
Unread 11-12-2013, 12:26 AM   #9
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,139
Quote:
Originally Posted by JS97ZJ View Post
A while back, another member had an extremely noisy injector problem when the engine was shut off. I forget what the solution was but it was related to the PCM not fully shutting down.
I'll check into it, but you can start by checking the connectors to the PCM, swap the ASD relay, and play around with the ignition key.
I remember reading this thread.

My ZJ always does this for a few seconds after running for a long time.

Tell the girl in the background that you wouldn't be video taping your engine bay if you knew what that noise was.
JasonStebbins is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.