Need Help in Finding Temp Sending unit - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Need Help in Finding Temp Sending unit

ECGS Black Friday Sale!!6th Annual, Beat Your Wife to the Credit Card Sale!50 in light bar /A pillar mount less than 500 at JeepHut.c

Reply
Unread 07-06-2013, 07:12 PM   #1
rosas214
Registered User
1994 ZJ 
 
Join Date: Jul 2013
Location: dallas, tx
Posts: 3
Need Help in Finding Temp Sending unit

Hello like the title says i need help in finding temp sending unit just bought this 94 Grand Cherokee y see a purple wire where the unit connects to but no luck in locating it not even the hole it goes in any help would be appreciated thanks


Last edited by rosas214; 07-06-2013 at 07:24 PM..
rosas214 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2013, 07:20 PM   #2
riot1987
Professional Wise Guy
 
riot1987's Avatar
1997 ZJ 
 
Join Date: Jun 2012
Location: Lakewood, COLORADO
Posts: 3,769
My (5.2) temp sending unit was on top of the motor kinda behind my water pump.
__________________
http://www.jeepforum.com/forum/f22/riots-97-grand-1436100/

Build thread^^
riot1987 is offline   Reply With Quote Quick reply to this message
Unread 07-07-2013, 08:54 AM   #3
AVR2
Web Wheeler
1993 ZJ 
 
Join Date: Apr 2007
Location: UK
Posts: 2,493
Do you have a 4.0L or 5.2L? The sensors are in different locations on both. And on the 4.0L there are two sensors, one for the PCM and one for the dash gauge.
AVR2 is offline   Reply With Quote Quick reply to this message
Unread 07-07-2013, 10:27 AM   #4
sebian
Registered User
1995 ZJ 
 
Join Date: Sep 2009
Location: Austin, TX
Posts: 1,360
Quote:
Originally Posted by AVR2 View Post
Do you have a 4.0L or 5.2L? The sensors are in different locations on both. And on the 4.0L there are two sensors, one for the PCM and one for the dash gauge.
The 93-95 V8 also has two sensors. One near the t-stat housing for the dash, the other behind the alternator for the PCM.
__________________
1995 ZJ 5.2L V8 318. 220,000 miles and still rollin.

List of parts not replaced yet:
...
sebian is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 06:58 PM   #5
rosas214
Registered User
1994 ZJ 
 
Join Date: Jul 2013
Location: dallas, tx
Posts: 3
its a 4.0L im looking for the one for the dash gauge
rosas214 is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 08:17 PM   #6
dellis
Registered User
1998 ZJ 
 
Join Date: Feb 2013
Location: Vienna, VA
Posts: 313



Or, if you prefer a picture, the engine coolant temperature sensor is this brass colored sensor with a black electrical connector, at the front of the engine:

dellis is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 10:28 PM   #7
rosas214
Registered User
1994 ZJ 
 
Join Date: Jul 2013
Location: dallas, tx
Posts: 3
dellis thank you but im looking for another one one that is supposed to be close to back of engine on the drivers side
rosas214 is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 12:11 AM   #8
dellis
Registered User
1998 ZJ 
 
Join Date: Feb 2013
Location: Vienna, VA
Posts: 313
That is the temperature sensor that affects the temperature gauge on your dash. The other sensor, called the intake air temperature sensor, does not display anything on your dash. But, if that is what you want, here is it's location ... on the driver's side of the engine toward the firewall:



dellis is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 12:15 AM   #9
dnuccio
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Phoenix, AZ
Posts: 3,484
Quote:
Originally Posted by sebian View Post
The 93-95 V8 also has two sensors. One near the t-stat housing for the dash, the other behind the alternator for the PCM.
you got those backward. the one behind the alternator is for the dash gauge, the one by the t stat housing is for the PCM
__________________
Reliability is relative
R.I.P. Ratmonkey
dnuccio is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 02:57 AM   #10
AVR2
Web Wheeler
1993 ZJ 
 
Join Date: Apr 2007
Location: UK
Posts: 2,493
Quote:
Originally Posted by dellis View Post
That is the temperature sensor that affects the temperature gauge on your dash
Only on ZJs with the BCM; the BCM takes the coolant temp from the PCM and uses that to drive the dash gauge.

Pre-BCM models (93-95 I think) drive the gauge from a separate single-wire coolant temp sensor. On the 4.0L it's at the back of the cylinder head near the firewall, in the area of the #6 fuel injector.
AVR2 is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 08:45 AM   #11
Jeeples
Registered User
2000 WJ 
 
Join Date: Jul 2006
Location: forum/f310/, UT
Posts: 4,773
^ x2

IIRC, the sensor the OP is looking for threads directly into the cylinder head. It shouldn't be too hard to find as I believe its the only electrical connector back there. Be careful when reinstalling the sensor, as its a fine thread that can strip easily.
__________________
His: '00 WJ 4.7 Limited- stock

Hers: '03 WJ 4.7 V8- IRO 3", 245/75/16 Duratracs
Jeeples is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 09:29 AM   #12
dellis
Registered User
1998 ZJ 
 
Join Date: Feb 2013
Location: Vienna, VA
Posts: 313
Quote:
Originally Posted by AVR2 View Post
Pre-BCM models (93-95 I think) drive the gauge from a separate single-wire coolant temp sensor. On the 4.0L it's at the back of the cylinder head near the firewall, in the area of the #6 fuel injector.
Thanks for the correction ... and I apologize to the OP for misinformation. My "pre-BCM" (1993) service manual doesn't list this temperature sending unit (or at least I can't find it), and the temperature sensor at the front of the engine has a main purple color to it ... but, in doing some searching I can see where there is indeed a sensor back there on some 4.0's (I can see it is on Cherokees, for example). Here's a drawing:

dellis is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 09:32 AM   #13
sebian
Registered User
1995 ZJ 
 
Join Date: Sep 2009
Location: Austin, TX
Posts: 1,360
Quote:
Originally Posted by dnuccio View Post
you got those backward. the one behind the alternator is for the dash gauge, the one by the t stat housing is for the PCM
Not to hi-jack the thread, but I broke the one behind the t-stat housing and my dash temp gauge reading was way off as a result. I did not get any codes for temps as I would have expected, if the sensor was sending an unexpected temp reading.
__________________
1995 ZJ 5.2L V8 318. 220,000 miles and still rollin.

List of parts not replaced yet:
...
sebian is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 11:13 AM   #14
dnuccio
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Phoenix, AZ
Posts: 3,484
Quote:
Originally Posted by sebian View Post
Not to hi-jack the thread, but I broke the one behind the t-stat housing and my dash temp gauge reading was way off as a result. I did not get any codes for temps as I would have expected, if the sensor was sending an unexpected temp reading.
maybe you have a really really late 95 with 96 electronics, because the sensor by the t stat housing shouldnt have anything to do with the gauge. 96+ only has 1 sensor. on 93-95, the sensor with 2 wires is for the PCM, the one with 1 wire is for the gauge.
__________________
Reliability is relative
R.I.P. Ratmonkey
dnuccio is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 12:44 PM   #15
sebian
Registered User
1995 ZJ 
 
Join Date: Sep 2009
Location: Austin, TX
Posts: 1,360
Quote:
Originally Posted by dnuccio View Post
maybe you have a really really late 95 with 96 electronics, because the sensor by the t stat housing shouldnt have anything to do with the gauge. 96+ only has 1 sensor. on 93-95, the sensor with 2 wires is for the PCM, the one with 1 wire is for the gauge.
I have the 95 electronics, and the two sensors. One near my t-stat only has the one wire.
__________________
1995 ZJ 5.2L V8 318. 220,000 miles and still rollin.

List of parts not replaced yet:
...
sebian is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.