Need Help: 5.9 Limited Starting Issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Need Help: 5.9 Limited Starting Issue

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 04-15-2010, 11:08 AM   #1
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
Need Help: 5.9 Limited Starting Issue

My Jeep was driving fine and just died on me. Then when ever it would warm up it would die again.. I noticed I had no fuel pressure with I checked it at the rail.

I originally figured Crank Sensor, until it wouldn't even start when it was cold. Then I figured Fuel Pump.

So I replaced the fuel pump. Still no fuel pressure and it doesn't even kick on.. However the Relay is still good in the fuse box and even tried a known working one..

Also there is power going to the hot leads of the relay connection in the fuse box when the relay is removed and has the full 12 volts plus just like it should.

I also cleared the computer as well..

Can a bad Crank Positioning Sensor cause a fuel pump not to turn on???
Any Ideas??

bradtabor is offline   Reply With Quote
Unread 04-15-2010, 11:18 AM   #2
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha, NE
Posts: 20,099
Check the ignition coil. If you have spark, your fuel pump motor may have died. Do you hear it "spin up" when you turn the key to run?


Hunter
__________________
00 4.7 Laredo...stock

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4
http://www.kevinsoffroad.com/
602.841.3355

For your performance needs:

kolak@kolakperformance.com
480.998.3661
Texas ZJ1 is offline   Reply With Quote
Unread 04-15-2010, 11:20 AM   #3
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
It's my second pump I have tried.

I put a new ignition coil on and the old one tested fine..

The pump doesn't try to even turn and I tested it out of the jeep as well and it worked fine.

Wiring Harness is good..
bradtabor is offline   Reply With Quote
Unread 04-15-2010, 11:32 AM   #4
ajmorell
Registered User
 
Join Date: Jan 2006
Location: Santa Fe, New Mexico
Posts: 7,147
Are you getting spark? If no spark and no fuel check the ASD relay.
ajmorell is offline   Reply With Quote
Unread 04-15-2010, 11:51 AM   #5
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
Never hear of that relay.. where is it at??
bradtabor is offline   Reply With Quote
Unread 04-15-2010, 12:04 PM   #6
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
Ok...
No spark..
No Fuel..
Swapped the AC relay out to test Auto Shutdown Relay and Still nothing..
bradtabor is offline   Reply With Quote
Unread 04-15-2010, 12:53 PM   #7
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
No Fuel no Spark no Error codes
bradtabor is offline   Reply With Quote
Unread 04-15-2010, 02:28 PM   #8
ajmorell
Registered User
 
Join Date: Jan 2006
Location: Santa Fe, New Mexico
Posts: 7,147
Test power going to the PCM to make sure that relay box is getting power
ajmorell is offline   Reply With Quote
Unread 04-19-2010, 10:03 AM   #9
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
Found out it was the Crank Sensor.. It was melted with exposed wires..

Thanks again guys!!
bradtabor is offline   Reply With Quote
Reply

Tags
cps , fuel pump , not starting , tps
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.