Need Help: 5.9 Limited Starting Issue - JeepForum.com

 
LinkBack Thread Tools
post #1 of 9 Old 04-15-2010, 12:08 PM Thread Starter
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
Need Help: 5.9 Limited Starting Issue

My Jeep was driving fine and just died on me. Then when ever it would warm up it would die again.. I noticed I had no fuel pressure with I checked it at the rail.

I originally figured Crank Sensor, until it wouldn't even start when it was cold. Then I figured Fuel Pump.

So I replaced the fuel pump. Still no fuel pressure and it doesn't even kick on.. However the Relay is still good in the fuse box and even tried a known working one..

Also there is power going to the hot leads of the relay connection in the fuse box when the relay is removed and has the full 12 volts plus just like it should.

I also cleared the computer as well..

Can a bad Crank Positioning Sensor cause a fuel pump not to turn on???
Any Ideas??

bradtabor is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 04-15-2010, 12:18 PM
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha
Posts: 20,349
Check the ignition coil. If you have spark, your fuel pump motor may have died. Do you hear it "spin up" when you turn the key to run?


Hunter

04 4.7 HO, limited

08 Z71 Suburban, front leveling kit with rear spacers. 285/65 18s Nitto TerraGrappler G2s

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

602.841.3355

For your performance needs:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

480.998.366
Texas ZJ1 is offline  
post #3 of 9 Old 04-15-2010, 12:20 PM Thread Starter
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
It's my second pump I have tried.

I put a new ignition coil on and the old one tested fine..

The pump doesn't try to even turn and I tested it out of the jeep as well and it worked fine.

Wiring Harness is good..
bradtabor is offline  
post #4 of 9 Old 04-15-2010, 12:32 PM
ajmorell
Registered User
 
ajmorell's Avatar
 
Join Date: Jan 2006
Location: Santa Fe
Posts: 7,144
Are you getting spark? If no spark and no fuel check the ASD relay.
ajmorell is offline  
post #5 of 9 Old 04-15-2010, 12:51 PM Thread Starter
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
Never hear of that relay.. where is it at??
bradtabor is offline  
post #6 of 9 Old 04-15-2010, 01:04 PM Thread Starter
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
Ok...
No spark..
No Fuel..
Swapped the AC relay out to test Auto Shutdown Relay and Still nothing..
bradtabor is offline  
post #7 of 9 Old 04-15-2010, 01:53 PM Thread Starter
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
No Fuel no Spark no Error codes
bradtabor is offline  
post #8 of 9 Old 04-15-2010, 03:28 PM
ajmorell
Registered User
 
ajmorell's Avatar
 
Join Date: Jan 2006
Location: Santa Fe
Posts: 7,144
Test power going to the PCM to make sure that relay box is getting power
ajmorell is offline  
post #9 of 9 Old 04-19-2010, 11:03 AM Thread Starter
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
Found out it was the Crank Sensor.. It was melted with exposed wires..

Thanks again guys!!
bradtabor is offline  
Reply

Tags
cps , fuel pump , not starting , tps

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Need Help: 5.9 Limited Starting Issue bradtabor WK Grand Cherokee & XK Commander Forum 2 04-14-2010 10:48 PM
94 gc limited radio issue/steering issue? r34civic ZJ Grand Cherokee Forum 7 01-04-2010 07:00 PM
Starting issue. neoncrazy101 ZJ Grand Cherokee Forum 2 11-16-2009 08:54 PM
94 ZJ Starting Issue NEp8ntballer ZJ Grand Cherokee Forum 10 08-06-2008 12:50 AM
Trouble starting my 95 GC Limited! nholmes11 ZJ Grand Cherokee Forum 2 09-14-2001 11:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome