need help!! - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > need help!!

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsCurrie

Reply
Unread 12-07-2011, 10:16 PM   #16
jtackerman28
Registered User
1997 ZJ 
 
Join Date: Nov 2011
Location: Flint, Michigan
Posts: 2,131
I checked asd relay .ignition fuse fuel pump relay. Pcm fuse. Just went for runnining ones. Will check others tommarow. I believe it was still no check engine light when unhooked.

__________________
3.5 re lift, double sheer front tb, 31" wrangler duratecs
jtackerman28 is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 12:07 AM   #17
phitmein
Web Wheeler
 
phitmein's Avatar
1995 ZJ 
 
Join Date: Feb 2009
Location: Columbia, SC
Posts: 2,335
"It is also reading empty on the gas gage while having fuel in it. When I turn the key I can hear the fuel pump running but it doesnt stop running idk"

--------------------------------------------------

Just for the heck of it pour a couple of gallons of gas in it and see what happens.

It just seems strange to me that the fuel pump keeps running.

Phit
phitmein is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 05:11 AM   #18
jtackerman28
Registered User
1997 ZJ 
 
Join Date: Nov 2011
Location: Flint, Michigan
Posts: 2,131
Already did
__________________
3.5 re lift, double sheer front tb, 31" wrangler duratecs
jtackerman28 is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 07:20 AM   #19
merlot2twisty
Registered User
1997 ZJ 
 
Join Date: Nov 2008
Location: CensorNazi, Ohio
Posts: 143
The fact that the fuel pump keeps running I think is key here. Since it is only supposed to prime and then stop, and given the strange other behavior, I vote for a short or bad ground somewhere.
merlot2twisty is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 02:14 PM   #20
jtackerman28
Registered User
1997 ZJ 
 
Join Date: Nov 2011
Location: Flint, Michigan
Posts: 2,131
Gages still read wrong when crank sensor unhooked where to next?
__________________
3.5 re lift, double sheer front tb, 31" wrangler duratecs
jtackerman28 is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 06:07 PM   #21
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,880
If you're not getting a CEL lamp check from the PCM, the PCM is not working (assuming you know the light was working earlier). Since it is sending a ground to the fuel pump relay, it's not completely dead. You can reset it by disconnecting the negative battery cable. After you disconnect it, turn the ignition to start to discharge any residual voltage. Then, take the keys out and put them in your pocket. Then go out and clean your battery cables if you haven't done so lately and reconnect them.

As a long shot you can try swapping the ASD and fuel pump relays with the horn and intermittent wiper relays.
ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 09:25 PM   #22
jtackerman28
Registered User
1997 ZJ 
 
Join Date: Nov 2011
Location: Flint, Michigan
Posts: 2,131
I did try the second one. Had yad battery unhooked but never had turned it on while unhook will try it. Could it be a possible alternator failure?
__________________
3.5 re lift, double sheer front tb, 31" wrangler duratecs
jtackerman28 is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 09:50 PM   #23
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,880
Quote:
Originally Posted by jtackerman28 View Post
Could it be a possible alternator failure?
Quote:
Originally Posted by ZeeJay1997 View Post
If you're not getting a CEL lamp check from the PCM, the PCM is not working (assuming you know the light was working earlier).
......................
ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 09:56 PM   #24
jtackerman28
Registered User
1997 ZJ 
 
Join Date: Nov 2011
Location: Flint, Michigan
Posts: 2,131
??? the light was working earlier.... I checked all fuses and unhooked rehooked battery multiple times. Is that a no om the alternator?
__________________
3.5 re lift, double sheer front tb, 31" wrangler duratecs
jtackerman28 is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 10:47 PM   #25
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,880
take battery cables off, pull plugs on PCM, clean them, reassemble and try it.
ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 10:56 PM   #26
jtackerman28
Registered User
1997 ZJ 
 
Join Date: Nov 2011
Location: Flint, Michigan
Posts: 2,131
Should I pull radiator tanl to get the plugs out of pcm or will it be easy with it on
__________________
3.5 re lift, double sheer front tb, 31" wrangler duratecs
jtackerman28 is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 10:57 PM   #27
jtackerman28
Registered User
1997 ZJ 
 
Join Date: Nov 2011
Location: Flint, Michigan
Posts: 2,131
Coolant overflow tank*
__________________
3.5 re lift, double sheer front tb, 31" wrangler duratecs
jtackerman28 is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 11:33 PM   #28
phitmein
Web Wheeler
 
phitmein's Avatar
1995 ZJ 
 
Join Date: Feb 2009
Location: Columbia, SC
Posts: 2,335
have you tried spraying some instant start down the TB to see what happens ?

Have you checked for spark and for fuel at the rail ?
phitmein is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.