need eng help please 318 v8 please...... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > need eng help please 318 v8 please......

Engo LED Flush Mount Lights *PAIR* Flood or Spot 1,600 LumYukon Ultimate 35 axle kit for c/clip axles with Yukon ZipRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 10-09-2010, 07:46 PM   #1
onyx
Registered User
1995 ZJ 
 
Join Date: Oct 2010
Location: rochester, new hampshire
Posts: 105
need eng help please 318 v8 please......

my 95 jgc 5.2 318 v8 had a leak in every seal i could find but ran smooth and nice
until i bought this chilton manual and followed it word for word except getting off the oil pan yea right twist out HA ha ha so did all my seals rear main front oil pan timeing cover headgaskets even valve seals etc.. sooo i put my jeep back together make sure its on tdc and kick her over clunk clunk horrible like a ratchet in a fan knocking i suppose more of a rapping its never sounded so bad i do have a large hole in my exhasut i havent welded yet but i took it apart and made sure everything is torqued on just right still horrible and my oil pressure is the highest the guage allows and i am now leaking oil from somewhere above my oil filter now im guessing from the oil pressure please help please.........................

onyx is offline   Reply With Quote Quick reply to this message
Unread 10-10-2010, 06:14 AM   #2
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha, NE
Posts: 20,133
Onyx,

is the oil pressure the problem or the guage?

Hunter
__________________
00 4.7 Laredo...stock

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4
http://www.kevinsoffroad.com/
602.841.3355

For your performance needs:

kolak@kolakperformance.com
480.998.3661
Texas ZJ1 is offline   Reply With Quote Quick reply to this message
Unread 10-10-2010, 09:20 AM   #3
onyx
Registered User
1995 ZJ 
 
Join Date: Oct 2010
Location: rochester, new hampshire
Posts: 105
ohh ya the oil pressure is definetly way up there almost like the pumps clogged but im getting oil above the oil filter strong enough to blow out gaskets i dont understand i primed the pump like it said too im more concerned about the god awful rapping i just spent a week pulling it all apart and putting it back together and now its freezeing here im pissed checked my fireing order and all that havent checked my timeing but doesnt sound off beat just awfull i thot it was my fan at first but its fine today im removeing my serp belt to make sure its not my water pump but that wouldnt make sence its all brand new thing was soo mint when i took it apart ive built so many inline sixxes and not had any issues this is tramatic i may never pick up a wrench again ill try and post sum picks of the work in my gallery or something
onyx is offline   Reply With Quote Quick reply to this message
Unread 10-10-2010, 09:53 AM   #4
onyx
Registered User
1995 ZJ 
 
Join Date: Oct 2010
Location: rochester, new hampshire
Posts: 105
need eng help please 318 v8 please......

no i dont think its the guaue im pretty sure the pump is pumping max psi into the thing and without any leaks until until i left it running with all that psi now i have an oil leak i primed the pump and all the noise is what concerns me an oil pump is cheap but an eng would kill me really would ran mint before i took it apart just leaked
onyx is offline   Reply With Quote Quick reply to this message
Unread 10-10-2010, 10:29 AM   #5
brian86
Registered User
1998 ZJ 
 
Join Date: Sep 2009
Location: WV
Posts: 77
when i installed a new motor in mine, i had a loud noise. it was the dust shield on the trans hitting the converter. if it's bent a little it will hit. and as suggested i would install a new oil presure sensor. and remove the dust shield and try it and see if the noise is still there.
brian86 is offline   Reply With Quote Quick reply to this message
Unread 10-10-2010, 10:57 AM   #6
onyx
Registered User
1995 ZJ 
 
Join Date: Oct 2010
Location: rochester, new hampshire
Posts: 105
need eng help please 318 v8 please......

okay took off the serp still same noises but now my batts dead soo tried hunting down oil leak from exstremely high oil pressure appears that it blew out my new headgasket on the right side in the rear good idea about the dust sheild but my starter goes over mine i think im stuck tearing this thing apart again could it be the timeing? but it sounds right on im so confused kinna sounds like a cranking
makes alot of sense with the dust sheild because the rear bolts to the pan are halfway behind it the socket would bend it to tighten it ...... not to mention the starter stud makes it so you have to bend it to get it on hmmm
anyone got any other ideas?
onyx is offline   Reply With Quote Quick reply to this message
Unread 10-10-2010, 09:02 PM   #7
freakinheep89
Registered User
1995 ZJ 
 
Join Date: Jan 2010
Location: Mobile, Alabama
Posts: 3,271
remove starter, remove inspection plate(dust shield) replace starter, see if noise goes away. Other than that try to track down exactly where the noise is coming from
__________________
TJ-
[SIZE="1"][B]95 ZJ 5.2[/B]- D30/XJ shafts/D35 Yukon alloys,249, 2"BB, 30x9.5"Wildcat EXT,lots of motor mods, rancho shocks & stabilizer.[/SIZE]

[QUOTE=slayercr23;12630497]How would i go about Stroking it?[/QUOTE]
freakinheep89 is offline   Reply With Quote Quick reply to this message
Unread 10-10-2010, 09:21 PM   #8
JrMechanic
Registered User
 
JrMechanic's Avatar
1993 ZJ 
 
Join Date: Oct 2008
Location: Lima, Ohio
Posts: 3,368
High oil pressure isn't going to blow out any seals, especially not the head gasket. Verify the oil pressure with a mechanical gauge, it's probably the sending unit.

Oh, and use punctuation and more people will be inclined to help you.
__________________
Want to swap an NP242 or NP231 into your ZJ? Here's how:
http://www.jeepforum.com/forum/f13/n...pdated-685644/
JrMechanic is offline   Reply With Quote Quick reply to this message
Unread 10-11-2010, 07:09 PM   #9
onyx
Registered User
1995 ZJ 
 
Join Date: Oct 2010
Location: rochester, new hampshire
Posts: 105
need eng help please 318 v8 please......

yup already tried it was the noise thanx but i am pissing oil from above the oil filter in the rear upper of the engine it didnt the first couple times it was sealed nice the but my oil pressure was way up there then i started it the third time and it just started pissing after 15 mins lotts of smoke after all the oil came out or most of it my oil pressure slowly went down and now doesnt read anything i figured i probly damaged the pump trying to get my pan out like the book was telling me too twist and remove out rear of the vehicle with the vehicle on jackstands on the frame with the tires hangin which if youve tried it it isnt happening with a stock suspension i even took out my shocks and swaybar i had to dissconnect the pitman arm from the tierod end to give me room to bring it forward to bring it down and out

im a redneck i aint use those round here
onyx is offline   Reply With Quote Quick reply to this message
Unread 10-11-2010, 07:14 PM   #10
onyx
Registered User
1995 ZJ 
 
Join Date: Oct 2010
Location: rochester, new hampshire
Posts: 105
need eng help please 318 v8 please......

thank you everyone whos helped me so far i wouldve been lost unfortunetly i think i have to take her back apart for that leak and an oil pump but hey my rear main doesnt leak lmao and the left side of the motor is nice and sealed i dont know where its leaking now im hopeing its the cork gasket on the back of the manifold but i dont think im that lucky its dripping down the side of the transmission just one side though the passenger theres nuthing else up there right just head gasket and intake manifold i think well and valve cover but im not that lucky thanx all
onyx is offline   Reply With Quote Quick reply to this message
Unread 10-11-2010, 07:40 PM   #11
freakinheep89
Registered User
1995 ZJ 
 
Join Date: Jan 2010
Location: Mobile, Alabama
Posts: 3,271
that sounds exactly like the oil pressure sending unit as Jrmechanic said. its on the back of the motor just to the passenger side of the distributor, when they go bad they will leak like all hell. I can almost guarantee thats the problem if its leaking to the extent your talking about. I have never known a valve cover to leak rapidly enough to lose all oil pressure. and BTW-dont run the motor if you have leaked enough oil to lose pressure.
__________________
TJ-
[SIZE="1"][B]95 ZJ 5.2[/B]- D30/XJ shafts/D35 Yukon alloys,249, 2"BB, 30x9.5"Wildcat EXT,lots of motor mods, rancho shocks & stabilizer.[/SIZE]

[QUOTE=slayercr23;12630497]How would i go about Stroking it?[/QUOTE]
freakinheep89 is offline   Reply With Quote Quick reply to this message
Unread 10-11-2010, 07:51 PM   #12
onyx
Registered User
1995 ZJ 
 
Join Date: Oct 2010
Location: rochester, new hampshire
Posts: 105
need eng help please 318 v8 please......

OMG i might not have to take apart my entire engine again im shocked but how could it go just while sitting perhaps it got bumped
thanx so much ill have to check it out seems like the best thing i did all week is join this forum thanks again
onyx is offline   Reply With Quote Quick reply to this message
Unread 10-11-2010, 08:02 PM   #13
freakinheep89
Registered User
1995 ZJ 
 
Join Date: Jan 2010
Location: Mobile, Alabama
Posts: 3,271
strangely enough my sending unit went out when I replaced my rear main seal. I think it had something to do with the new oil pump I put in, the slightly increased pressure was too much for it I guess. my sending unit was $36 from the dealer
__________________
TJ-
[SIZE="1"][B]95 ZJ 5.2[/B]- D30/XJ shafts/D35 Yukon alloys,249, 2"BB, 30x9.5"Wildcat EXT,lots of motor mods, rancho shocks & stabilizer.[/SIZE]

[QUOTE=slayercr23;12630497]How would i go about Stroking it?[/QUOTE]
freakinheep89 is offline   Reply With Quote Quick reply to this message
Unread 10-11-2010, 08:29 PM   #14
onyx
Registered User
1995 ZJ 
 
Join Date: Oct 2010
Location: rochester, new hampshire
Posts: 105
need eng help please 318 v8 please......

yea i never replaced my oil pump but i did clean mine out with carb cleaner the screen was gritty and it had sum rtv peices on it but my jeep has always leaked alot of oil im sure the shock of not haveing any leaks increased the pressure this is a big oil leak if this is what it is wow but i do think it is its the only thing i have never replaced on it besides my oil pump but ive never had any problems with it
the only other problem i have with the car is the speedometer goes out everyonce in awhile i replaced the speed senser at first it was all crazy reading 80 when i was going twenty then it just started working and not working most of the time bellow zero but i dont really need it so i havent bothered

ive been thinking of replaceing my front springs with 3.5 lifted ones and moveing the front to the rear with sway bar extensions and some new shocks maybe some longer brake lines but i dont think ill need them im just not sure of the reach of my brake lines and control arms not to mention my driveshafts just trying to do something cheap to lift her a little
onyx is offline   Reply With Quote Quick reply to this message
Unread 10-14-2010, 05:39 PM   #15
onyx
Registered User
1995 ZJ 
 
Join Date: Oct 2010
Location: rochester, new hampshire
Posts: 105
need eng help please 318 v8 please......

yup turned out to be the sending unit cant figure out how mut reached down and it was barely even hanging on the top came right off she runs great now yea i shut it off before it reached 0 i hadnt noticed she was leaking that much until i saw the oil pressure i was too busy looking for where it came from runs better than she ever has cant wait to put the lift on
onyx is offline   Reply With Quote Quick reply to this message
Reply

Tags
grand , jeep , problem , rebuild , v8

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.