Nee help re: Instrument Cluster 04 WJ - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Nee help re: Instrument Cluster 04 WJ

Jeep Wrangler Bushwacker Flat Fender Flare Sale at BaselinLedlight bar light locks @ oconee off road 706 534 9955Don't forget the Jeep Forum discount, 10% off!

Reply
Unread 11-28-2008, 10:46 AM   #1
LongueCarabine
Registered User
1985 CJ7 
 
Join Date: Mar 2008
Location: South Louisiana
Posts: 192
Nee help re: Instrument Cluster 04 WJ

My brother is down from Atlanta and had a receiver installed on his 04 GC a couple of days ago.

He got back from having it installed and now his entire instrument cluster (fuel guage, tach, speedo, and oil pressure) are not working.

I do want to mention that when he got it back, the numbnuts at the UHaul Center had run a wire from the battery to the hitch to power the lights, etc. Apparently in the process they stripped the bolt on the positive battery terminal. When he got back, his battery had completely discharged and was dead. We got a new battery since this one was 5 years old, figured it was only a matter of time before the battery went out.

But now, I am not so sure these guys didn't do something really stupid to the vehicle.

Anyone got any ideas as to what might be going on? I certainly don't think anything we did changing the battery could have caused this problem.

TIA

LC

LongueCarabine is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.