My new 5.2 build thread - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > My new 5.2 build thread

Trick Tabs - NalinMFG.comWarn, Smitybilt, Engo, Rugged Ridge Winches at CCORClayton Off Road XJ Long Arm Suspension Systems!

Reply
Unread 06-05-2013, 03:38 PM   #16
biggreen
Registered User
1995 ZJ 
 
Join Date: Mar 2009
Location: Chino Hills
Posts: 121
That would all be great and fun if I wanted all that. I'm happy with just a 4.5 iro on 32 MT lol I dont do any huge rock crawling mainly just small trails here and there. I do plan on going for the rubicon trail at some point with my dad and his zj.

biggreen is offline   Reply With Quote
Unread 06-07-2013, 10:24 PM   #17
mperry13
Registered User
1994 ZJ 
 
Join Date: Aug 2009
Location: knoxville tn
Posts: 1
Are you planning on doing anything special to the engine? I got mine back from the machinist a couple weeks ago and am looking for ideas. I definitely need a new cam. Any thoughts?
mperry13 is offline   Reply With Quote
Unread 06-13-2013, 11:39 PM   #18
biggreen
Registered User
1995 ZJ 
 
Join Date: Mar 2009
Location: Chino Hills
Posts: 121
Quote:
Originally Posted by mperry13
Are you planning on doing anything special to the engine? I got mine back from the machinist a couple weeks ago and am looking for ideas. I definitely need a new cam. Any thoughts?
Nothing special no. I did a 30 over bore but that's it. I want to pour more money into the suspension and other fun items.
biggreen is offline   Reply With Quote
Unread 06-24-2013, 04:02 PM   #19
biggreen
Registered User
1995 ZJ 
 
Join Date: Mar 2009
Location: Chino Hills
Posts: 121
I have been driving my jeep around with its newly built motor in it and it is great. Ran into a issues which i have resolved all but one so far. Power Steering pressure line had a hole in it. Got that replaced. Belt tensioner was bad so i was squealing, replaced that. Catalytic converter was bad so i replaced that as well. Now I have a new noise that is coming from the right side of the motor over by the power steering pump and AC Compressor. It sounds like a bearing is spun in circles freely and clunking around. when i hit the gas it moves faster. I cant figure out what it is. Any thoughts on what it could be. It is coming from the area of the compressor/power steering pump.
biggreen is offline   Reply With Quote
Unread 06-24-2013, 04:34 PM   #20
Rich93ZJ
Registered User
1993 ZJ 
 
Join Date: Sep 2012
Location: Richland, Ga
Posts: 452
Quote:
Originally Posted by biggreen View Post
I have been driving my jeep around with its newly built motor in it and it is great. Ran into a issues which i have resolved all but one so far. Power Steering pressure line had a hole in it. Got that replaced. Belt tensioner was bad so i was squealing, replaced that. Catalytic converter was bad so i replaced that as well. Now I have a new noise that is coming from the right side of the motor over by the power steering pump and AC Compressor. It sounds like a bearing is spun in circles freely and clunking around. when i hit the gas it moves faster. I cant figure out what it is. Any thoughts on what it could be. It is coming from the area of the compressor/power steering pump.
Try and run it for a minute with the belt off. You can eliminate the accessories if the noise is still there.
Rich93ZJ is offline   Reply With Quote
Unread 06-25-2013, 05:52 AM   #21
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral, FLORIDA
Posts: 1,043
My power steering pump sounded like an engine knock when it started going. Scared the crap out of me, but I could feel the thumping when I stuck my finger on the fill cap while it was running. I took the belt off and started it to verify as well.
zj97ltd is offline   Reply With Quote
Unread 06-25-2013, 11:55 AM   #22
biggreen
Registered User
1995 ZJ 
 
Join Date: Mar 2009
Location: Chino Hills
Posts: 121
i have a feeling mine is the power steering pump as well. i know its not the engine since its brand new. i will pull the belt off tonight and try that. thanks!
biggreen is offline   Reply With Quote
Unread 06-25-2013, 05:31 PM   #23
Rich93ZJ
Registered User
1993 ZJ 
 
Join Date: Sep 2012
Location: Richland, Ga
Posts: 452
Quote:
Originally Posted by biggreen View Post
i know its not the engine since its brand new.
Not trying to wish you bad vibes but YOU NEVER KNOW. I forgot to add that you will throw the check engine light when you pull the belt.
Rich93ZJ is offline   Reply With Quote
Unread 06-26-2013, 12:22 AM   #24
biggreen
Registered User
1995 ZJ 
 
Join Date: Mar 2009
Location: Chino Hills
Posts: 121
No I get ya, if it is the motor well good thing it's waranteeed, but it's definitely not it.
biggreen is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.