My 5.2 Build Thread - Page 5 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #61 of 117 Old 08-08-2013, 11:55 PM
Myusername1674
Registered User
1995 ZJ 
 
Join Date: Dec 2011
Location: Chattanooga
Posts: 2,310
Quote:
Originally Posted by ZJNewbi3 View Post
She's lifted! 2" BB! Also plasti-dipped the rims! Looks awesome! Ran into trouble with the rear spring retaining post extensions so I left them off, hopefully I'll be ok with out them. I was going to use exhaust pipe to extend it but had sizing issues. Anyone know if I can buy IRO's extensions and put them on WITHOUT removing the spring?
Looks good man! I find it funny, both of our Jeeps looked so similar to begin with, and we've both done similar things to them.

Just for comparision here's mine right when i'd bb-d it.


Sucks about that shock though, you might check the classifieds on here possibly, you might find an extra one somewhere.


95 FiveTwo ZJ, DD, Lifted, Locked on 35s, Build (in progress)

My 5.9 swap (in progress)

Want your zj to be doorless in 60 seconds?
Myusername1674 is offline  
Sponsored Links
Advertisement
 
post #62 of 117 Old 08-09-2013, 12:22 AM Thread Starter
ZJNewbi3
Registered User
1995 ZJ 
 
Join Date: Mar 2013
Location: Milwaukee
Posts: 785
Quote:
Originally Posted by Myusername1674 View Post

Looks good man! I find it funny, both of our Jeeps looked so similar to begin with, and we've both done similar things to them.

Sucks about that shock though, you might check the classifieds on here possibly, you might find an extra one somewhere.
Thanks dude! I found that Summit Racing sold single shocks, but only for a 3.5" height. Guess I need to turn to part #s now. Going to give RE a call bout tht tomorrow. Unless I can run a 3.5" shock with a 2" lift?

Just trying to keep her goin'!!
ZJNewbi3 is offline  
post #63 of 117 Old 08-09-2013, 12:44 AM
CGlaser
Registered User
1998 ZJ 
 
Join Date: Jan 2013
Location: Columbus
Posts: 341
Nice build. Got a lot done on it already.

http://www.jeepforum.com/forum/f22/98-zj-slow-build-1484672/
CGlaser is offline  
post #64 of 117 Old 08-09-2013, 04:49 AM
moparlover1992
Registered User
1995 ZJ 
 
Join Date: Dec 2011
Location: Whittemore
Posts: 354
Quote:
Originally Posted by ZJNewbi3 View Post

Thanks dude! I found that Summit Racing sold single shocks, but only for a 3.5" height. Guess I need to turn to part #s now. Going to give RE a call bout tht tomorrow. Unless I can run a 3.5" shock with a 2" lift?
If you Google the part number I recall one of the well known four wheel drive websites sold them individually.

95 zj 5.2 np242 3.5'' IRO lift, IRO adjustable arms, KOR front trackbar, steering stabilizer and box brace, IRO rear adjustable trackbar, bilsteins, Hughes plenum plate, flow master 40, 31x10.5s on 15'' dc-2 rims
Mopar or no car!
moparlover1992 is offline  
post #65 of 117 Old 08-09-2013, 10:27 AM Thread Starter
ZJNewbi3
Registered User
1995 ZJ 
 
Join Date: Mar 2013
Location: Milwaukee
Posts: 785
Quote:
Originally Posted by moparlover1992 View Post
If you Google the part number I recall one of the well known four wheel drive websites sold them individually.
Called RE to get number, googled around, found that the shock was sold on Amazon for $52 then I activated my free trial of Prime to hopefully get it here faster. Now to install the shock and remember to de-activate Prime!

Anyone know why it blew out so fast? Its the weirdest thing to me...There is and tan-ish oil coming out, it makes a squish sound, but when you "bounce" it, it acts normal, and drives fine.
ZJNewbi3 is offline  
post #66 of 117 Old 08-29-2013, 12:16 PM Thread Starter
ZJNewbi3
Registered User
1995 ZJ 
 
Join Date: Mar 2013
Location: Milwaukee
Posts: 785
Replaced the rear main seal and oil pan gasket along with replaced the faulty shock. Now facing a intermediate no crank no start problem. Its probably a bad ground somewhere, hopefully. Otherwise college sucked my money. Now I have to save, spend less on the Jeep (like that's possible). Looking at transferring to a technical college to take electrician courses and then start my apprenticeship when I'm done. It's cheaper and more promising. Kissing my Computer Engineer dreams goodbye.

Just trying to keep her goin'!!
ZJNewbi3 is offline  
post #67 of 117 Old 10-06-2013, 05:36 PM Thread Starter
ZJNewbi3
Registered User
1995 ZJ 
 
Join Date: Mar 2013
Location: Milwaukee
Posts: 785
Fixed the random no start, brand new starter in. Along with all 8 control arms and new front swaybar bushings. I also developed a weird tranny leak.

There's fluid on the pan, sometimes a little puddle, but the fluid level hasn't dropped significantly within a week period.

Just trying to keep her goin'!!
ZJNewbi3 is offline  
post #68 of 117 Old 10-07-2013, 06:53 PM Thread Starter
ZJNewbi3
Registered User
1995 ZJ 
 
Join Date: Mar 2013
Location: Milwaukee
Posts: 785
Re-wired my sub woofer amp more efficiently today. Thinking about when I'm going to get time to fix my tranny leak, how I am going to get money for extended sway bar links, and other things that I would like to do. All in all, its running well! Did a little backyard flexing the other day. Didn't max it out but still had fun with it. Going to play around more when the parents leave on vacation
Attached Images
 

Just trying to keep her goin'!!
ZJNewbi3 is offline  
post #69 of 117 Old 10-20-2013, 03:20 PM Thread Starter
ZJNewbi3
Registered User
1995 ZJ 
 
Join Date: Mar 2013
Location: Milwaukee
Posts: 785
Put on new quick-disconnect battery terminals today. Also shined up and de-yellowed my head lights! Surprisingly ran into some extra money from selling my iTouch, getting more hours at work, and eating a lot of left overs. Might buy a pair of 100w KC fogs to replace the factory fogs. Decided to leave the sway links until I absolutely need them replaced. Also confirmed my tranny pan leak today, went under with a torque wrench set to 12.5ft-lbs and found that all bolts "clicked" right away. Probably over tightened them the first time. HOPEFULLY a new seal and correct steps will result in no more leaking. Also in the market for new and cheap rims...the PO neglect of mine lead to them leaking Need stock size since my tires are still brand new and I don't want to sell them, loose the warranty, and make my parents mad!

Just trying to keep her goin'!!
ZJNewbi3 is offline  
post #70 of 117 Old 10-20-2013, 04:49 PM
Scopez
Registered User
1994 ZJ 
 
Join Date: Oct 2011
Location: Aiken
Posts: 1,751
Quote:
Originally Posted by ZJNewbi3
Put on new quick-disconnect battery terminals today. Also shined up and de-yellowed my head lights! Surprisingly ran into some extra money from selling my iTouch, getting more hours at work, and eating a lot of left overs. Might buy a pair of 100w KC fogs to replace the factory fogs. Decided to leave the sway links until I absolutely need them replaced. Also confirmed my tranny pan leak today, went under with a torque wrench set to 12.5ft-lbs and found that all bolts "clicked" right away. Probably over tightened them the first time. HOPEFULLY a new seal and correct steps will result in no more leaking. Also in the market for new and cheap rims...the PO neglect of mine lead to them leaking Need stock size since my tires are still brand new and I don't want to sell them, loose the warranty, and make my parents mad!
Every kind of battery terminals I buy locally, give out within 3 months.

94 ZJ Laredo. 5.2 Crate engine. 6in JKS SA Lift. 33in Destination MTs. ARB Front Bumper.
Scopez is offline  
post #71 of 117 Old 10-20-2013, 10:51 PM Thread Starter
ZJNewbi3
Registered User
1995 ZJ 
 
Join Date: Mar 2013
Location: Milwaukee
Posts: 785
Quote:
Originally Posted by Scopez View Post

Every kind of battery terminals I buy locally, give out within 3 months.
I bought some brand at advanced auto. They were quick release, and have a colored (epoxy?) coating over them, I also sprayed them with dielectric grease. Hopefully that's not the case with these. I was running the stock ones still and they were TRASHED.

Just trying to keep her goin'!!
ZJNewbi3 is offline  
post #72 of 117 Old 10-21-2013, 03:25 AM
Scopez
Registered User
1994 ZJ 
 
Join Date: Oct 2011
Location: Aiken
Posts: 1,751
Quote:
Originally Posted by ZJNewbi3
I bought some brand at advanced auto. They were quick release, and have a colored (epoxy?) coating over them, I also sprayed them with dielectric grease. Hopefully that's not the case with these. I was running the stock ones still and they were TRASHED.
I bought a marine, gold plated one from there, the screw snapped in half as I was tightening it. I've had the red and black top post ones crack. They don't hold up if you disconnect a lot, so maybe you're in the clear with quick disconnects.

94 ZJ Laredo. 5.2 Crate engine. 6in JKS SA Lift. 33in Destination MTs. ARB Front Bumper.
Scopez is offline  
post #73 of 117 Old 10-21-2013, 07:55 AM Thread Starter
ZJNewbi3
Registered User
1995 ZJ 
 
Join Date: Mar 2013
Location: Milwaukee
Posts: 785
Quote:
Originally Posted by Scopez View Post

I bought a marine, gold plated one from there, the screw snapped in half as I was tightening it. I've had the red and black top post ones crack. They don't hold up if you disconnect a lot, so maybe you're in the clear with quick disconnects.
*crosses fingers* I don't even disconnect my battery much to begin with I was just getting tired if those dang square bolts!

Just trying to keep her goin'!!
ZJNewbi3 is offline  
post #74 of 117 Old 10-21-2013, 12:16 PM
Scopez
Registered User
1994 ZJ 
 
Join Date: Oct 2011
Location: Aiken
Posts: 1,751
Quote:
Originally Posted by ZJNewbi3
*crosses fingers* I don't even disconnect my battery much to begin with I was just getting tired if those dang square bolts!
I need to find a good crimper so I can put lugs on all my ends. Any suggestions? Or were you able to just leave the wire exposed and screw it down tight?

94 ZJ Laredo. 5.2 Crate engine. 6in JKS SA Lift. 33in Destination MTs. ARB Front Bumper.
Scopez is offline  
post #75 of 117 Old 10-21-2013, 12:47 PM
JeepNicholson
Registered User
1996 ZJ 
 
Join Date: Apr 2013
Location: Burbank
Posts: 753
Quote:
Originally Posted by Scopez View Post
I need to find a good crimper so I can put lugs on all my ends. Any suggestions? Or were you able to just leave the wire exposed and screw it down tight?
I used solder to put my lugs on. Actually the lugs came with solder already in them, or you can get solder pellets. Just torch n go.
JeepNicholson is offline  
Reply

Tags
5.2l , build thread , limited , v8

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome