Is my 46re on its way out? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Is my 46re on its way out?

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 02-15-2011, 07:10 PM   #1
jeep360limited
Registered User
2003  
 
Join Date: Aug 2008
Location: Maryland
Posts: 584
Is my 46re on its way out?

My Jeep has round 175k on the clock and the check engine light has come on for the third time in the past year for what seems like transmission related problems. It always seems to come on when the trans wont shift into overdrive. Even if i let it warm up in the morning(letting it idle in neutral to heat it up) it still wont **** into OD. I have heard that these transmissions are the weak link in the drivetrain and i want to know if it sounds like mine needs a rebuild or something along those lines.

Thanks

__________________
Charlie
2003 Ford Ranger Edge
1986 Jeep CJ7
1998 Jeep Grand Cherokee 5.9 Limited-----SOLD
jeep360limited is offline   Reply With Quote
Unread 02-15-2011, 07:26 PM   #2
newfieZJ
Registered User
1995 ZJ 
 
Join Date: May 2008
Location: , Alberta
Posts: 6,406
I doubt it's the trans after reading the FSM about no 3-4 shift .

Coolant sensor
Overdrive Circut fuse
Speed sensor
O/D wire shorted/cut

and thats just a few causes .

Wait for , or PM Ratmonkey , he'll give you a more percise diagnoses
newfieZJ is offline   Reply With Quote
Unread 02-15-2011, 07:40 PM   #3
jeep360limited
Registered User
2003  
 
Join Date: Aug 2008
Location: Maryland
Posts: 584
That's what the CEL code was for last time, a hard 3-4 shift. The coolant sensor warning goes off every once in a while, usually only during the warmer months. Are any of those problems expensive and/or hard to fix?
__________________
Charlie
2003 Ford Ranger Edge
1986 Jeep CJ7
1998 Jeep Grand Cherokee 5.9 Limited-----SOLD
jeep360limited is offline   Reply With Quote
Unread 02-15-2011, 07:57 PM   #4
ZombieJeep93
Registered User
1993 ZJ 
 
Join Date: Sep 2010
Location: westminster, co
Posts: 125
Whats the dtc? any other symptoms? do you still have 1-2-3 upshifts?
__________________
93 Grand Wagoneer (de-wooded) 5.2 Mag, 2"BB, Magnaflo Cat, Gibson ex, K&N CAI, Mopar pcm, 32" BFG AT, Accel truck ignition
ZombieJeep93 is offline   Reply With Quote
Unread 02-15-2011, 11:36 PM   #5
jnicewan
Registered User
1995 ZJ 
 
Join Date: Dec 2010
Location: Norman, OK
Posts: 2,006
Need to read codes, do you have T/C lock up too. Whats the fluid look/smell like???
jnicewan is offline   Reply With Quote
Unread 02-16-2011, 12:37 PM   #6
MaintMech
Senior Member
 
MaintMech's Avatar
1996 ZJ 
 
Join Date: Feb 2011
Location: Farmington, MN
Posts: 537
Coolant Sensor

If it's the low level sensor that shows up as bad on your VIC there's a great thread on here about troubleshooting it. phild328 started it. Probably a bad solder joint on the VIC display.

Good Luck!!
MaintMech is offline   Reply With Quote
Unread 02-17-2011, 02:24 AM   #7
ZJ5point2GCL
Registered User
1998 ZJ 
 
Join Date: Oct 2009
Location: Calgary
Posts: 3,392
Quote:
Originally Posted by MaintMech View Post
If it's the low level sensor that shows up as bad on your VIC there's a great thread on here about troubleshooting it. phild328 started it. Probably a bad solder joint on the VIC display.

Good Luck!!
i dont think the VIC has a sensor for trans fluid level, its almost impossible to measure electronically.

newfies on the right track though.

whats the DTC? when the CEL is on?
__________________
98 Deep Slate Niner- 6''s on 35's ---11 F150 Platinum Pearl White- Modded Tiny V6 with Two Turbos. ---93 Black 5.2 limited- Slowly dying in my Parents Driveway
ZJ5point2GCL is offline   Reply With Quote
Unread 05-14-2013, 11:33 AM   #8
Goliath27
Registered User
1996 ZJ 
 
Join Date: Sep 2010
Location: Cleveland
Posts: 67
Not to open an old thread again but don't want to start a new one. Has this ever been fixed?

I'm having the same issues now. 96ZJ, 4.0 - 1-2-3 are fine but it wont shift out of 3. I think if I get to a high enough speed it started to shift or maybe slip, hard to tell.

I changed the TPS thinking that was the problem and nothing changed, so now I'm here.

Trans fluid is good, and I just had it serviced not too long ago at the dealership.

edit: I also recalled having a couple of codes -

P0720 (M) Low Output Spd Sensor RPM Above
15 mph
Output shaft speed is less than 60 rpm with vehicle speed
above 15 mph (4-speed auto. trans. only).

P0740 (M) Torq Con Clu, No RPM Drop at
Lockup
Relationship between engine and vehicle speeds
indicated failure of torque convertor clutch lock-up system
(TCC/PTU solenoid)


but received conflicting answers about them. When I cleaned the IAC it stopped giving me the problems and then it just went to crap.
Goliath27 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads
  • 46re Tutorial - ZJ Grand Cherokee Forum (117 replies)
  • 46re - ZJ Grand Cherokee Forum (3 replies)
  • 46re rebuild - ZJ Grand Cherokee Forum (3 replies)
  • 46re in a 5.2 - ZJ Grand Cherokee Forum (4 replies)
  • 46re? - ZJ Grand Cherokee Forum (4 replies)





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.