Lower clock keeps turning off / resetting itself .. ?? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Lower clock keeps turning off / resetting itself .. ??

Rough Country Jeep Suspension Deals at Rockridge 4WD!Engo winches available at www.rockridge4wd.com! Free shippRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 10-11-2006, 06:08 AM   #1
lawdogg
Registered User
2002 WJ 
 
Join Date: Dec 2004
Location: Charlotte, VT
Posts: 259
Lower clock keeps turning off / resetting itself .. ??

I looked through the FAQ and didn't see anything about it so maybe it's an uncommon thing. My lower info display screen only turns on intermittently and when it does, it always isn't the right date and it sits there and flashes.

Also, sometimes the rear wheels are blank (like how it fills them in to tell you 2WD/4WD?) ... well, it'll go away as if I was in no-wheel-drive. Is this bad?

I'm assuming a faulty connection, maybe a bad ground. But is it something more serious?

__________________
2002 WJ 4.0 - [COLOR="Blue"]Blue[/COLOR] Jeep Club #255 (totalled by drunk driver)
1994 3000GT VR-4 (11.8 @ 116, 17psi, pump gas & street tires)
lawdogg is offline   Reply With Quote
Unread 10-11-2006, 08:02 AM   #2
ArloGuthroJeep
Mr. Hyde!
 
ArloGuthroJeep's Avatar
2004 WJ 
 
Join Date: Mar 2005
Location: Boulder, CO
Posts: 23,082
A lot of times if the clock keeps resetting itself the battery is near the end of its life.
__________________
'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline   Reply With Quote
Unread 10-11-2006, 09:15 AM   #3
lawdogg
Registered User
2002 WJ 
 
Join Date: Dec 2004
Location: Charlotte, VT
Posts: 259
Quote:
Originally Posted by ArloGuthroJeep
A lot of times if the clock keeps resetting itself the battery is near the end of its life.
Huh, battery is relatively new. I'll have to whip out the multimeter when I get off work.

So this hasn't happened to anyone else?
__________________
2002 WJ 4.0 - [COLOR="Blue"]Blue[/COLOR] Jeep Club #255 (totalled by drunk driver)
1994 3000GT VR-4 (11.8 @ 116, 17psi, pump gas & street tires)
lawdogg is offline   Reply With Quote
Unread 10-11-2006, 09:25 AM   #4
ArloGuthroJeep
Mr. Hyde!
 
ArloGuthroJeep's Avatar
2004 WJ 
 
Join Date: Mar 2005
Location: Boulder, CO
Posts: 23,082
I did a search in the VIC (Vehicle Information Center) for something else yesterday and came across a lot of posts about low batteries and the clock resetting. Not saying that is what is wrong for sure with yours, just what others have experienced. You could have a bad gound, corodded battery terminals, or a loose connection etc...
__________________
'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline   Reply With Quote
Unread 10-11-2006, 09:43 AM   #5
lawdogg
Registered User
2002 WJ 
 
Join Date: Dec 2004
Location: Charlotte, VT
Posts: 259
Quote:
Originally Posted by ArloGuthroJeep
I did a search in the VIC (Vehicle Information Center) for something else yesterday and came across a lot of posts about low batteries and the clock resetting. Not saying that is what is wrong for sure with yours, just what others have experienced. You could have a bad gound, corodded battery terminals, or a loose connection etc...
Yeah it would make sense but the radio clock is fine.

I think it's a problem with that lower display. It turns off randomly (like the whole thing ... just black) and if I smack it it'll turn on sometimes.
__________________
2002 WJ 4.0 - [COLOR="Blue"]Blue[/COLOR] Jeep Club #255 (totalled by drunk driver)
1994 3000GT VR-4 (11.8 @ 116, 17psi, pump gas & street tires)
lawdogg is offline   Reply With Quote
Unread 10-11-2006, 05:11 PM   #6
platinum5.9
Web Wheeler
 
platinum5.9's Avatar
2003 WJ 
 
Join Date: May 2006
Location: Olean, New York
Posts: 1,858
I am having the same exact problem with my 95 ZJ, sometimes it will stay off for a couple days, then I get in and it will be back on, but flashing the wrong time. I will set it because the flashing annoys me and then be on my way, and after a while I will look down and it will be black, completely off. Also mine was doing the same exact thing with the tires not lighting up too. I am assuming maybe the VIC itself is bad, but please let me know what you figure out and I will do the same, its very frustrating. Thanks!
platinum5.9 is offline   Reply With Quote
Unread 10-11-2006, 05:48 PM   #7
user jeep
Registered User
 
Join Date: Aug 2006
Location: IL
Posts: 372
i would start by removing the VIC and checking the connections, it really doesnt take that long
__________________
[B]ZJ[/B] - 1995 [B]Jeep Grand Cherokee[/B]
user jeep is offline   Reply With Quote
Unread 10-12-2006, 05:46 AM   #8
lawdogg
Registered User
2002 WJ 
 
Join Date: Dec 2004
Location: Charlotte, VT
Posts: 259
Alright I'll check that out. Where is it in the Jeep?
__________________
2002 WJ 4.0 - [COLOR="Blue"]Blue[/COLOR] Jeep Club #255 (totalled by drunk driver)
1994 3000GT VR-4 (11.8 @ 116, 17psi, pump gas & street tires)
lawdogg is offline   Reply With Quote
Unread 10-16-2006, 12:13 AM   #9
Dempster_Runner
Registered User
 
Join Date: Oct 2006
Location: Yukon Canada
Posts: 2
Try checking the fuses. My 93 Grand was doing that, changed a fuse and its good to go now.
Dempster_Runner is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.