low idle, backfiring and stalling - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 03-18-2014, 12:39 PM Thread Starter
SS1013
Registered User
1997  
 
Join Date: Mar 2014
Location: St Paris
Posts: 1
low idle, backfiring and stalling

I have a 1997 Jeep Grand Cherokee Laredo 4WD with the 5.2 and been having problems with it. Last year my coil went bad and replaced it and ever since i have been having low idle, backfiring and at time even stalling. I have replaced the plugs and wires, replaced the distributor. I don't know what else to do. Can someone help me?

SS1013 is offline  
Reply

Tags
backfiring , stalling , zj

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome