low coolant message - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 01-01-2007, 12:23 PM Thread Starter
RFisher
Registered User
 
Join Date: Feb 2006
Posts: 335
low coolant message

2000 Jeep Grand Cherokee 4.7 V8 engine.

I started engine and got this message "Low Coolant Level". Added coolant to bottle but message did not disappear until after I stopped engine and later came back to restart.

I want to make sure something is not wrong, so drove vehicle for 15 minutes and temp is 200 on gauge, stopped and inspected bottle is still full. Upper hose is hot but I can hold it, radiator cap on opposite side of radiator is cold. Lower hose is cold also and metal part attached to engine is only luke warm. Seems to be not flowing hot coolant from upper hose through the radiator. I ran engine idle for additional 5 minutes idle and temp is 200 on gauge still, and hoses feel the same, and radiator cap is same.

Last month I had the coolant flushed and dealer recalled the electric fan to replace it.

Can someone tell me does this sound normal? I am concerned because apparently I lossed coolant out of overflow bottle, it was empty.

RFisher is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-01-2007, 01:30 PM
1star2
Registered User
 
Join Date: Nov 2005
Posts: 38
I had this same problem on my '02 and it turned out to be the water pump was bad. Might want to check that.
1star2 is offline  
post #3 of 5 Old 01-01-2007, 02:05 PM Thread Starter
RFisher
Registered User
 
Join Date: Feb 2006
Posts: 335
water pump

How can i check water pump?

Also, i did some research on here and think that the T-stat is on lower hose. If that is correct it would seem the temp is not hot enough for T-stat to open. I touch the metal housing around lower hose and it is barely warm. Why after 20 mins of running it is barely warm I do not understand.
RFisher is offline  
post #4 of 5 Old 01-01-2007, 04:18 PM
JeepZJ94
Registered User
1994 ZJ 
 
Join Date: Nov 2006
Location: Michigan
Posts: 117
To check the water pump you could take the serpentine belt off and try to wiggle the shaft or do what i do with parts and just replace them cause sooner or later it will need to be replaced. I'm not really sure if you can check the water pump that way but i think that is one way.

Why dont Money Grow On Jeeps?

1994 Jeep ZJ. 5.2L Engine, 3.5" Lift. 15x7 Steel Wheels w/BFG AT's, Push bar with 6" lights. Factory tow package. Bigger tires to come and much more.
RnR 4x4 Club
JeepZJ94 is offline  
post #5 of 5 Old 01-02-2007, 01:19 PM Thread Starter
RFisher
Registered User
 
Join Date: Feb 2006
Posts: 335
thermostat

seems to me if housing around thermostat is not hot, then coolant will not be able to flow anyway. Thermostat is in the lower hose correct? If so, how long does it take for it to get hot enough to open? Or, is it normal for lower hose assy to be only barely warm to touch. This is my case even when temp gauge is at normal for 10 minutes.
RFisher is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Low coolant message jgclorado ZJ Grand Cherokee Forum 4 01-03-2010 01:01 PM
Replace water pump, now getting low coolant message ZeJokee ZJ Grand Cherokee Forum 2 10-10-2009 02:16 PM
coolant low message keeps popping up bricktop ZJ Grand Cherokee Forum 3 01-18-2007 11:41 AM
Message: Coolant Sensonr Bad.....? Big Red 96 ZJ Grand Cherokee Forum 2 10-03-2005 08:51 PM
What does this message mean?? papa ZJ Grand Cherokee Forum 1 05-26-2004 06:57 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome