Just got back and AC shot - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Just got back and AC shot

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 08-22-2009, 01:24 PM   #1
crazymjb
Registered User
1998 ZJ 
 
Join Date: Apr 2009
Location: somewhere
Posts: 207
Just got back and AC shot

Well, I went away for my 2 weeks annual training with the Marine Corps and I got back and was thrilled to find my Jeep started up perfectly. The AC, which blew cold as ice 2 weeks ago no longer works. I thought I must have had a freon leak since the lines weren't getting cold (so not a blend door problem). However, upon looking at it closer I noticed the compressor wasn't going on.

I tried swapping over the relay and that didn't solve it. However, the relay does click when inserted into the socket, so I don't think it is the climate control unit.

Next up I figured the clutch must be shot, however if I remove the relay and insert it one out of 5 times the clutch will engage for a second or so then disengage. So... anything I should be checking? There are only a few hot days left this summer but I am going on a short trip next week and would really love to have AC.

Edit: Am going to recheck all fuses and Low Pressure switch as per what I read in some other threads and report back

Thanks,

Mike

crazymjb is offline   Reply With Quote
Unread 08-22-2009, 01:41 PM   #2
Turbonut
Registered User
 
Join Date: Nov 2004
Posts: 1,828
Jump the pressure switch to see if the compressor engages. If the compressor energizes and it's low on gas, the oil won't circulate, so don't let it run too long. Get a set of gauges and put on the system to be certain.
Turbonut is offline   Reply With Quote
Unread 08-22-2009, 04:40 PM   #3
thegrand
Registered User
1983 CJ7 
 
Join Date: Aug 2009
Location: cocoa beach fl
Posts: 127
just take the doors off like i did...just kidding hope you have better luck then i did my berring preatty much expluded and took the belt with it if you dont figure it out carquest has a belt that you can run under the compressor on the 5.2 model i can give you the part number if you want
__________________
83 cj7 with a 79 cj5 304 v8 2.5 inch suspension 31 10.50 15 and soa coming soon
96 grand cherokee 5.2 318 stock on 33 with a custom snorkle built not bought #116
thegrand is offline   Reply With Quote
Unread 08-22-2009, 05:19 PM   #4
WiCkeDuDe
Web Wheeler
 
WiCkeDuDe's Avatar
2002 WJ 
 
Join Date: Dec 2007
Location: Utah
Posts: 3,091
x2. Check your pressure to see if all the refridgerant has leaked out. If its too low the compressor will not engage. I would start there but it would seem that is what has happened if it worked 2 weeks ago.
WiCkeDuDe is offline   Reply With Quote
Unread 08-23-2009, 08:14 AM   #5
crazymjb
Registered User
1998 ZJ 
 
Join Date: Apr 2009
Location: somewhere
Posts: 207
Added refrigerant and it is good to go for now. Thanks for the help. Hopefully its working fine in 2 weeks.

Mike
crazymjb is offline   Reply With Quote
Unread 08-23-2009, 10:17 AM   #6
WiCkeDuDe
Web Wheeler
 
WiCkeDuDe's Avatar
2002 WJ 
 
Join Date: Dec 2007
Location: Utah
Posts: 3,091
It will not be. Its got a good sized leak to completely discharge the system in 2 weeks. You need to get the leak fixed.
WiCkeDuDe is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.