JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   Jeep grand Cherokee Laredo (http://www.jeepforum.com/forum/f13/jeep-grand-cherokee-laredo-1551378/)

jws123 07-20-2013 12:53 PM

Jeep grand Cherokee Laredo
 
I have a 1997 Jeep grand Cherokee Laredo it randomly stalls when driving it runs good then it will randomly just shut off i have replaced the Fuel pump,Coil and rotor pickup, new plugs, wires. what else can it be?

mig1289 07-20-2013 01:08 PM

http://www.jeepforum.com/forum/f13/1...talls-1407423/

jws123 07-20-2013 02:22 PM

4wd and i went threw that list already only thing i can think of is the computer but i see peopel that say they replaced it and it still does the same thing?

mig1289 07-20-2013 02:43 PM

You clean the iac sensor and the cps as well?

dellis 07-20-2013 02:49 PM

It can be a lot of things.
  • Most commonly, it could be the PCM or the CKPS.
  • It could be a component that causing a random short on your 12V supply (CMPS, O2 Heaters, or Injectors), or your 5V supply (MAP, TPS, or CMPS).
  • It could be a wire or a connector not making proper connection, or a shorting situation.
  • It could be a problem with the Fuel Pump or ASD relay, or their contacts in the PDC.
  • In a few rare cases, it could be due to the spark plugs installed or a problem with vacuum created in your tank (EVAP/gas cap) ... there is also a story of a binding torque converter that caused stalls.

If you are interested in testing, I can give you a diagnostic tree. Also, do you encounter no-starts from time to time?

jws123 07-20-2013 04:30 PM

it starts right up ever time runs great then randomly dies when driving. sometimes it does not even do it it is intermittent but when it happens it stalls 3 times in a row.

dellis 07-20-2013 05:45 PM

1. Have you put an OBDII scanner on the Jeep to see if any DTCs are stored?
2. Is the engine always hot when it happens, or does it happen sometimes when cold?
3. After the "3 times in a row", does it then run smoothly for the rest of your day's driving?
4. When it stalls, if you were to go back to your gas tank and open up the cap, would you get a tremendous "whoosh"?

jws123 07-20-2013 07:38 PM

1 yes i had it scanned they said it was the coil changed it still had the problem
2 it happens randomly but most of the time like 10-20 mins into the ride
3 after the 3 times it runs perfect sometimes for the rest of the day.
4 never tried that but what would that mean if it does?

dellis 07-20-2013 09:56 PM

Quote:

Originally Posted by jws123 (Post 15699754)
3 after the 3 times it runs perfect sometimes for the rest of the day.
4 never tried that but what would that mean if it does?

The "3 times" after 10-20 minutes is odd, and seems to indicate that something resets on the third attempt. The "swoosh" would indicate that you have a vacuum developing on your gas tank, likely because your gas cap is not venting or there is a problem in the EVAP system.

jws123 07-21-2013 05:58 PM

Fixed put zip ties around the pcm plugs so they dont move.

JasonStebbins 07-21-2013 06:08 PM

Edit - He fixed it already.


The time now is 04:24 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.