post #1 of Old 06-11-2006, 01:44 PM Thread Starter
mustang 1
Registered User
 
Join Date: Aug 2005
Location: charleston sc
Posts: 24
instrument cluster

after replacing the fuel pump, computer, pickup, crankshaft sensor, afew relays and fuses
the instrument cluster won't work - the lights work on it , but nothing else, the fuel light stays on also
I swapped the cluster with the backup one that I got, still the same, nothing works


96 zj 4.0 145k+

mustang 1 is offline  
post #2 of Old 06-11-2006, 07:02 PM
GreenDean
Registered User
 
GreenDean's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Jersey, Exit 105
Posts: 1,918
sounds like you either left a plug unplugged... or halfway unplugged.
or even you might have bent a pin over in one of the plugs.
check all your plugs and make sure all the terminal pics are nice and straight.
if you do find one bent... a dental pick work great for bending them back.
GreenDean is offline  
post #3 of Old 06-12-2006, 06:26 AM Thread Starter
mustang 1
Registered User
 
Join Date: Aug 2005
Location: charleston sc
Posts: 24
the cluster went out before I began replacing all the stuff. The trouble with the cluster started on a trip about 1 hour into it the cluster went NUTTS, all the needles were peging low or high, then everthing died
mustang 1 is offline  
post #4 of Old 01-30-2012, 02:47 PM
norcalzj
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: Sacramento
Posts: 70
I'm having the same problem , did you figure out what it was ??
norcalzj is offline  
post #5 of Old 01-30-2012, 03:02 PM
Muncie4sp
Registered User
1995 ZJ 
 
Join Date: Aug 2010
Location: austin tx
Posts: 68
this thread was started in 2006!
Muncie4sp is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
WJ instrument cluster ruinz ZJ Grand Cherokee Forum 8 03-31-2016 03:46 PM
Nee help re: Instrument Cluster 04 WJ LongueCarabine ZJ Grand Cherokee Forum 0 11-28-2008 10:46 AM
instrument cluster asleep! Kymware ZJ Grand Cherokee Forum 2 07-11-2008 05:16 AM
Instrument Cluster rollin2447 ZJ Grand Cherokee Forum 2 08-18-2005 03:52 PM
99 instrument cluster sorrento ZJ Grand Cherokee Forum 0 07-01-2005 05:31 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome