information display - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 06-19-2003, 03:11 AM Thread Starter
PaulV
Registered User
 
Join Date: Apr 2003
Posts: 3
information display

I have a 1996 Grand Cherokee. The information display in the center console is displaying 2 errors. One error is for the rear brake lights. I have checked, and both are working, along with the turn signals and running lights. What should I look for?
Also, the display is saying the coolant sensor is bad. I am not having any overheating.
Where is the coolant sensor located? And how do I check it to see if it is bad?
Anything else I should look for?

Thanks,
Paul

PaulV is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-19-2003, 06:07 AM
ALS59LTD
Registered User
 
ALS59LTD's Avatar
2003 TJ Wrangler 
 
Join Date: Aug 2002
Location: NY
Posts: 79
When I first got my jeep it said there was a problem with the brake lights, yet they all worked. I just replaced them all (backup, turn, brake, and highmount brake) and that solved the problem. I think as the bulbs get older the resistence changes, which is how it senses an out light. not sure about that coolant sensor....

-Alex
http://www.jeepforum.com/forum/f22/turbocharged-2-4l-jeep-tj-me-too-2255329/
ALS59LTD is offline  
post #3 of 4 Old 06-19-2003, 06:12 AM
jeepme79
Registered User
1998 ZJ 
 
Join Date: Jun 2003
Location: Mt Vernon, IA
Posts: 57
Check the brake lights at the top of the window. I had the same problem when I bought mine.

2003 Dodge CTD Quad Cab 4x4, 320k miles and counting
Former Jeeps:
98 ZJ Limited, 5.2L, NP242, Jet Stage II (worthless), K&N, 245/75-16 BFG KO's
89 XJ, stock
79 CJ7 - Options included ripped soft top, leaky 4.2L (5qts/week), ripped seats, 33" tires, bondo & gray primer
jeepme79 is offline  
post #4 of 4 Old 06-19-2003, 09:28 AM
anthonyh75
Registered User
 
Join Date: Apr 2003
Location: Alexandria, VA
Posts: 50
I think the coolant sensor is in your overflow resivoir. It will only tell you if your coolant is low not the condition of it.

1998 5.9L Limited, 99 TL 1000s, 1995 Stingray 586zp
anthonyh75 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Need Display Help!! pattydaddy ZJ Grand Cherokee Forum 7 09-11-2008 09:53 PM
Display pattydaddy ZJ Grand Cherokee Forum 0 09-09-2008 10:02 PM
No VIC display at all TripleRLtd ZJ Grand Cherokee Forum 11 07-08-2008 03:39 PM
RB1 Display TJTony ZJ Grand Cherokee Forum 3 01-09-2008 11:30 PM
Information display after stereo install? Phrozin ZJ Grand Cherokee Forum 3 03-26-2004 02:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome